2 Replies Latest reply: Mar 30, 2012 10:27 PM by Justthis
Mr. Teej Level 1 Level 1 (0 points)

Recently my phone began using my email address to send all my test through imessage rathe than my phone number. So if I send a tesxt to my son my wife recieves the text message as an e mail.  How can I fix this?

  • modular747 Level 6 Level 6 (18,235 points)

    The email address is only used when sending texts via iMessage - you can disable it by disabling iMessage and sending only via SMS: 


    Settings > Messages > iMessage > OFF


    If you want iMessage enabled, you can disable the email address(s) associated with it by:


    Settings > Messages > Receive At > Email > Remove This Email.   If the email address is your Apple ID, the "Remove" will be grayed out - you have to tap the Apple ID on the previous settings page and sign out.

  • Justthis Level 1 Level 1 (0 points)

    This didn't work for me (the "delete this email" button did not respond at all)  However I did end up finding the solution. You have to un-associate your Apple ID with iMessage:


    Settings>Messages>Receive at 2 places.>

    Click on your Apple ID>Sign out


    You don't have to be signed in with your Apple ID to use iMessage as long as your on an IPhone with a phone#. On an IPad/ipod without a cell number, you have to use your Apple ID.  Using your Apple ID on either (in iMessage) automatically sets you up to use whatever email is tied to your Apple ID for iMessaging -- even though you didn't tell it to do anything of the sort.