9 Replies Latest reply: Jul 11, 2014 7:08 AM by mrfuzzy1502
Barrus31 Level 1 (0 points)

Hello,

 

My iPhone 4s will not connect to my home wireless network.  The phone recognizes the network, but after i put in the password, the grey loading circle just spins endlessly on my chosen network without connecting.  I've tried restting the network setting, restting the router, and checking for updates.

 

Can someone please help?

 

Thanks in advance.


iPhone 4S
  • randers4 Level 9 (62,715 points)

    If you haven't already, power-cycle your wireless router (unplug for 30 seconds, plug back in).  This will reset a potentially hung DHCP service.  Also, be sure you router is broadcasting 2.4 GHz, not just 5GHz.  Here's a longer list of troubleshooting steps to work through: http://support.apple.com/kb/TS1398.  (Be sure to also look at the ones under Additional Information at the bottom.)

  • Barrus31 Level 1 (0 points)

    Thanks for the reply Randers.

     

    my router is the Actiontec V1000H, which  according to a goodle search is 2.4GHz.  Oddly i was able to connect easily to an unsecured wireless network in my neighborhood, and my sister was able to connect her iPhone 4 to my home network. 

     

    I'm at my wits end trying to figure this out....

  • randers4 Level 9 (62,715 points)

    Look through the other troubleshooting steps on the article linked above, including:

    • Power you phone off (hold on/off until you see the off slider, slide to turn off), then back on
    • Try resetting network settings on your phone (Settings>General>Reset>Reset Network Settings)
    • Make sure you are using the latest firmware for your wireless router (http://www.actiontec.com/support/product_details.php?pid=191&typ=all)
    • If you are using WEP security for your wireless router, consider changing to WPA or WPA2
    • Disable 40MHz on the 2.4GHz settings on your wireless router

    You can also look through the recommended settings for your wireless router here: http://support.apple.com/kb/HT4199.

  • Barrus31 Level 1 (0 points)

    Thanks again, Randers for taking the time to help.  I've tried powering off/on on the phone, resetting network settings, resetting my router, checking firmware for the router (its up-to-date - at least the version number is higher on my router than is available from the Actiontec site).

     

    below are some screenshots of my router's settings.  I read through the list of preferred setting you linked to, and I *think* my router is complying;

     

    router settings.png

     

    router seetings -adv.png

  • randers4 Level 9 (62,715 points)

    Try changing your Encryption Type from AES to WPA/WPA2 on the Basic tab.  (Use WPA Personal (TKIP) if that isn't available.)

  • Barrus31 Level 1 (0 points)

    Ok, i'll give that a go.  I also just applied an OD update to 5.1 (I just figured out i could do it through itunes).

  • Barrus31 Level 1 (0 points)

    Great, now my wireless network doesnt show up as an available network.  Shoot me.

  • randers4 Level 9 (62,715 points)

    If this happened due to changing the router settings, go back and change them back.  If this happened due to the 5.1 iOS update, try turning wifi off, then back on on your phone.  If that doesn't work, try resetting your phone (hold the on/off and home buttons until your see the Apple logo, ignoring the off slider that appears first, then release).  If that doesn't work, try power-cycling your router again.

  • mrfuzzy1502 Level 1 (0 points)

    uhh, i have the same problem, exept i have an iphone 4, scince it has no service, i just use it as an ipod. so can you help me? ive tried reseting network settings, turning the ipod off and unplugging the router for 30 seconds.