13 Replies Latest reply: Mar 19, 2012 2:35 PM by BDAqua
Pundamilia Level 1 (0 points)

Setting up an old G4 as a game machine for retired senior (90+). Set up a new user under Sys Prefs, but when I try to log in to test, pw that I just created is not accepted. Also, would like to set "Login Options" to "Automatically log in", but when I pick that User from the pulldown menu, I get prompted for the pw. I put in the pw I just created and get "You did not enter the correct password for your user account". I know the pw is right because I just created the account. What is going on? I cleaned up this machine a bit. Could I have inadvertently deleted some critical file. I cannot create ANY new user accounts and have their pws accepted even though I am the administrator.





PowerMac, Mac OS X (10.4.11)
  • BDAqua Level 10 (122,227 points)

    Also, would like to set "Login Options" to "Automatically log in", but when I pick that User from the pulldown menu, I get prompted for the pw. I put in the pw I just created and get "You did not enter the correct password for your user account".

    Can you set that to auto login tour original account?

  • Pundamilia Level 1 (0 points)

    Yes, I can and that works fine.

  • BDAqua Level 10 (122,227 points)

    Could be many things, we should start with this...


    "Try Disk Utility


    1. Insert the Mac OS X Install disc, then restart the computer while holding the C key.

    2. When your computer finishes starting up from the disc, choose Disk Utility from the Installer menu at top of the screen. (In Mac OS X 10.4 or later, you must select your language first.)

    *Important: Do not click Continue in the first screen of the Installer. If you do, you must restart from the disc again to access Disk Utility.*

    3. Click the First Aid tab.

    4. Select your Mac OS X volume.

    5. Click Repair Disk, (not Repair Permissions). Disk Utility checks and repairs the disk."




    Then try a Safe Boot, (holding Shift key down at bootup), run Disk Utility in Applications>Utilities, then highlight your drive, click on Repair Permissions, reboot when it completes.


    (Safe boot may stay on the gray radian for a long time, let it go, it's trying to repair the Hard Drive.)


    If perchance you can't find your install Disc, at least try it from the Safe Boot part onward.

  • Pundamilia Level 1 (0 points)

    Thanks again for your help.


    I followed your instructions. After the Repair Disk from OS X Tiger, response was no disk errors in green text. Did the safe boot and Repair Permissions from Utilities and response was:


    Group differs on ./private/etc/authorization, should be 80 group is 0

    Owner and group corrected on  ./private/etc/authorization

    Permissions corrected on  ./private/etc/authorization


    Pernission Repair Complete

    The privileges have been verified or repaired on the selected volume.


    With keen anticipation, I rebooted and tried again to log in with one of the newly created user accounts, but got exactly the same result. I went in and re-set the password for one of the accounts, logged off and tried again. Same thing, password was not accepted.


    Earlier I had tried to Repair Permissions from the Utilities/Disk Utility program and had received the following:

    Group differs on  ./private/etc/authorization should be 80 group is 0


    Permissions verification is complete.


    Permissions have been verified or repaired on the selected volume.


    So it would appear that if the repairs ARE being made, they don't last or are being re-corrupted. Does that make any sense?



  • BDAqua Level 10 (122,227 points)

    Perhaps, but most repeating Permissions fixes can be ignored since usually it's resetting it two or more times from past updates... but not always of course, and this one seems to be quite relevant!?


    You don't have another drive to install to & boot from do you?


    In Finder goto /private/etc/


    Do a Get Info on authorization & see if it says Owner= system R&W, Group= wheel RO, Others RO

  • Pundamilia Level 1 (0 points)

    Thanks again for your help in trying to track this down. 


    I do have another drive that I could possibly install to and boot from. Do you mean to do a complete Tiger install from scratch (Tiger was an update from OS X 10.1)? My other alternative is to give them a PC (which is looking like a much simpler solution at this point).  ;-(


    Get Info on /private/etc/authorization shows Owner = system R&W, Group=admin RO, Others RO.


    There is also a file called authorization.cac in this directory and its permissions are:


    Owner = system R&W, Group=admin RO, Others No Access


    I don't know if this other file is relevant or not.

  • BDAqua Level 10 (122,227 points)

    Those permissions seem right, but is your Tiger Install Disc the Black Retail one, or an upgrade Disc requiring 10.3 to be already installed.


    We have some corruption, & may be able to track it down, but a fresah Install on another drive, or if you can afford it an Erase & install on this one would likely be faster.

  • Pundamilia Level 1 (0 points)

    Tiger install disk is Black (Mac OS X Tiger Includes Xcode 2 Install DVD).


    I don't have too many options for IDE drives. Will the OS X 10.4 fit on a 4 GB (unformatted) drive? There won't be much data stored on it by its intended user.  If not, I may be able to get my hands on a larger IDE drive.


    This may take a while as I am leaving town for 10 days on Tuesday. I was hoping to get this sorted out before I left because I thought it would be pretty simple and straightforward. Famous last words.



  • BDAqua Level 10 (122,227 points)

    Tiger Requirements...

    To use Mac OS X 10.4 Tiger, your Macintosh needs:

        * A PowerPC G3, G4, or G5 processor

        * Built-in FireWire

        * At least 256 MB of RAM (I recommend 1GB minimum)

        * DVD drive (DVD-ROM), Combo (CD-RW/DVD-ROM) or SuperDrive (DVD-R) for installation

        * At least 3 GB of free disk space; 4 GB if you install the XCode 2 Developer Tools  (I recommend 20GB minimum)


    You can probably reduce the 3GB a bit by eliminating some Apps, LKanguages, & printer Drivers at the Cusmoxe Install step.

  • Pundamilia Level 1 (0 points)

    Thanks. I will give it a shot tomorrow with the 4 GB drive. In the meantime I have the word out with friends for a slightly bigger IDE drive.


    I really appreciate the time and your knowledge that you have spent on this.



  • BDAqua Level 10 (122,227 points)

    Great to hear, hope we can do it.


    Oh, what is the reason we can't erase the one that's in it now? What size is it?

  • Pundamilia Level 1 (0 points)

    Found a 60 GB backup dive, did an Erase and Install and everything works fine. I was hoping to not have to do that, but I guess you were right - in the end it was the quickest solution. I had forgotten how good the Apple install is at preserving your old information. I could have kept all the old users, but due to the problems I was having, I only kept my own admin account, re-created the other user and everything sems to be great.


    I really appreciate your advice and will try to pass on the favour to someone else in need of assistance.



  • BDAqua Level 10 (122,227 points)

    Great news, & great way to make your world a better place to live, pass it on, thanks!