Previous 1 2 Next 26 Replies Latest reply: Oct 21, 2013 6:30 PM by Trismegister
Edm Dude Level 1 Level 1

I have found many people having the same problem, no solution yet. I have the latest version of everything.


iCal handles invitees who are users perfectly, but inviting an external user does not work.


iCal give me an error:

You entered an invitee that wasn’t recognized by the server.   Invitee “” in “Meeting Example” was not recognized by the server.


The iCal Server Log shows:

2012-03-19 02:06:11-0600 [-] [caldav-0]  [PooledMemCacheProtocol,client] [twistedcaldav.scheduling.scheduler#error] Unknown calendar user address:

2012-03-19 02:06:11-0600 [-] [caldav-0]  [PooledMemCacheProtocol,client] [twistedcaldav.scheduling.scheduler.ScheduleResponseQueue#error] Error during PUT for Unknown recipient


In Server > iCal the "Allow invitations using email address" option is selected.   The IMAP and SMTP server information is set.   


Email is done with a 3rd party email host.   The IMAP and SMTP is set properly to use an email account on this 3rd party host.


Any ideas how to get this working??

  • Edm Dude Level 1 Level 1

    So everyone's iCal Server works except for mine?  


    I installed the server clean and it's right out of the box for the most part.   I do not understand why mine is not working....

  • sweboi Level 1 Level 1

    Not sure this is the problem but I had a similar issue and changing the email address under "allow invitations using email addresses" to an address that used the FQDN as supposed to hostname.FQDN sorted my problem.

  • Edm Dude Level 1 Level 1

    My server is not a mail server.   I have entered an email account hosted my a third party.  Therefore I do not believe this is my issue.

  • Edm Dude Level 1 Level 1

    Other people actually have this working then??

  • MattMacPro Level 1 Level 1



    I have it sort of working


    There are two things you need to know about iCal server under 10.7.3.


    First - the email server you are sending through MUST support plus addressing. From the looks of your logs - your mail server does not support plus addressing.


    Gmail supports plus addressing. Try setting up an account with Gmail and sending your invite through that.


    Second - the server will only send when SSL and username and password is configured. Seems to be a bug in the GUI  - you can set it to anything you like to send email (SMTP) but it will only work when you configure it to send using SSL and a valid username and password.


    I have iCal Server 10.7.3 sending emails to an external user. That bit seems to be working fine. My current problem is the reply comes back to the iCal server - but the original user is not notified that the invite has been acepted or declined.

    Internal users within the company work fine for invites.

    I'm still troubleshooting it .....

  • RoseValley Level 1 Level 1

    I have setup a Gmail account for the ical server to use and yet I can still not get it to work. Can anyone tell me what the settings on the should be for using a gmail account? Gmail wants password authentication and that is not one of the choices in the server app. Everything else seems to work until I activate the email invites and then it comes falling down.


    HELP!! :-)




  • MattMacPro Level 1 Level 1

    Hi Kevin


    First - get the new Gmail account you have setup working in Apple Mail. Once you have done that - you will have all the settings needed (and tested) to work with iCal server.

  • RoseValley Level 1 Level 1

    Hi Matt,


    I did that and in Apple Mail it is using [Password] authentication and that is NOT an option in the server setup. There is none, plain, login, and a few more. But not password. ANy clue what option I should choose?




  • MattMacPro Level 1 Level 1

    Hi Kevin


    Not sure what you mean by 'password authentication' - all email accounts need a username and password.


    In the first screen - enter your gmail address -


    Mail server type:IMAP

    Imcoming -

    port 993 tick Yes use SSL

    Supply username (

    Supply Password


    Outgoing -

    port 465 tick Yes use SSL

    Auth Type - Login

    Supply username (

    Supply Password


    Again - make sure this all work under Apple mail before configuring ical Server.

    More info - A9651007DA8E

  • RoseValley Level 1 Level 1

    Hi Matt,


    I did exactly the steps here. I also had tested the email in the on the server and it works there. But again, when I setup the email for iCal server I get the following error lines in the log and nothing works.


    do server-to-imip request : <twistedcaldav.scheduling.imip.ScheduleViaIMip object at 0x10d622cd0> iMIP VFREEBUSY REQUESTs not supported.

    2012-06-20 08:32:09-0400 [-] [caldav-11]  [PooledMemCacheProtocol,client] [twistedcaldav.scheduling.scheduler.ScheduleResponseQueue#error] Error during POST for iMIP request failed

    2012-06-20 08:38:59-0400 [-] [mailgateway] 2012-06-20 08:38:59-0400 [ESMTPSender,client] SMTP Client retrying server. Retry: 5

    2012-06-20 08:48:59-0400 [-] [mailgateway] 2012-06-20 08:48:59-0400 [ESMTPSender,client] SMTP Client retrying server. Retry: 4


    It continues to try and fail and then messes up my calendar that I used to test this. I am thinking there is something not getting set into the actual config file properly.


    Any suggestions?


    Thanks again,


  • MattMacPro Level 1 Level 1

    Hi Kevin


    Well - you are now at the point I'm at. I am also seeing those POST error - as per your log.


    I'm not seeing the 'SMTP Client retrying server' errors in my logs - so that's different to me. I'm using an internal mail server to sent the invite - so that will differ from your setup. Maybe try the other setting 'plain' for password type.


    Just out of curiosity - do you have the Address Book service running on your server?


    Another thing to try -

    Webmail into the Gmail account as see if there are any email within the IN BOX. All emails should be cleared by iCal server if it's checking the account correctly.

  • RoseValley Level 1 Level 1

    I have got ot laugh. I have tried all the **** settings and get the same thing. I think I might try using the comand line to enter the information as I am starting to think it might be a glitch in the GUI.


    I do have the address book running but have not spent much time on that yet. Doing on thing at a time, For information purposes I am running 3 Xserve machines and 5 Xserve RAID boxes. Two of the machines are dedicated to MDC's and the thrid is my File Server / Wiki / Web / iCal / OD / DNS / CardDAV / iChat.


    I can't do to much playing as this is my file server for 25 users.



  • RoseValley Level 1 Level 1

    OK, I was trying again and when I added an invitee and before I actiually saved the changes, this appeared in the log.


    [twistedcaldav.scheduling.scheduler.ScheduleResponseQueue#error] Error during POST for iMIP request failed


    Hmm, Anyone got any ideas?

  • MattMacPro Level 1 Level 1

    Well - if you don't laugh - you cry ;-)


    I have turn OFF the Address Book service chasing something I saw in the logs. I'll wait and see if that helps in any way.


    I'm getting this in the error log -

    Error during POST for iMIP request failed


    The email reply is in the IN BOX of the gmail account. It should be cleared by iCal - but it's not.

    When I check the actual email account - I can see two emails in there that are replies to invitations.


    If I go to the Server app on the server and go through the process of setting up the email notification for the ical service (just clicking next on each of  the setup windows and leaving the settings unchanged) - the ical server seems to kick in and remember that it needs to check the account. Watching the account the two emails within the email 'Inbox' disappear as iCal server checks the email account.


    This seems to be a bit random. I can go 3-6 days without any emails being 'stuck' in the email account. Go into iCal server settings - run through the notification setup and the account is cleared. It might be that the staff are only inviting external people intermittently - not sure. What I can say is the emails get stuck and are not cleared until I run through the notification setup.



    After some more testing I will probably be giving Appe Support a call and see if they have any ideas.



Previous 1 2 Next