4 Replies Latest reply: Aug 12, 2012 5:28 PM by JScott
jonhammer Level 1 Level 1 (0 points)

has anyone else experienced this issue?

 

The iMac will display the following error message on the screen every day or so (with the host number incresing by 1 digit each time):

 

This computer's local hostname "MacName.local" is already in use on this network.The name has been changed to "MacName-1.local". This continues even after I've reset the name in the System Preferences panel/sharing settings, for example ("MacName-2.local, MacName-3.local, MacName-4.local" etc).

 

Please advise

 

Currently running an Apple iMac

OS 10.6.8

 

*please see attached screenshot for a reference

error.png


iMac, Mac OS X (10.6.8), 2.4 GHz Intel Core 2 Duo/4 GB SDRAM
  • Kevin Kelso Level 1 Level 1 (10 points)

    @jonhammer Having the same problelm with my iMac running Snow Leopard. Has been happening off and on for a few months. There are no other computers on my ApplePort Extreme home network. I do have an iPhone and iPad, and I use an AirPort Express to stream Air Tunes.

     

    Anyone know why this keeps happening?

  • steve626 Level 4 Level 4 (1,475 points)

    (1) Check names of all other devices on the network, including the router, any airport express, iphone, ipad, printers etc. Make sure these all have unique names.

     

    (2) Do you have both wired ethernet as well as wireless active on any of these devices, including the Mac computer? This has been linked to such renaming behavior in the past, apparently the two methods of accessing the internet, if both are active at the same time, may switch off and on and conflict with one another (shouldn't happen, but apparently does sometimes). Solution is to switch one of them off.

     

    (3) The following may be helpful:

    In System Preferences > Network > Airport > Advanced > TCP/IP

    Set "Configure iPv6" from "Automatically" to "Off".

    If you do this, check to make sure that your email and other tools are still working properly. If something goes amiss, change the iPv6 back to what it was.

     

    (4) Go to your router and reset power to it.

     

    (5) Go to your router and check its LAN client table. Make sure that all entries should be there. Investigate any "extra" devices on the network. For instance, if it shows 4 devices, but you know you have only a computer and a printer, investigate what the other two are. Delete them from the list if they really seem to be "ghosts."

  • jonhammer Level 1 Level 1 (0 points)

    Thank you steve626.

     

    I'm in the process of troubleshooting by eliminating the culprits one at a time, and your info is quite helpful. I will move through your steps above (though I know for sure that the ethernet and wireless are both active and could be the issue).

     

    I will update this thread once I have more info.

     

    Thanks again

  • JScott Level 2 Level 2 (220 points)

    Hello, I am having this problem lately also.  After much diggiing, I believe my 27" iMac, which is on a wired ethernet, is getting confused with our Time Capsule.

     

    We thought we fixed it when we cycled our U-Verse modem but now I am ready to try changing the iPv6 configuration.  I am on Mac OS X Lion.  When I choose Settings - Ethernet - Advanced - TCP/IP - Configure iPv6, I don't have an option for Off.  It is defaulting to "Automatically" and the other choices are "Manually" or "Link-local only".  Should I choose "Manually"?

     

    I also think I need to try to clear my LAN client table in my U-Verse modem so that it reassigns new IP Addresses to everything on my network - seems like that might help.

     

    I'd appreciate hearing if someone has really solved this... several threads of discussion out there about this....

     

    thanks