Previous 1 2 3 4 5 6 Next 164 Replies Latest reply: Mar 28, 2016 7:35 AM by CallMeKatie Go to original post
  • artaddict Level 1 Level 1

    Thank you but no thank you... all the methods listed here not only DID NOT fix the problem, (and I did invest 3+ hours) but they made it worse....


    One 15 minute visit to the Apple store and all is well.... next time I will avoid listening/reading to the "know it alls" that don't and go to apple where they are nice, kind, don't make things worse, or make me feel stupid or ungrateful. 


    FYI all of the solutions listed here were not the solution that Apple had... infact it was 3 little steps... no saving files, looking for libraries or any of that...


    So, lesson learned.... just go to apple.

  • freebass Level 1 Level 1

    Hi Pumpkin,

    I have had this problem - my fix was to connect my iphone 5. Then open itunes and then click the "info" tab.

    Where it says Sync Calendars check that  box and then check the "selected calendars" circle and then check every calendar inside the square (i.e. Calendar, Home, Work,). Then hit the Sync TAB at the bottom right of the window.  It worked for me. I think the "all calendars" switch doesn't work - checking all the possibilities and the "selected groups" switch worked for me.

    My iphone 5 and MacBook Pro Calendars now sync perfectly.  NB Without i cloud being activated.


    Good luck.

  • Mom2JK Level 1 Level 1

    Thanks, rorygilmore!  I was having the same problem with my new iPhone 5 (OS 6.0.1) and my MacBook Pro (OS 10.6.8).  I spent several hours at the Genius one could fix the problem.  I came home, found your solution, and it worked!!  Thank you, thank you, thank you!!

  • sympleapp Level 1 Level 1



    It's not going to be over-the-air sync, but at least it's a reliable calendar sync.


    I have an iPhone 5 running iOS 6.0 and an iMac running Mountain Lion 10.7.4


    By turning off calendars in Settings>iCloud on my iPhone, I was successful in transferring events from my iPhone to my iMac (I just used the generic "Calendar" rather than "Home" or "Work" to keep all events on the same calendar). Once done, you'll have to hardwire sync your iPhone and iMac the old-fashioned way. Not convenient because you need your fancy new cord to connect your phone to your computer, but at least the information is transferred.


    PS: Apple, I'm not psyched about buying multiple cables to charge my iPhone (upstairs), sync my iPhone (in the office), and keep it charged on the fly (in the car). Had syncing in fact WORKED via iCloud, I wouldn't be so annoyed. But now, I need to buy at least two new lightening to USB cables to RETAIN the syncing/powering capability I had with the iPhone 4s.

  • cleidson.desouza Level 1 Level 1

    hi guys,


        maybe someone can help me. I tried the suggestions before (steps 1 to 7, although I had to reset my sync history using command line), but it is not working. I mean, I create an event in iCal and it syncs to the iPhone. But, when I create an event in the iPhone it does NOT sync to the iCal. The suggestions had an improvement in my case, since I was having duplicate entries in the iCal, but not anymore.


       I am running Snow Leopard (10.6.8) and iOS 5.1.1. Again, when I create an event in the iPhone it does NOT sync to the iCal.


       Can anyone help me?



  • ascotsgranny Level 1 Level 1

    Same issue here.  Followed these steps but my export file (which I re-imported) was empty because calendar is now blank.  I also have my google calendar on here but it won't sync now.  There were many many files in the Library/Calendar folder so I renamed them all to start with OLD_




    I think I have an icloud account because I had an old mobile me account.  I never used mobile me and don't want icloud.  I have MacBook on OSX 10.6.8 and not excited about paying too upgrade to mountain lion and encounter even more issues.

  • stillsue Level 1 Level 1

    I just upgraded to itunes 11. I have had this calendar synch problem every time I update either the imac OS or itunes. Each time I have successfully implemented rorygilmore's fix (thank you rorygilmore!). Since I recently upgraded the imac to Mountain Lion, I have the 90 days of tech support included with the upgrade purchase, so I called them to see what apple had to offer me (and us). Turns out, it's very close to rorygilmore's fix - at least if you don't use icloud, which I don't. This is what I got - after 2 hours and 3 techs - so I thought I'd share it with y'all:


    Unplug iphone if connected.

    First, back up Contacts by opening Contacts, doing a File -> export -> contacts archive (I just saved to desktop). Quit Contacts.

    Back up Calendar by opening Calendar, doing a File -> export -> calendar archive (I just saved to desktop). Quit Calendar

    Then, use this knowledge base article for your OS:


    Mac OS X: Resetting the SyncServices folder


    Once those steps were followed, I had to connect phone to imac and go back to itunes Info tab under the iphone, and be sure that the synch categories were checked off for calendars, contacts, and bookmarks, and then run a synch. The tech told me I didn't need to check synch mail accounts (it was grayed out). There was no info from apple as to a permanent solution, so I anticipate this is going to happen each time I update. My friend who uses icloud doesn't have this problem, but plenty of people here apparently do even with using icloud.


    Still not happy with apple for not fixing this!


    imac (2009) 10.8.2, itunes 11.0, iphone 4 ios 6.0.1

  • tawiphone Level 1 Level 1

    Ok, I admit that I'm nervous about reseting my sync history. After following the first two steps and clicking "reset sync history," I get a warning that this action would restore to factory settings. Wouldn't that restore everything – not just iCal – to the factory settings? Sorry if this duplcates queries from other nervous users.

  • janis153 Level 1 Level 1

    I'm having the same problem. Running Lion 10.7.5 on my Mac, trying to sync all calendars to my iPhone 5. Only some calendars sync, and only part of the time. I've check and re-checked settings on both, and I'm not sure how I can fix this. I'm wondering if the suggested solutions will work for Lion? I don't want to start deleting folders if that will create more of a headache than I presently am dealing with.

  • janis153 Level 1 Level 1

    Will this work the same way with Mac Lion 10.7.5 and iphone 5? iCloud settings are turned off on my phone, and I would just like to keep it simple and sync  ical on my Mac to my iPhone 5 via cable. Not all calendars are showing up on my iPhone 5 after a sync through iTunes via cable.

  • taneashia Level 1 Level 1

    Thanks Ima29. The solution you wrote fixed my issue w/ my iPad & iPhone calendar syncs not showing up on iCal. Once I dragged the calendar folder to my desktop and reopened iCal, the correct sync'd calendar from the iPad and iPhone immediately appeared.  Thanks again for the simple solution!  I did want to add that I had to be in the finder mode and then hold the "option" key while clicking "go" in order to locate the correct "library" folder.  Additionally, when the new iCal appeared, I deleted the 2 default calendars that appeared. Once that happened, the calendar from the iPad and iPhone appeared, in it's entirety. I ran a few sync tests between the computer and my iPad & iPhone, all syncs went well. Then I trashed the old calendar folder from my desktop. Problem solved. (:  thanks again!


    "Sometimes the calendar folder is corrupt so you have to create a new one.

    Library, calendars, drag your folder to desktop to save a copy in case it dosent work and create a new calendar folder..."

  • patbaldwin Level 1 Level 1

    Thanks for the help rorygilmore!  I have been trying to figure this out and now it works! YAY!!!  Thanks

  • aray1126 Level 1 Level 1

    what did apple do to fix this? can you share?

  • carlosxxx Level 1 Level 1

    Hi rorygilmore, I had a similar problem but with Iphone ical  not sync/updating from mac ical and this has worked out  ( so far!) with your notes. Thank You.

  • cindyruakere Level 1 Level 1

    Thank you so much rorygilmore you have suddenly made my life SO much easier!

Previous 1 2 3 4 5 6 Next