Previous 1 2 Next 21 Replies Latest reply: May 15, 2012 4:15 PM by etresoft
the-big-eye Level 1 Level 1 (0 points)

Hi,

 

After updating from Snow Leopard to Lion TextEdit will not open any Rich Text files.  If preferences are set to open RTF files it will not open a default document.  It just hangs.  If I set TextEdit preferences to open a plain text document, it will open a default .TXT document.  The console displays this when trying to open RTF doc.

 

3/20/12 12:50:48.865 PM TextEdit: *** Assertion failure in -[NSMenu itemAtIndex:], /SourceCache/AppKit/AppKit-1138.32/Menus.subproj/NSMenu.m:850

3/20/12 12:50:48.865 PM TextEdit: Invalid parameter not satisfying: (index >= 0) && (index < [_itemArray count])

3/20/12 12:50:48.868 PM TextEdit: (

          0   CoreFoundation                      0x00007fff8a112fc6 __exceptionPreprocess + 198

          1   libobjc.A.dylib                     0x00007fff90870d5e objc_exception_throw + 43

          2   CoreFoundation                      0x00007fff8a112dfa +[NSException raise:format:arguments:] + 106

          3   Foundation                          0x00007fff870d5743 -[NSAssertionHandler handleFailureInMethod:object:file:lineNumber:description:] + 169

          4   AppKit                              0x00007fff8a67ae13 -[NSMenu itemAtIndex:] + 165

          5   AppKit                              0x00007fff8a82d9d1 -[NSPopUpButtonCell itemAtIndex:] + 46

          6   AppKit                              0x00007fff8a82d99a -[NSPopUpButton itemAtIndex:] + 46

          7   AppKit                              0x00007fff8a8749c3 __-[__NSInspectorBarItemController updateSelectedAttributes]_block_invoke_2 + 156

          8   CoreFoundation                      0x00007fff8a10ad5e __NSArrayEnumerate + 718

          9   AppKit                              0x00007fff8a871f60 -[__NSInspectorBarItemController updateSelectedAttributes] + 5405

          10  AppKit                              0x00007fff8a865aa2 -[NSInspectorBar setVisible:] + 299

          11  AppKit                              0x00007fff8a8656f4 -[NSTextView(NSSharing) setUsesInspectorBar:] + 236

          12  TextEdit                            0x0000000108e18c2b TextEdit + 72747

          13  TextEdit                            0x0000000108e0d17b TextEdit + 24955

          14  TextEdit                            0x0000000108e0ce4a TextEdit + 24138

          15  TextEdit                            0x0000000108e0bafb TextEdit + 19195

          16  AppKit                              0x00007fff8a84f73b -[NSWindowController _windowDidLoad] + 566

          17  AppKit                              0x00007fff8a846dfd -[NSWindowController window] + 109

          18  AppKit                              0x00007fff8a8bbad3 -[NSDocument windowForSheet] + 86

          19  AppKit                              0x00007fff8a84671a -[NSDocument _shouldShowAutosaveButtonForWindow:] + 50

          20  AppKit                              0x00007fff8a84640a -[NSWindowController setDocument:] + 237

          21  TextEdit                            0x0000000108e0b63c TextEdit + 17980

          22  TextEdit                            0x0000000108e0fbeb TextEdit + 35819

          23  CoreFoundation                      0x00007fff8a10275d -[NSObject performSelector:withObject:] + 61

          24  Foundation                          0x00007fff87059d94 __NSThreadPerformPerform + 214

          25  CoreFoundation                      0x00007fff8a0816e1 __CFRUNLOOP_IS_CALLING_OUT_TO_A_SOURCE0_PERFORM_FUNCTION__ + 17

          26  CoreFoundation                      0x00007fff8a080f4d __CFRunLoopDoSources0 + 253

          27  CoreFoundation                      0x00007fff8a0a7d39 __CFRunLoopRun + 905

          28  CoreFoundation                      0x00007fff8a0a7676 CFRunLoopRunSpecific + 230

          29  HIToolbox                           0x00007fff9034831f RunCurrentEventLoopInMode + 277

          30  HIToolbox                           0x00007fff9034f5c9 ReceiveNextEventCommon + 355

          31  HIToolbox                           0x00007fff9034f456 BlockUntilNextEventMatchingListInMode + 62

          32  AppKit                              0x00007fff8a650f5d _DPSNextEvent + 659

          33  AppKit                              0x00007fff8a650861 -[NSApplication nextEventMatchingMask:untilDate:inMode:dequeue:] + 135

          34  AppKit                              0x00007fff8a64d19d -[NSApplication run] + 470

          35  AppKit                              0x00007fff8a8cbb88 NSApplicationMain + 867

          36  TextEdit                            0x0000000108e08678 TextEdit + 5752

          37  ???                                 0x0000000000000002 0x0 + 2

)

 

This only happens in my main user account.  If I use another account TextEdit works as expected.

 

I have trashed all TextEdit preference files I can find and searched for this problem online but am still confounded.  I also reinstalled Lion and deleted all caches I could find.  Still no joy.

 

Any help would be greately appreciated.


iMac (27-inch Mid 2011), Mac OS X (10.7.3)
  • macjack Level 9 Level 9 (50,625 points)

    Tried booting in "safe mode"?

  • the-big-eye Level 1 Level 1 (0 points)

    Thanks for the reply.  Safe mode did make the problem go away in my account.  So, I looked in my user/Library folder to delete anything that looked old and not needed any more.  Still not working after reboot.

     

    Any advice on where else to look in my account for something that might be the offender?

     

    Thanks, again for the reply.

  • macjack Level 9 Level 9 (50,625 points)

    If your TextEdit functions correctly that way, then go to System Preferences >> Accounts >> Login Items and remove them. Boot normally and test.

  • the-big-eye Level 1 Level 1 (0 points)

    Thanks again for this reply.

     

    I removed ALL login items and still no TextEdit function.  Then I spent most of the day uninstalling everything I could think of that I had installed over the years.  Then I removed anything that looked suspicious from my User/Library folder.  The system starts up a lot faster now, but I still have no TextEdit function with RTF.  I still get the same Console error:

     

    Mar 21 16:26:06 iMac27-Tom TextEdit[245]: *** Assertion failure in -[NSMenu itemAtIndex:], /SourceCache/AppKit/AppKit-1138.32/Menus.subproj/NSMenu.m:850

    Mar 21 16:26:06 iMac27-Tom TextEdit[245]: Invalid parameter not satisfying: (index >= 0) && (index < [_itemArray count])

    Mar 21 16:26:06 iMac27-Tom TextEdit[245]: *** Assertion failure in -[NSMenu itemAtIndex:], /SourceCache/AppKit/AppKit-1138.32/Menus.subproj/NSMenu.m:850

    Mar 21 16:26:06 iMac27-Tom TextEdit[245]: Invalid parameter not satisfying: (index >= 0) && (index < [_itemArray count])

     

    I'm at wits end wit this problem.  Any other ideas wopuld be appreciated.  Thanks again for the help.

  • macjack Level 9 Level 9 (50,625 points)

    Create a new User go to System Preferences > Users & Groups > "+" (make it an admin acct) and test the apps in this new account, if they work the problem is isolated to your User and not systemwide.

     

    If it is systemwide you may be able to repair this with  the Lion 10.6.4 Combo Update. http://support.apple.com/kb/dl1048 This is a fuller install, as opposed to an incremental "delta" update so it should overwrite any files that are damaged or missing. It does not matter if you have applied it before. It should preserve all your data and settings, but that said you should always have a backup.

     

    Remember to Verify Disk before update and repair permissions after update from /Applications/Utilities/Disk Utility.

  • the-big-eye Level 1 Level 1 (0 points)

    I tried another login and the problem is isolated to my own account only.  It's not system-wide.  This problem started when I upgraded to Lion.  So, I booted into the restore partition and then rebuilt the OS X 10.7.x system there.  Still no Joy.  I also just repaired permissions, and verified the disk.  Still get the same error.  I've removed Fonts and any other system stuff that I thought might have been a problem.  No help.

     

    Dang, this is a stumper.  I've never been vexed by a problem this long.  Still open to any other ideas.  And thanks again for your reply.

  • the-big-eye Level 1 Level 1 (0 points)

    I've spens hours trying to resolve this TextEdit problem (not being able to open .RTF files - see thread above).  Text Edit works fine in other logins but not in my my master admin login.  Is anyone alse having this problem?  I've switched to Bean as a text editor just to keep going.  Bean works well but I'm conserned that there is something wrong with my system if it can't use TextEdit.  Anybody?

     

     

    Thanks............   Tom A

  • Leonard Cho Level 1 Level 1 (0 points)

    The symptoms you describe, app failure dependent on account/login, indicates a corrupted user .plist file. These files are located in your /Users/[account name]/Library/Preferences folder. You can verify this by moving those files out of that folder and restarting your computer. I usually place them in a temporary folder on my Desktop in batches. In your case, I would start with the Text Edit .plist, should be com.apple.textedit.plist, then try all com.apple.[app name].plist files, then all .plist files. You will know you have found the corrupted .plist file when Text Edit starts working again. Once it is working, you can, if you like, restore the .plist files back to the Prefs folder. Each time you restart, OSX will recreate default .plist files that it thinks it needs, so you may have to overwrite those files. Testing your app after copying those files back can allow you to isolate the offending file.

     

    Good luck

    .leonard

  • the-big-eye Level 1 Level 1 (0 points)

    Thanks for this reply, Leonard. 

     

    I tried your suggestions.  I even removed ALL the .plist files from my user/library/preferences folder and then rebooted. The Text Edit problem was unchanged.

     

    Any other thoughts?

     

     

    Thanks............   Tom A

  • etresoft Level 7 Level 7 (26,415 points)

    Do you have any 3rd party "haxies" installed? Some software that adds new menu items? A SIMBL plug-in or something?

  • softwater Level 5 Level 5 (5,370 points)

    Look in

     

    ~/Library/LaunchAgents

     

    and remove anything that does NOT start with "com.apple...."

  • the-big-eye Level 1 Level 1 (0 points)

    I removed all the SIMBL stuff before updating to Lion.  A search didn't bring up anything current.  I've generally avoided Haxies because of these kinds of issues.  Don't know of anything current.  I do have many of those little Manu ICONS on the right side of the Menu Bar installed, but I've made sure they are all current updates.

     

    Thanks for replying.  Any other ideas would be appreciated.

     

     

    Thanks............   Tom A

  • the-big-eye Level 1 Level 1 (0 points)

    I just removed all the Launch agents and rebooted.  Still no joy.

     

    Any other ideas?

     

     

    Thanks............   Tom A

  • Leonard Cho Level 1 Level 1 (0 points)

    Stepping back, do a parameter ram reset for good measure, then a Permissions Repair in Disk Utility. If you can boot from another volume or mount your mac in target disk mode, do a Repair Disk in DIsk Utility. If you have access to DiakWarrior 4, run that on your volume. These measures may not help, but they typically will not hurt and are good maintenance practices.

     

    Since it is specific to your account, the source should be in your home folder somewhere. Migrating your user would be the simple way to confirm this. If you have another startup volume on an external drive or another mac, use Migration Assistant to migrate only your user. If the behavior follows the user, then the problem has to be in the home folder. If not, it could be some secondary interaction between your user and something in your /System or /Library folders.

     

    If it follows your user, you can experiment on that migrated user by removing and swapping parts of the home folder with another user on that volume. If it does not follow your user, backup your entire volume, and delete your user and migrate your user account back from the other volume.

     

    Hope this makes sense.

    Leonard

Previous 1 2 Next