7 Replies Latest reply: Mar 26, 2012 10:49 AM by BDAqua
ComputerAggrivation Level 1 Level 1 (0 points)

Couple days ago I noticed the "you have mail" sound I've been using for years had reset to default all by itself. Then started noticing other things that had changed from the way they've always been set. Everything else was working normal so i went on for a couple days cause i was too busy to deal with it. Then when firefox started lagging & getting glychy, I started closing windows to quit and restart when mail quit all by itself. I restarted the computer and when it started back up, mail opened on it's own and started trying to send out three years worth of Calander reminders. It couldn't send anything because all of my accounts and settings were GONE. It was like I was opening mail on a new computer for the first time and it was using a me.com account I must have set up long ago and never used.

     Restarting, Permissions, all the usual and nothing changed. I look in my library folder under Mail and the accounts folders are still there but Mail isn't recognizing them.

 

1) Most importantly, any idea how I get my old Mail back?

 

2) What the @#T% happened?

 

My machine is a pre intel (2005 ish) G5 desktop, dual 1.8Ghz PPc  running 10.5.8

 

Everything else is still working fine (for a dog old computer...)


G5 Power PC Dual 1.8GHz., Mac OS X (10.5.8)
  • BDAqua Level 10 Level 10 (119,040 points)

    Hmmm, first do this...

     

    "Try Disk Utility

     

    1. Insert the Mac OS X Install disc, then restart the computer while holding the C key.

    2. When your computer finishes starting up from the disc, choose Disk Utility from the Installer menu at top of the screen. (In Mac OS X 10.4 or later, you must select your language first.)

    *Important: Do not click Continue in the first screen of the Installer. If you do, you must restart from the disc again to access Disk Utility.*

    3. Click the First Aid tab.

    4. Select your Mac OS X volume.

    5. Click Repair Disk, (not Repair Permissions). Disk Utility checks and repairs the disk."

     

    http://docs.info.apple.com/article.html?artnum=106214

     

    Then try a Safe Boot, (holding Shift key down at bootup), run Disk Utility in Applications>Utilities, then highlight your drive, click on Repair Permissions, reboot when it completes.

     

    (Safe boot may stay on the gray radian for a long time, let it go, it's trying to repair the Hard Drive.)

     

    If perchance you can't find your install Disc, at least try it from the Safe Boot part onward.

     

    On Mail...

     

    First Quit Mail, then I'd backup these two Mail folders, by right clicking on them in the Finder, then choose Archive/Compress.

     

    Users/YourUserName/Library/Mail

     

    Users/YourUserName/Library/Mail Downloads

     

    (Could be a different folder here if you chose such in Mail Prefs)

     

    Right click on that Mail folder, choose archive, you'll get everything in the folder, and the folder itself in a file called Mail.zip, move it to a safe place, same for the Mail Downloads folder... only the plist is separate.

     

    /Users/YourUserName/Library/Preferences/com.apple.mail.plist

     

    Move the above file to the Desktop for now, then start Mail & setup the Accounts again exactly as they were.

     

    Alternativly you could try this instead...

     

    Not certain, but this can fix myriad Mail problems...

     

    Safe Boot from the HD, (holding Shift key down at bootup),  it will try to repair your Disk Directory while the spinning radian is happening, so let it go, run Disk Utility in Applications>Utilities, then highlight your drive, click on Repair Permissions, then move this folder & file to the Desktop.

     

    Move this Folder to the Desktop...

     

    /Users/YourUserName/Library/Caches/Mail/

     

    Move this file to the Desktop...

     

    /Users/YourUserName/Library/Mail/Envelope Index

     

    Reboot.

     

    If that doesn't do it and you can afford to redo all your Rules, try these & reboot...

     

    /Users/YourUserName/Library/Mail/MessageRules.plist

     

    /Users/YourUserName/Library/Mail/MessageRules.plist.backup

     

    Note, in 10.5 & up /Users/YourUserName/Library/Caches/Mail/ does not exist.

  • ComputerAggrivation Level 1 Level 1 (0 points)

    Thanks for the info. I'm trying different parts of it as I can. My Not-so-superdrive is only working intermittently.

     

    When it first happened I used DiscWarrior to rewrite the directory but had a hard time restarting out of DiscWarrior because, appantly, now have a firmware password that I never set up. So, I can't startup in safemode or reset the pram or NVram. Can't hold down the option key to startup from a disc either. Basically screwed not matter which way I turn at the moment.

     

    After getting out of DiscWarrior I had a rare instance of the superdrive being functional and was able to startup from the install disc by holding down the command+O keys. I did run the repair disc utility and then the verify permissions.

     

    Tried removing the com.apple.mail.plist preference and started up mail again. The odd thing is there was still that old/never used email address in there. Could this be associated with a glych from my iphone?

  • BDAqua Level 10 Level 10 (119,040 points)

    Is the iPhone set to sync?

  • ComputerAggrivation Level 1 Level 1 (0 points)

    Yes, I sync this iphone with the computer regularly. To my recolection... this didn't happen directly after a sync. Probably a day or two.

     

    I've been able to start up from the install disk and tried to use the "reset password" utility but it won't work. Not being able to reset the pram or start up in safe mode is a major road block I can't seem to get around. Any insight?

  • BDAqua Level 10 Level 10 (119,040 points)

    Why can't you Reset PRAM or Safe Boot?

  • ComputerAggrivation Level 1 Level 1 (0 points)

    It just doesn't happen. Until I attempted to start up from a disk by holding down the option key I didn't realize that I apparently have a firmware password in place now that wasn't there before. At least according to another thread I read here.

          Attempting to start up from the disc like that results in a screen with a picture of a padlock on the left, a space to type something (password) and and arrow button pointing to the right. I didn't do this, never seen it before. Typed in every password I have ever used and nothing.

         Lost the ability to reset the pram right after installing a firmware update that apple tech support told me I needed to make migration assistant work between the G5 in question and a new Macbook Pro I got my wife. It didn't help at all, but that was when I could no longer reset the pram on start up. So I assume they are related. Safeboot doesn't work either.

  • BDAqua Level 10 Level 10 (119,040 points)

    Ah, I see.

     

    Force Removing Password Protection

     

    1) Add or remove DIMMs to change the total amount of RAM in the computer.

     

    2) Then, the PRAM must be reset 3 times. (Command + Option + P + R).

     

    http://www.securemac.com/openfirmwarepasswordprotection.php