12 Replies Latest reply: Oct 29, 2013 1:47 AM by sefpeters
rednose22 Level 1 (0 points)

does anybody have safari issues like not responding to links


iMac, Mac OS X (10.7.3)
  • Pichicanes Level 1 (0 points)

    Yes, I m experiencing the same problem.

     

    For instances, trying the link http://elpais.com/

     

    However, via Firefox there is no problem at all.

    I noticed via the activity monitor screen that the process "Safari Web content" is taking 100% CPU time and most of the memmory available until it crashes.

  • wendyfrommiami Level 1 (0 points)

    I am having the same issue..and a lot of other issues.

     

    Not able to see javascript on certain pages. Yes..also pages are not loading all the content from databases. This will make me put safari in the garbage.

     

    I haven't updated my other macs and I am so glad I didn't!

  • Linc Davis Level 10 (192,559 points)

    Please post a link to a page you're having trouble with.

  • Pichicanes Level 1 (0 points)

    Hi! Davis.

     

    Please, as per above, use http://el pais.com/

     

    Regards,

     

    Pichicanes

  • Pichicanes Level 1 (0 points)

    Oop! I Am sorry, please, correct it!!

     

    http://elpais.com/

     

    Regards,

  • Thlayle Level 1 (0 points)

    I am seeing some troublesome issues with Safari lately. One that has come up has been a failure to load web forms properly, showing only blank, inaccessable fields (at Miblood.org - https://donate.miblood.org/portal/). I contacted the web master & he was able to get this work without problem, also using Mac (OS unknown, Safari version unknown (mine's up to date)).  I had to go to Opera to use the forms. This issue isn't totally new to me. I have seen other web pages for user forums that would not load properly.

     

    NOW - I am experiencing problems with Safari when trying to fill in dates on calendar fields, with financial institutions like CUs and private businesses. The calendar mini-window pops out but shows incorrect information, like the current month being January (same for all other months!) and all days showing as Sunday. Then nothing will work to satisfy the form.

     

    I have reset Safari & cleared the cache, checked settings for Java & so forth. Nothing stands out as a possible cause/explanation. (Not that I would really know!)

     

    Lately, I've been thinking how my Mac experience is starting to resemble the Windows problems that I thought I left behind.

  • Pichicanes Level 1 (0 points)

    You may find some additional info at the link:

     

    Safari cannot access this website, but firefox!

     

    There is a solution disabling Javascripts at Safar's Preferences. By doing that way I can reach access to the link I had provided to you early today. However, I do not know what the limitations will be after disabling Javascripts.

     

    Cheers

  • Thlayle Level 1 (0 points)

    Disabling Javascripts makes the sites unusable. They (the sites I am having problems with (financial institutions & so forth)) require Javascript to use their pages. Disabling the Javascripting just blocks access totally.

     

    Strangely, I do not seem to be having these issues with Opera.

  • Pichicanes Level 1 (0 points)

    I did find the solution -at least for my case-

    Please, read the following link:

     

    https://discussions.apple.com/message/17934947#17934947

     

    All you have to do is to uncheck the 32 bit mode at Safari by going to the App folder, mark Safari and do "Cmd i". At the infomration window uncheck 32 bit mode, leaving by default 64 bit mode

     

    It worked out for me. Now I can reach access to the link specified early this morning.

     

    Cheers

  • Thlayle Level 1 (0 points)

    Yep. This worked for me as well.

     

    Safari was set to 32 bit mode. How it got there is a mystery to me. I have not seen this problem ever before & I update to the latest version of Safari quite a while ago - without any noticeable problems. I did not set it to 32 bit.

     

    Anyway, it worked. Thanks!

  • sefpeters Level 1 (0 points)

    Since the update to Maverick.

    in Safari no links within a page works. Many other problems like the Tab-button does not work, i can only work with 1 pageview. no problem in Chrome.

  • sefpeters Level 1 (0 points)

    Safari works again. Problem was Glims. After an update of Glims Safari is o.k.