Previous 1 2 Next 22 Replies Latest reply: Jan 15, 2015 3:46 PM by fastasleep Go to original post
  • Silverreven Level 1 Level 1 (0 points)

    Hey everyone,

     

    I think I might have stumbled into the reason why this problem seem to pop up for all of us:

     

    Poor programming from developers who haven't done their homework.

     

    Whenever you have symbols or characters other than the common letters in the English alphabet, in the location name, I get this problem. Regardless of I get the invite through iCloud or Google Cal.

     

    Example: If I get an invite with a "$" sign in it or an "é" in the location (like café).

     

    I think the newbie who wrote the code simply forgot to add this check to the code, so all unfamiliar characters generate an error.

     

    I have tried now with a bunch of different combinations, and this indeed seem to be the problem. So try removing any event in your calendar that have these characters and see if the problem goes away

  • florele Level 1 Level 1 (0 points)

    http://support.apple.com/kb/HT2513?viewlocale=en_US&locale=en_US

     

    you need to add your email account in iCal (= add a calendar), and activate invitations download in Preferences/Advanced, and then invitations show in iCal.

  • cretino Level 1 Level 1 (0 points)

    This is 2014... still the problem hasn't been solved. Wake up Apple!!!!!

  • fastasleep Level 1 Level 1 (10 points)

    Holy crap, this is it! I just opened the .ics I was just testing in TextWrangler and checked the location: "three-way call". Removed the dash in three-way and saved it, double clicked and it opened in Calendar just fine!

     

    Amazing. What a stupid, stupid bug. Hopefully Yosemite has this fixed.

     

    Update — interestingly enough, this seems to be the case with the ics earlier that was created by Outlook (PRODID:-//Microsoft Corporation//Outlook 15.0 MIMEDIR//EN) but does not happen with an .ics I created in Calendar with a dash in the Location field. Go figure.

  • Simsonic11 Level 1 Level 1 (15 points)

    I can't believe I just figured this out. If the Events are coming from an MS Server account then all I had to do was add my account to the calendar and this all went away. Sheesh! Basically go to the mail account setting and sync the "calendar" as well as the email address. This can be done on both your macbook or iPhone. What a relief!

  • fastasleep Level 1 Level 1 (10 points)

    My workaround for this has been to drag the .ics from Mail directly to the Calendar sidebar onto the calendar I want the event to apply to, and it appears in the Calendar inbox. One less step than them auto-adding, but hey, it works.

     

    Still though, why isn't this fixed?

  • fastasleep Level 1 Level 1 (10 points)

    Wow, I think this explains it. I believe now that all the event invites that weren't auto-importing were being sent by Google users, and being intercepted by "my" Google Calendar, which I do not use (I have a Google account associated with my email for use with Analytics, etc, but not Calendar or contacts or Gmail etc). Basically I think all invites sent by other Google users to my email get checked by Google to see if there's an associated Google account (which there is, even though I don't actively use Calendar), then associates the event with that specific calendar, then sends me the email notification which has links to accept/decline/etc linking back to Google Calendar, which I never click on. But since I don't SYNC that calendar to Apple Calendar, it doesn't auto-import because it's not seeing the associated calendar listed. Hence why it doesn't auto-import BUT I can drag and drop onto another calendar in the list, like my REAL primary calendar which I sync over iCloud.

     

    I can't seem to find a way to disable Google Calendar for an account, and my fear is that you can't. :/ Contemplating setting up a Gmail address specifically to get my other services migrated to that, so I no longer have my non-Google email address getting associated with this stuff. Not sure that's worth the hassle yet but I'm not sure there's another way to fix this.

  • fastasleep Level 1 Level 1 (10 points)

    Or, maybe not. I just got one from an Outlook.com account, which I do not have, so that rules that out.

Previous 1 2 Next