13 Replies Latest reply: Mar 19, 2015 3:24 AM by Bas204
Ferre Level 1 (0 points)

MacBook Pro late 2009

10.7 (OS X Lion)

 

Today I received my brand new Sennheiser PX 210 BT.

This headset supports APT-X for significant better audio quality.

 

Alt+click the bluetooth icon in the menubar tells me the following info:

Bluetooth Version: 4.0.3.f12

Active codec: SBC (this should be APT-X)

 

How can I change/fix this so I can use APT-X as the bluetooth codec?


MacBook Pro (15-inch 2.53 GHz), Mac OS X (10.7.3), iPhone 4
  • SJT81 Level 1 (5 points)

    Try playing and pausing the audio. The codec ID may have gotten stuck.

  • wch100 Level 1 (0 points)

    I have this exact same problem, with a Creative ZiiSound D5 speaker system. I'm using my MacBook Air's built-in Bluetooth instead of the Creative USB dongle.

     

    It says that the Active Codec is SBC, not aptX. Stopping and starting the audio doesn't help at all. I have a 13-inch Mid-2011 Core i7 Macbook Air, running OS X 10.7.3.

  • jamarita Level 1 (0 points)

    Same to me , apt-x is enabled in my macbook pro 13 middle 2009 but not in my iMac 21 early 2011. I dont know how to enbable it here??

     

    thanks

  • dizzychoonz Level 1 (0 points)

    i had the same initial problem.

     

    sennheiser px 360's   freshly connected and working on the macbook pro 15" but after checking the bluetooth icon with  "alt click" it seemed they were using sco codec.

     

    However after a mac restart the codec changed to apt x. and has remained since.

     

    then again i cant really hear any significant difference in audio quality.. maybe just a touch  more open..

     

    so its not the end of the world if you cant release apt x.. although with mountain lion its there.

     

     

    BTW.. sennheisr px 360's 9 £70 on ebay)  awesome... just dont hit the srs button...eeek.. nasty nasty remove it.

  • rideMTB Level 1 (0 points)

    It may be necessary to turn on the aptX codec via Bluetooth Explorer -> Utilities -> Special Options

     

    That did the trick for me.

     

    The bluetooth explorer used to be available by pressing option then the bluetooth button, but now its bundled seperatly either with xcode or here : https://developer.apple.com/downloads/index.action?name=bluetooth%20explorer

  • Michael Erb1 Level 1 (0 points)

    I used bluetooth explorer as you described and for a while apt-x was working for me when I connected to Nuforce S3-BT speakers.

     

    At some point, and I think it may have been with the most recent OS update 10.9, apt-x no longer seems to be an option for me. My iMac always connects to the speakers using SBC.

     

    But not only that, now the connection to the speakers breaks after a few minutes and once the connection gets broken, the speakers emit a loud tone.

     

    Other devices such as my iPhone4 and iPad3 (not apt-x enabled) connect to the speaker with no issues.

     

    So I'm not sure what happened but apt-x is no longer there for me and even SBC is flakey.

     

    My iMac is literally 2 feet away from the speakers and the connection strength is 100% according to bluetooth explorer.

  • Raffael M. Level 1 (0 points)

    i also have the same problem with my macbook air 13" mid 2012 (with OSX 10.9) :-(

    bought a new BT 4.0 speaker with apt-x but my mac does not change to this codec.

    i'v deleted every connection which use bluetooth (mouse, keyboard) and also tried the "force to apt-x" option in bluetooth explorer, but nothing did help.

  • dancingmuthu Level 1 (0 points)

    apt-X is invalidated by default.

    Use Terminal.

     

    apt-X ON

    - - - - -

    $ defaults write com.apple.BluetoothAudioAgent "Enable AptX codec" -bool true

    - - - - -


    apt-X OFF

    - - - - -

    $ defaults delete com.apple.BluetoothAudioAgent "Enable AptX codec"

    - - - - -

     

    From 2010, some Mac's Bluetooth module

    Open Bluetooth icon on MenuBar with option key.

    If your Mac's Bluetooth module can use apt-X,

    you may confirm that it becomes effective.

  • Raffael M. Level 1 (0 points)

    it still doesn't work :-(

     

    Bildschirmfoto 2014-01-17 um 15.26.31.png

    Bildschirmfoto 2014-01-17 um 15.31.20.png

  • dragon242 Level 1 (0 points)

    I tried the command line enable and rebooted, and re-paired the whole nine yards...nada, then I tried the Bluetooth Explorer module. In the Bluetooth Explorer, I went to Tools then Audio Options and checked off Force use of aptX. Viola!!!  The Bluetooth Explorer is available from here: https://developer.apple.com/downloads/index.action?name=bluetooth%20explorer .  I am running Mavericks OS X 10.9.1...let me know if it works for you...cheers

  • MDMac86 Level 1 (0 points)

    Also, if none of these work for you ... Try turning off multipoint functionality on your headphones if the feature is available. Having this enabled forced the SBC codec to be used regardless of the 'force aptx' setting.

  • r4vin Level 1 (0 points)

    Like dragon242 said, uncheck aptX in the Bluetooth Explorer - special options, solved my problem. Make sure to disconnect, reconnect the device after changes. I also increased the Buffer size to 300, seems to get less stutter now at long range.

     

    Current working settings on MBA 2010 - CANTON DM50 , with good sound quality.

     

    Allow role switches for audio connections : Checked

    Enable aptX codec : Unchecked

    Disable aptX codec: Unchecked

    Disable HFP: Unchecked

    Use dynamic bitpool values: Checked

    Minimum bitpool : 50

    Maximum bitpool: 80


    Delay start: 1,0

    Delay resume: 0,8

    Buffer at maximum: 300


    Screen Shot 2014-07-17 at 16.17.27.png



    Screen Shot 2014-07-17 at 16.18.54.png

  • Bas204 Level 1 (5 points)

    Thanks this worked as a charm!