8 Replies Latest reply: Mar 25, 2012 10:58 AM by léonie
barryphoto Level 1 Level 1 (0 points)

I have Aperture 3 running on iMac 10.7.3.   When I downloaded the new version from the App store I get an erros saying "Check with the developer to make sure Aperature works with this version on Mac OS X.  It has been working fine up untilError Message.jpg now."   Any suggestions?


Aperture 3, Mac OS X (10.7.3)
  • léonie Level 9 Level 9 (77,665 points)

    Hallo,

     

    the errorlog you posted shows, that Aperture crashes with a very typical error message: Do you have by any chance installed "Final Cut" lately? The error message is, that a Framework is missing in your system library:

    /Library/Frameworks/PluginManager.framework/Versions/B/PluginManager

     

    Open your System Library by using the Finder "GO" menu:

         Finder -> Go -> Go to Folder     and enter:   /Library/Frameworks

     

    Then browse this folder and see, of the framework really is missing.

     

    If that is really the case, either try to restore this Framework from your TimeMachine Backup or reinstall the Operating System - this should restore the framework.

     

    Post back, if you need further assistance

     

    Regards

    Léonie

  • barryphoto Level 1 Level 1 (0 points)

    thanks very much...and yes i recentl did install Final Cut .  I will try that

     

    Barry

  • shuttersp33d Level 4 Level 4 (1,540 points)

    Here is the Apple support article concerning your issue.

  • zootopia Level 1 Level 1 (15 points)

    Hello! I was having the same trouble... I just downloaded Aperture form the App Store and when I went to open it, it quit and gave me the error log and all that good stuff. I tried your suggestion leonieDF, and it worked on my iMac, which I have hooked up to Time Machine and therefore was able to get the Frameworks file. My problem is that I want to install Aperture on my MacBook Pro but I don't have a back up of the Frameworks file... Both machines have Final Cut Pro X and I wonder if getting the Frameworks file from Time Machine worked for the iMac, would reinstalling OS X Lion work for the MacBook Pro? Would it have an effect on the current settings of my MacBook Pro? Could I move the Frameworks file from my iMac to the MacBook Pro or would that be a no no? I just don't know how else to ge the needed Frameworks file back to the MacBook Pro. Any help you can offer would be greatly appreciated!

  • léonie Level 9 Level 9 (77,665 points)

    I am really not sure, if the Plugin Manager Framework is completely independent of the platform. It will be safer by far to reinstall the OS. Reinstalling shoud not change your User Settings, if you install on top of your current system and do not do a clean install and wipe your machine completely. But make sure you create a working backup before you reinstall. This way you will be able to recreate your current state with "Migration Assistant", if anything should go wrong.

  • zootopia Level 1 Level 1 (15 points)

    Thank you so much for the quick reply! I will giove it a shot. I did find the Combo Update for OS X 10.7.3 and downloading it now. I'll give that a run and see what happens. If that doesn't solve it, then I'll do an install of OS X Lion over my verison and see what happens then. I'll post back with results.

  • zootopia Level 1 Level 1 (15 points)

    The Combo Update found here:

     

    http://support.apple.com/kb/DL1484

     

    seems to have resolved the issue... Aperture now opens on all machines and works properly. Thanks again for your help.

  • léonie Level 9 Level 9 (77,665 points)

    You are welcome. I am glad it worked for you.

     

    Léonie