Previous 1 2 3 Next 128 Replies Latest reply: Apr 5, 2012 3:46 PM by Rod Stasick
NuLynx Level 1 Level 1 (0 points)

I've got a problem with my computer at work. It's running Snow Leopard 10.6.8. I've got a number of older apps, including Quark 6, Epson scanner software, Disc Catalog, etc, that have all been working fine for the last number of years. As of yesterday afternoon, I was still scanning with the Epson software and everything was running fine. When I came in to work this morning and fired up the computer, NONE of my pre-Snow Leopard apps work.

 

At first, when a few of my apps didn't work, I suspected a font issue, because at the end of the previous day, I was working on a "problem job" that had conflicts with my basic system fonts. But, as the hours passed, I began to realize none of my older apps worked. At that point, I started to suspect a problem with Rosetta.

 

Hours and hours of searching, both here and across the internet came up with nothing. A few sites gave step by step instructions to drop into terminal to reset bindings, delete preferences, etc. Nothing worked.

 

Most of the older apps I NEED for our company. Many of those don't have upgrades available, and some are just too expensive to justify.

 

After almost an entire day of getting nowhere, I decided to set up another "user" called Troubleshooting. Lo-and-behold, all of the apps worked fine. So, that ruled out a problem with the Rosetta interface, and the suspeced Security update in the recent past that was said to cause problems with the whole Rosetta interface.

 

So, my question is, since only my original Administrator User is not functioning properly, is there possilby a preference .plist file that could be causing the problem? Could there still be a font issue? Is there anything I can do in Terminal to reset to a default?

 

I wasted an entire day banging my head on the desk trying to wrap my brain around it. Repairing permissions, disc check, etc. did nothing to help the issue.

I COULD get around the problem by logging into my "Troubleshooting" user to use the apps...but that's beside the point. I COULD do that, but I really want to figure out what's going on with my main User workspace.

 

So, before I need to come into work on Monday and spend another whole day not knowing what to do, can anyone offer any ideas?

 

Thanks in advance.

 

Brad


PowerMac, Mac OS X (10.6.8)
  • Kurt Lang Level 7 Level 7 (34,115 points)

    Since a test account works, that automatically eliminates an issue with the system. That is, nothing wrong with the OS itself, Rosetta, or any update causing an issue. If any of those were true, then you would have the same problem in any user account.

     

    If the fonts in question were installed to the /Library/Fonts/ folder, then that too is probably not the issue since they would be active for any account. But if they were installed to the Fonts folder of your normal user account, then it's possible, though still not likely since it would be pretty hard for a conflicting font to stop Rosetta from working at all.

     

    Still, just to help eliminate that possible problem, restart and hold down the Shift key. Keep holding it until you at least see the loading bar at the bottom of the screen, which indicates you are booting into Safe Mode. Log in to your account (you get this screen on a Safe Mode boot even if you're Mac is set to automatically login).

     

    Test an app or two you know are PPC based. Do they work in Safe Mode? If so, boot back normally. By doing this, among a few other things a Safe Mode boot does, it clears all cache files of the account you logged into and resets Font Book's database. Once booted normally to your account, do your PPC apps still work?

  • NuLynx Level 1 Level 1 (0 points)

    Thanks for the reply Kurt.

     

    I forgot to mention the "safe boot" part in my attempt to try everything I could think of. I tried it twice during the course of the day, for different reasons...but both times, I had the same failed results. Actually, I was totally positive the safe boot would work, and then I could begin systematically troubleshooting from there. When it didn't work, I was stumped. When creating another user... and it actually worked, I became TOTALLY stumped.

     

    Hopefully that helps someone to narrow down the problem, but it's only complicated it from my point of view.

     

    Safe boot should have eliminated the font possibility, because I use a third party font manager called Font Explorer which normally launches on startup. When safe boot didn't work, I immediately ruled out a font problem, but then started wondering if I was either missing a core system font, or possibly one became corrupted during my previous day's font problems.

     

    So, I don't totally rule it out...although it seems like a very slim possibility. Still, over 20-some years of Macs and Graphic Arts, I've seen fonts cause some really weird problems.

     

    I pretty much figure the fonts aren't the problem, but I keep them on the back burner as a possibility.

     

    I agree with everything you wrote, and came to the same conclusions. I figured safe mode would rule out a number of problems, but it didn't. Things acted the same in safe mode as they do in full mode.

     

    Then, when a new user account worked fine…that REALLY left me scratching my head while I was banging it on my desk. As you said, it shows the core system is working, so it must be something else. That's why I am wondering about a specific preference file or something. Problem is, I can't find any info about any specific file that pertains to the Rosetta part of the software.

     

    Any other ideas?

     

    Brad

  • X423424X Level 6 Level 6 (14,205 points)

    If a new account "works" and safe mode in you "real" account doesn't the problem I think is specific to that one account.  It could be plists, something in /Application Support, or other places.

     

    Is it just ppc apps that are having problems or other intel apps?

     

    Is it all pcc apps?

     

    Consider (re)installing Mac OS X 10.6.8 Update Combo v1.1.  I just remembered there was some security update that screwed up rosetta.  That combo update was supposed to fix the problem (hence the 1.1 version number).

     

    Rosetta broken in OS X 10.6.8 after security update

     

    Of course this wouldn't explain why rosetta works in your other accounts.  But it probably won't hurt to redo the combo updater anyhow.  Just have backup(s) before doing it.

  • NuLynx Level 1 Level 1 (0 points)

    ALL and ONLY PPC apps across the board. To the point of becoming predictable.

     

    "This one is old, it problably shouldn't work"....<click>....nope.

    This one is newer, so it shoud work....yup it does.

    Not sure about this one, but it's pretty old....nope, it doesn't.

    This one for sure shouldn't work...<click>...nope.

     

    Not being at my computer, I would say more than a dozen, less than 20 older apps that don't work anymore, and ONLY older apps. Everything else is running fine.

     

    I'm aware of the security update screwing things up...I made mention of it in my original post. That was installed almost a month ago with no problems. As a troubleshooting measure, I even re-downloaded the security update that was supposed to fix the issue you mention. It didn't make any difference.

     

    The only recent installations were on Tues, when there was an update to Epson printer drivers, Safari, and Apple Software Update. Even with those updates, things have worked just fine.

     

    Basically, Thursday everything was running fine. Shutdown at the end of the day. Came in Friday morning and on startup none of the older apps worked. No chance for an overnight update, since the computer was shut down...but on restart Friday morning, none of the old apps worked.

  • X423424X Level 6 Level 6 (14,205 points)

    Ok, time to dig a little deeper.  Open terminal.  Type open -a followed by a space.  Drag one of the problem ppc apps into the terminal window.  You should have a line that looks something like:

     

    open -a /path/to/app

     

    Where /path/to/app is the full pathname to the app.  Hit return.  Does anything display on the terminal?  If so, post the result.

     

    If you get no output (because the above will launch an app like the finder but I am not sure it will show anything on the terminal) then drag the app to the terminal window, but don't type a space.  Then type /Contents/MacOS/appname, where appname is just the name of the app.  The terminal line will look something like,

     

    /path/to/app/Contents/MacOS/appname

     

    Hit return and post the result of that command (if any).

     

    And while I am thinking of it use that same line as a argument to a file command on the terminal:

     

    file /path/to/app/Contents/MacOS/appname

     

    Post its result.

  • fane_j Level 4 Level 4 (3,660 points)

    NuLynx wrote:

     

    NONE of my pre-Snow Leopard apps work.

    I apologise if I missed this, but

     

    (1) How do you know that only PPC apps don't work? Do you know from their version that they're PPC? Or did you check the architecture?

     

    (2) What exactly happens when you try to launch such an app? Any error message? Nothing at all?

     

    (3) Did you check Console to see if there's any relevant message? For instance, immediately after trying to launch one of these apps?

     

    (4) Did you try to reset the Launch Services database?

  • NuLynx Level 1 Level 1 (0 points)

    I can mostly tell from the version history and the fact that I've had a large number of the applications since PowerPC's were the new kids on the block. In many cases, the software companies don't even exist anymore.

     

    When I started to realize I had a problem, I went down my list of apps from A-Z, trying the ones that had been brought forward from generation to generation, and soon saw a pattern. All of my newer apps work fine….Adobe Creative Suite 4, Creative Suite 5, Quark 7 (doesn't work fine, but then again…never did...but at least it launches), all of the apps associated with Apple work fine. The only ones that don't work are ones that I've had since the early days of OSX.

     

    A little background of how the day started may help. My company uses Disc Catalog, which they've been using for 8 or 9 years to keep track of backup DVDs. First thing Friday morning, I needed to retrieve a few images, and Disc Catalog didn't work. I figured I had a software problem, so I had a coworker use their Disc Catalog to find the images…I'd deal with my problem later.

     

    About an hour later, a job came in that needed images scanned. That's when I found that my Epson scanning software no longer worked. THAT was serious, because I'm the only one that does the scanning and color correcting, etc.

     

    So, my first step was to troubleshoot that. I went to Epson's site, downloaded the "newest" installer and uninstaller. The uninstaller worked great…but when I went to reinstall the software, the installer itself wouldn't work. NOW I had a problem. I went back to Epson's site, and the uninstaller was for OS 10.6 and 10.7, but the "newest" installer was only good up to OS 10.5. That's when I started wondering about other applications, and started to realize just how many apps were no longer working.

     

    As to what happens when I launch an app, I instantly get the dialog box "(YourApp) has unexpectedly quit." The dialog box is immediate. Usually by the time I let up on the mouse button, it's on screen. No delay, no wait period while the app "tries" to open. I checked the error log to see if there was anything I could recognize. Off hand I don't remember what the exception was exactly, but I tried to search for that, but never found any answers that helped. Console basically said the app had unexpectedly quit, and a log was recorded. Not being in front of the computer, I can't tell you for sure what the message is.

     

    X423424X, thanks for the suggestion. I will try that and post the results, but it will have to wait until Monday when I get back to work.

     

    I'm just hoping someone can shed a bit of light on things before then, so I can hit the ground running first thing Monday morning to fix my problem. I've already wasted a whole day at work, and my boss sees computers as some kind of magic toaster. He pretty much assumes all we do back in the art Department is hit "print". I doubt being down most or all of Monday will sit very well.

     

    Thanks for the feedback so far.

     

    Brad

  • fane_j Level 4 Level 4 (3,660 points)

    NuLynx wrote:

     

    I can mostly tell from the version history and the fact that I've had a large number of the applications since PowerPC's were the new kids on the block.

    As indicated by X423424X , the file command will give you a specific app's architecture(s). However, you can use System Profiler > Software > Applications to generate a report with all applications on your Mac and their architectures.

    I instantly get the dialog box "(YourApp) has unexpectedly quit."

    Then there should be a crash report. The report might indicate something; so might also the Console message.

    That's when I found that my Epson scanning software no longer worked.

    It is possible that Epson doesn't have newer software for the scanner, but Apple does. Check if you can scan with Image Capture. There's also VueScan; I think it's better than Epson's software.

  • NuLynx Level 1 Level 1 (0 points)

    I'll check X423424X's suggestions on Monday.

     

    As I said in my previous post, Console and the log/crash report showed an exception which I did a search on, but nothing I could personally work out. I'll post more on that on Monday when I can replicate the problem.

     

    VueScan is something I've looked into in the past, and it may be the route I have to take, but that doesn't help the problem with my other apps. Image Capture is an option, but it can't handle advanced scanning settings like custom cropping, resolution, color correction, gamma settings, or grey balance. I can do most of that in PhotoShop, if need be...but I would prefer something much better. If I can't figure something out, I would rather log in as another user and keep the things I have.


    At any rate, workarounds aren't what I'm looking for at this point. SOMETHING went wonky with my main user settings...albeit prefs, fonts, or whatever. Something that doesn't affect any other users I set up. So it's more of a matter of finding out what went wrong...be it a preference file or what. There's always a workaround...but, I just want to fix what went wrong in the first place. There has to be a reason for it, and I want to set things back to normal.

     

    Brad

  • WZZZ Level 6 Level 6 (12,640 points)

    MIght be a corrupt preference file or cache. You might try running Applejack for this. Since it's specific to your user, just steps 3 & 4 underlined below.

     

    Download:

     

    http://sourceforge.net/projects/applejack/

     

    Article on using:

     

    http://reviews.cnet.com/8301-13727_7-10334620-263.html?tag=mfiredir

     

    It runs in single user mode, where it runs more safely than other maintenance/cleaning programs because there is less chance of interference from the OS. After installing (you won't see it in the Applications Folder) hold CMD-S at startup. You will get a black screen with MS-DOS like text. Just follow the prompts: type in "applejack AUTO" and it will run through the following:

     

    Correct any Disk problems.

    Repair Permissions.

    Clear out Cache Files.

    Repair/check several plist files.

    Dump the VM files for a fresh start.

    Trash old Log files.

     

    You can also run tasks selectively and for specific users by typing in "applejack." After running in "AUTO,"  you can go back and run it again as "applejack," steps 3 & 4 only, for your user.

     

    The first reboot will take much longer than usual, as it rebuilds caches. It may take several restarts to see the benefits. Because of the deep cache cleaning in AUTO mode some applications may tell you they are being opened for the first time.

     

    NOT YET UPDATED FOR LION (although it is reported by some that it is working)

     

     

     

    (Adapted from post by BDAqua)

  • fane_j Level 4 Level 4 (3,660 points)

    NuLynx wrote:

     

    I'll check X423424X's suggestions on Monday

    Guess we'll have to wait for that.

    VueScan is something I've looked into in the past, and it may be the route I have to take, but that doesn't help the problem with my other apps.

    No, and I didn't suggest it as a solution. You said earlier, the scanner issue "was serious, because I'm the only one that does the scanning and color correcting". VueScan might tide you over until you solve the Rosetta problem.

  • NuLynx Level 1 Level 1 (0 points)

    Interesting. Thanks for the information. I will definitely try Applejack. At the very least, it looks like a really useful application to have.

     

    Thanks!

     

    Brad

  • NuLynx Level 1 Level 1 (0 points)

    fane_j...

     

    You are correct. I apologize if my reply came off sounding rude. Re-reading it, I can see that it may.

     

    It's just that after spending the bulk of my weekend obsessing about the problem (I should get O.T. pay for this.)   the conclusion of most of the threads I've followed on anything relating to Rosetta is "change or upgrade your software and move on."

     

    But, as I said, you're right...in the mean time, it may be the best way to go. Even if/when I get the problem fixed, I still may give it a try. Epson's interface isn't great…but it's functional. I'll look into VueScan.

     

    Except for the possibility of a font problem, I think it's all coming down to a preference file somewhere. I'm starting to come to the conclusion that, unlike other problems, where someone suggests removing a specific preference file, when it comes to the case of Rosetta and PPC apps, things aren't so cut and dried. I've found nothing anywhere that says "remove rosetta .plist file" (by any other name), and that should fix it.

     

    So, my plan of attack in the morning is to drop into terminal and get the info X423424X requested.

     

    Next, I will boot up from my SnowLeopard disc (which I didn't have at work on Friday) and try a full repair permissions and disc check.

     

    If that doesn't take care of it, I'll try AppleJack.

     

    If all fails, I'll try to carry on work using my alternate login, and I'll give VueScan a shot for my emergency needs.

     

    Then, I'll wait to see what X423424X has to say about the info I've provided. One way or another, something's got to take care of it.

     

    Thank you all for trying to help fix the problem.

     

    Brad

  • Kurt Lang Level 7 Level 7 (34,115 points)

    Since we know the issue is somewhere in your user account, you can also attack just the preference files.

     

    We don't know which ones for sure, but create a new folder on the desktop. Open the Preferences folder of your user account and drag most things that starts with com.apple into the new folder. To keep from having to rebuilt the Dock, or totally mess up certain preferences, leave at least these alone:

     

    com.apple.AddressBook.abd.plist

    com.apple.AddressBook.plist

    com.apple.appstore.plist

    com.apple.dock.db

    com.apple.dock.plist

    com.apple.iTunes.eq.plist

    com.apple.iTunes.plist

    com.apple.iTunesHelper.plist

    com.apple.Safari.plist

     

    Pick and choose others as you see fit and restart the Mac. This will cause a lot of personal preferences to return to their defaults, such as the desktop picture, and lots of other minor settings in the System Preferences. But if this doesn't help, you can always just move all of the items you moved out back into the Preferences folder (overwriting the newly created ones) and restarting. Then you'll be right back where you were.

Previous 1 2 3 Next