8 Replies Latest reply: Mar 25, 2012 5:03 PM by ed2345
Smiler* Level 1 Level 1 (0 points)

I often borrow audiobook CDs from the library and have no trouble importing them to iTunes. But many of them come as mp3 CDs, which has been causing me lots of headaches. First of all, iTunes doesn't recognize those kinds of CDs. I used to be able to get around this by simply using the File > Add to Library feature. But with iTunes 10.6, this no longer seems to work and I haven't found a simple way to upload the tracks to iTunes. When I Google this problem, I find lots of answers to copying mp3 tracks from iTunes onto CDs, but I want to do the opposite. Help?!?


MacBook Pro (15-inch Early 2011), Mac OS X (10.7.3)
  • Chris CA Level 9 Level 9 (77,870 points)

    File > Add to library is the correct way.

    But with iTunes 10.6, this no longer seems to work

    Perhaps you would care to explain a bit more?

    What does/does not happen?

    Any messages?

  • ed2345 Level 7 Level 7 (21,540 points)

    Smiler,

     

    Just a thought, but please go to Edit > Preferences > Advanced, and make sure you still have a check mark for "Copy files to iTunes Media folder...."

  • Miss Clandestine Level 1 Level 1 (25 points)

    Another option that might work for you would be to open the Finder and look at the CD itself (should show up under devices). From there you should just be able to drag-and-drop them over to iTunes. Especially if you have the "Copy files to iTunes Media folder" option checked, as ed2345 mentioned.

  • Smiler* Level 1 Level 1 (0 points)

    I went into my prefs and saw that "Copy files to iTunes Media folder" was not selected, so I've fixed that. I have a new batch of mp3s coming in from the library tomorrow, so I'll be able to try it out and see if it works... I'll be sure to report my findings.

     

    Thanks!

  • Smiler* Level 1 Level 1 (0 points)

    I'd done the drag and drop think from the finder, but without the "Copy files to iTunes Media folder" chequed. Hopefully that'll make all the difference. I can't wait to try it out!

  • ed2345 Level 7 Level 7 (21,540 points)

    That is most likely the issue.  Drag-n-drop from Finder has equivalent behavior as Add to Library.  If you do it with "Copy..." not selected, iTunes will reference the file you give it.  In your case that file is on the MP3 CD, and when you take out the CD, iTunes is at a loss.

     

    With "Copy..." enabled, iTunes will make its own copy, and will play that new copy even after the CD is removed.

  • Smiler* Level 1 Level 1 (0 points)

    Awesome! You have no idea how much time I wasted and how much I raged against iTunes for not having a simpler function to enable copying mp3 CDs. I just tried it out with one CD and it worked without a glitch and as quickly as I'd expect from the latest version of iTunes.

     

    Thanks for you help ed!

     

    I just want to add as a general comment about iTunes that it would be nice if they made copying mp3s a more direct and a more obvious process... "copy files to iTunes media folder" works fine... once you've figured out you need to check that option!. I love apple products and apps for how intuitively they can be used, and can't say it's the case here!

  • ed2345 Level 7 Level 7 (21,540 points)

    Smiler,

     

    That is true, but to avoid any problems, the best thing to do with the "Copy..." option is to check it, and leave it checked.

     

    And of course, I am glad to hear the problem is fixed.  Enjoy the music!

     

    Ed