2 Replies Latest reply: Mar 24, 2012 12:25 PM by Hans Eklundh
Hans Eklundh Level 1 Level 1 (15 points)

I wanted to upgrade my Apple TV 2 to the new software iOX 5.0. I have been trying for weeks wtih no result.


When I select "Update software" in ATV settings it responds "Apple TV does not need to be updated".

When I select "Restore" in ATV settings it responds "Apple TV can not download the latest update right now. Please try later".


I have read the threads in the dicussions about how people solved this by changing the DNS to either OpenDNS or Google.

Done that, both in my Time Capsule ant ATV with no difference at all. I have not yet tried to connect it to my Mac Book and via iTunes.


I am in Sweden (if that matters) and I still like to update. I just don't know how.

Could atv flash black be the cause? A restore should kill it, but I can not restore.


Anyone with any sollutions? If not I'll buy the new ATV 3.

MacBook Air, Mac OS X (10.6.7), 2,13 GHz Intel Core 2 Duo, 4 GB RAM