Previous 1 2 Next 20 Replies Latest reply: Nov 26, 2014 4:20 AM by cbriscar
Vpr99 Level 1 (0 points)

Hi All,


Hopefully you can help me out with this, because I'm near wits end with this.


I have had Lion since the day it came out, and this is the first time I've encountered this problem. All of the applications that I have downloaded and installed before yesterday worked perfectly. Then, out of the blue, any application that I install or update (not from the App store) refuses to launch. It either bounces forever in the dock or does nothing when it is clicked.


The only system changes I have made are installing Photoshop CS6 Beta and Steam. So far, I've tried:

- Permissions & Disk repair through the Lion recovery partition

- Removing and re-downloading the apps

- Running in 32-Bit mode


I'm running 10.7.3, with all the latest updates installed, on a mid-2011 Macbook Pro. Any help in the matter would be greatly appreciated, as I'm tearing my hair out over this. Restoring from a TM backup is not really a viable option currently, since my backup drive is 50 miles away and unavailable for the next week and a half (yes, I know... stupid me...)


Thanks again,


MacBook Pro, Mac OS X (10.7.3)
  • Linc Davis Level 10 (184,365 points)

    Launch the Console application in any of the following ways:


    Enter the first few letters of its name into a Spotlight search. Select it in the results (it should be at the top.)


    In the Finder, select Go Utilities from the menu bar, or press the key combination shift-command-U. The application is in the folder that opens.


    If you’re running Mac OS X 10.7 or later, open LaunchPad. Click Utilities, then Console in the page that opens.


    Click the Clear Display icon in the toolbar. Try again to launch one of the affected applications. Post any messages that appear in the Console window – the text, please, not a screenshot.

  • Vpr99 Level 1 (0 points)

    These seem to be the pertinent lines.


    3/24/12 12:22:25.207 PM ([0x0-0x54054].com.incident57.Less[763]) posix_spawn("/Users/ericskram/Desktop/", ...): Operation not permitted


    3/24/12 12:22:25.207 PM ([0x0-0x54054].com.incident57.Less[763]) Exited with code: 1

  • Vpr99 Level 1 (0 points)

    Hmm. I may have found a solution to this. It seems to be caused by a bug with Lion's quarantine system. To solve it, I followed the following steps. ( is my example)


    In Terminal, I moved to the following:


    Replace everything except for Contents/MacOS with the location of your application.

    $:  cd /Users/ericskram/Desktop/


    List the files in the directory using ls. There should just be one. In my case, it was named less.


    $: xattr less


    There should be an entry labeled If there is, use the following command to remove it.


    $: xattr -d less


    Restart the system and it should work... at least it did for me.


    Source: -in-os-x-lion/

  • Linc Davis Level 10 (184,365 points)

    The quarantine attribute shouldn't have that effect, but if it does, you're apparently triggering a bug. In any case, there should be no need to restart after clearing the attribute. At most, you might need to move the file or relaunch the Finder.

  • jkwaters Level 1 (0 points)

    I am having the exact same issue, with the same console messages. When trying to run an app from a disk image I'm asked:


    Screen Shot 2012-03-24 at 7.13.06 PM.png


    Clicking open leaves me with a bouncing icon in the dock and these messages in Console:


    12-03-24 7:13:01.334 PM ([0x0-0xa21a21].com.hyperbolicsoftware.tidyup!2[5746]) posix_spawn("/Volumes/Tidy Up! 2/Tidy Up!.app/Contents/MacOS/Tidy Up!", ...): Operation not permitted


    12-03-24 7:13:01.335 PM ([0x0-0xa21a21].com.hyperbolicsoftware.tidyup!2[5746]) Exited with code: 1


    12-03-24 7:13:01.340 PM Dock: no information back from LS about running process


    12-03-24 7:13:17.291 PM CoreServicesUIAgent: Unable to kill suspended application -- error 4294966696



    If I check "Don't warn me when opening applications on this disk image" and open, I will get the bouncing icon and error messages. Open the app once more and it works as expected.


    Also copying the app to a native folder and opening it I get the same error, but it opens on the second try.

  • mrm312 Level 1 (0 points)

    Thank you, this helped me with a similar situation.  Was driving me crazy!!!

  • Simon (UK) Level 4 (3,565 points)

    I'm having a similar situation with 1Password but I can't seem to get the workaround to work. Any ideas?

  • Vpr99 Level 1 (0 points)

    Hey Simon,


    It turns out that, while my solution worked for certain things, it wasn't the root of the issue. Soemone on another forum suggested that it was related to a corrupted user account. So, per to his suggestion, I created a new account and did my best to swap over my settings. This worked better. I know it's a pain, but I couldn't find another way around it.

  • Simon (UK) Level 4 (3,565 points)

    Thanks for that.


    Did they happen to go into detail about what they thought the corruption was? I'd prefer to try and  discover the reason behind a corrupted user account, which is something I've never encountered before, rather than just make a new one.



  • iam3rr0r Level 1 (0 points)

    I had this same issue after the failed install of a native instruments product (10.7.3). To actually complete the NI install, i had to create a different user account to get to not fail.  Anyways, today I tried to update a drag and drop application and the outcome was the same as Vpr99's experience.  Upon launching the application, it would appear on the dock, bounce, then eventually stop bouncing and disappear if clicked. 


    Same console output:

    3/27/12 10:52:07.752 PM ([0x0-0x60060].com.freemacsoft.AppCleaner[1053]) posix_spawn("/Applications/", ...): Operation not permitted

    3/27/12 10:52:07.752 PM ([0x0-0x60060].com.freemacsoft.AppCleaner[1053]) Exited with code: 1


    Removed, reinstalled the application several times and removed any related files.

    I ran all the relevant maintenance routines that one could find in Onyx or MacPilot--no resolve...restarted several times.


    I reinstalled the app again then dropped it in BatChmod with a 755 octal setting, cleared xattrs, unlocked, applied to enclosed files and folders and the application opened up properly. 

  • yanokwa Level 1 (0 points)

    If you are using The Unarchiver 3.0 to unzip the application, it will not work properly when you launch it. This is because of the sandboxing feature in 10.7.


    Use Keka (v1.0.1) or the built-in Archive Utility (v10.7.1) as a workaround.  See for more information.

  • Markie Castle Level 1 (25 points)

    Clarification and resolution on thread

  • smallthing Level 1 (0 points)

    I just wanted to pop in to say that I was having this EXACT problem. Some (not all) of my new apps would bounce forever in the dock, but if I clicked them, the icon disappeared. The app would never open. The solution presented by yanokwa above worked 100% the first time.


    I uninstalled the Unarchiver and redownloaded and reunzipped a problem application using Archive Utility, and jango! It worked perfect.


    Thank you!

  • Lotus.Geek Level 1 (0 points)

    @yanokwa - YOU ARE A LIFESAVER. You have NO IDEA how hard it was to find this answer. I've literally been spending hours trying to find the right combination of things to do to solve this - and I was about to throw my MBP across the room. I am SO glad you were able to explain the problem, and the solution - and of course it was painfully simple.


    Thank you so much for providing this answer. You have saved me from, and I am sure many, many others, a geek's life of frustration.


    Thanks again.


    P.S. If I could I would give you the 10 points for providing the correct solution. You deserve it.


    ***Message was edited by: Lotus.Geek - P.S. was added.

Previous 1 2 Next