4 Replies Latest reply: Mar 25, 2012 4:01 PM by PieroF
PieroF Level 5 Level 5 (4,275 points)

Hi, I just made a clean Install, and I cannot reinstall Final Cut X that I purchased while running Snow Leopard. How can I get it back without buying it again ?

 

Thanks

 

Piero


MacBook Pro, Mac OS X (10.6.8), FCP X - Canon HF M31 PAL
  • Carolyn Samit Level 10 Level 10 (96,745 points)

    Hi Piero ..

     

    Mac App Store application disappears after Lion Clean Install

     

    Install the OS X Lion Update 10.7.3 (Client Combo)

     

    That will reinstall the App Store for you. It's ok to do this even though you are already running v10.7.

     

    Restart your Mac after the combo is installed then re download FC X.

     

    How to re download apps from the Mac App Store:

     

    Open the App Store. From the menu bar click Store > Sign In

     

    Click Purchases from the top of the App Store window.

     

    Select which apps you want to re download. Then right or control click where you see Installed  then click Install.

     

    Make sure and use the same Apple ID used for the original purchase.

     

     

     

    edited by:  cs

  • PieroF Level 5 Level 5 (4,275 points)

    Hi Carolyn,

    thanks for your answer.

     

    In fact I already tried your suggestion but to no avail (btw initially I tried to update OS X using SW Update, and I ran into a known failure at the end of the download - instead the combo worked)

    Basically I had purchased only Final Cut Pro X.

    But it does not appear: not among the purchased items, nor among the upgrades, neither before nor after the update.

     

    I thought that playing with the "receipts" would work, but in fact I don't know where to look for and in the Snow Leopard (Time Machine Backup) Library/Receipt I found only 3 files not present in the corresponding folder of Lion: Application Data, Program Files, Registration, all "for TC3D.pkg". I dragged them into the Lion library, quit and reenter App Store. No effect.

     

    Any more suggestion ?

     

    Piero

  • PieroF Level 5 Level 5 (4,275 points)

    Hi Carolyn, I'm back...

    I read more carefully your last line, and in fact yes I changed the password of my account, actually not the account... just the password.

    So I logged in with the older password (I though it was no longer needed...) and magically FCP X appeared again!

     

    Thanks a lot!

     

    Piero

  • PieroF Level 5 Level 5 (4,275 points)

    Ooops,

    Sorry I made a mess with the "this helped/solved" buttons! I meant to give YOU 10 points, not to me...! I hope I don't get them, it wouldn't be fair (I cannot give points to myself, right ?)

     

    Piero