5 Replies Latest reply: Mar 27, 2012 9:22 AM by Bob Timmons
Rembert Oldenboom Level 1 (0 points)

Situation: Fritz.box WiFi network with AirPort Express to WiFi enable my Canon Pixma 6700D printer so I don't need to keep my iMac running to share this printer to macbook pro's.


This works well, until (I guess) the printer falls asleep: the printer then cannot be found on the network anymore while the AirPort Express is still reachable via the Airport Utility. Toggling AirPlay on the AirPort doesn't reinitialize the connection to the printer. Tried to print from another Mac: no go either.


The only way to get the printer to work again is by turning it off and on again. But that's exactly contrary to the whole idea of having a WiFi enabled printer: it should just work remotely. IMO the Airport Express is causing this problem: it should reconnect to the printer when a job is submitted.


I cannot change anything to the Airport Express and I'm about to return it to buy a WiFi enabled printer. A shame.


Anyone having a suggestion to solve this?

iMac, Mac OS X (10.6.7)
  • Bob Timmons Level 10 (98,334 points)

    IMO the Airport Express is causing this problem: it should reconnect to the printer when a job is submitted.

    The AirPort Express is not the cause here. It is "always on"....in fact, there is no way to make it "sleep"....even if you wanted to do this.


    Your problem is with the sleep function of the Canon printer.


    I don't have your same model printer, but do have a Canon iP4500 connected to an AirPort Express. It works just fine....always comes out of sleep whenever a print job is sent....even if the printer has been sleeping for days.


    Suggest that you check with Canon support to see if they have updated drivers that you could download and install for your printer.

  • Rembert Oldenboom Level 1 (0 points)

    I don't know how printer drivers can help me: these are installed on the mbp. When the printer was shared to the network via my iMac I never had any problems printing from my mbp.


    Just for the record, I just changed to the Gutenprint driver. A print job now almost immediately pauses the printer on my mpb. On the jobinfo I read: Unable to write print data: g~w. Checked the Canon website: no new OSX drivers for this printer.


    Pity. This solution didn't work. Tried to do something via the cups webinterface but no success either. So, guess I'm stuck.

  • Bob Timmons Level 10 (98,334 points)

    IMO the Airport Express is causing this problem


    As I said, the AirPort Express is "always on". Nothing to wake up or come out of sleep there, so its hard to conceive how the Express might be causing this problem.


    If it really is, we would appreciate your findings in this regard to increase the knowlege base. Thanks.

  • Rembert Oldenboom Level 1 (0 points)

    I'm not saying the AE is falling asleep but the printer is. The AE is not able to wakeup the printer again. I have to restart the printer. I just discovered printing will resume immediately if I disconnect and reconnect the USB cable.


    I really don't know how this could be caused by drivers on the computers.


    On this page http://www.ifelix.co.uk/tech/1013.html I read my printer is just not listed and therefore apperantly not supported by the AE. But the printer does work seamlessly when connected to my iMac, even when shared over the network, falling asleep and needing to be woken-up again. Nothing wrong with my network, nothing wrong with the printer. That leaves the AE to be the culprit IMHO.

  • Bob Timmons Level 10 (98,334 points)

    I'm not saying the AE is falling asleep but the printer is

    Exactly. The Express is not doing anything except passing through the information that it receives from upstream on the network. It is always on, it changes nothing since it is in Bridge Mode.


    It is up to the printer to come out of sleep. It is not doing that.


    You might consider a simple test.....


    Leave the printer "always on" for a day or two. What happens?


    If the printer always prints, then you know that the Express is not altering the signal in any way.


    If the printer still has connection problems, then you can blame the Express.


    I just wonder why I cannot duplicate your issue. If I leave my Canon printer sleeping for a few days and it always comes out of sleep correctly whenever I send a print command. I'm even using a longer than normal USB cable....about 15 feet....to connect the printer to the USB port on the Express.


    True, we are not talking about the same model number....and it's always possible that Canon is using different software for your model. That is why I suggested checking to make sure that your printer had the latest updates.


    For what it's worth, my Express is using firmware version 7.6.1.