13 Replies Latest reply: Apr 12, 2016 10:56 AM by Hawk118
nicholas.he Level 1 Level 1

Hello all,

 

I am hoping to change my 'From' email address in Mail.app in Lion. I have my own SMTP credentails to use my own domain email address in gmail. I would love to use this same 'from' address in Mail.app, but I cannot work out how this works. Is this possible? I want to stop having my Gmail address being shown when I use Mail.app.

 

Ideally, this would also work in the Mail app in iOS.

 

I know that I cannot use my own domain email in iCloud, so for now I must continue to use Gmail.

 

I would love to hear the experiences of powerusers in Mail.app on Lion.

 

Best,

 

Nicholas


MacBook Pro, Mac OS X (10.7.3)
Solved by leroydouglas on Mar 25, 2012 9:36 AM Solved

iMail>Preferences>Accounts>Account Information>Email Address

 

Make change here,

 

or add another email address to the list seperated by comma,  this will give you a drop down menu to choose which address you want in From field.

  • leroydouglas Level 6 Level 6

    iMail>Preferences>Accounts>Account Information>Email Address

     

    Make change here,

     

    or add another email address to the list seperated by comma,  this will give you a drop down menu to choose which address you want in From field.

  • nicholas.he Level 1 Level 1

    Thank you lerodouglas,

     

    That's a great pro tip to use the comma to add a new email address, I haven't seen that mentioned!

     

    Another thing for others to know is that for this to work is that the SMTP settings have to be correct in the 'Outgoing Mail Server (SMTP)' settings at the bottom of the email Accounts section. Also, that your email username for your SMTP settings may not be the same as your outgoing email address.

     

    Best,

     

    Nicholas

  • alexhelsinki Level 1 Level 1

    Hello Nicholas.he!

     

    Thank you for your previous reply, I know that is old conversation, but still I have the same problem.

     

    I've done all you mentioned, I even see two emails now to chose from, but still when I send email from my new custom email, the recipient gets it from my old one (hotmail).. 

     

    You said this (below) - can you please specify a little bit for me? Thank you!

     

    Another thing for others to know is that for this to work is that the SMTP settings have to be correct in the 'Outgoing Mail Server (SMTP)' settings at the bottom of the email Accounts section. Also, that your email username for your SMTP settings may not be the same as your outgoing email address.

     

    Regards,

    Alex

  • jvanhoecke Level 1 Level 1

    Hello,

    It seems that this solution (adding an email address separated with a comma) does not work anymore in OS X 11/ El Capitan ... Can anyone confirm this? I installed El Capitan yesterday and now note I've lost the dropdown menu. Trying to add an e-mail with the described procedure does not work anymore. Any help very welcome! Thanks.

    Jan

     

    ++++ update ++++

     

    Just after writing this comment I returned to Apple Mail and now everything is normal. Weird.

    I assume some latency in updating my preferences (gmail server?) may have been the problem.

  • Kiks73 Level 1 Level 1

    I'm using a gmail account, just installed OS X El Capitan.

    My outgoing smtp is gmail.

    I've added others email senders comma-separated, but when I write a new email I cannot see the dropdown menu to select sender.

     

    I also restarted mail app.

     

    Where am I going wrong?

  • Adam Horner Level 1 Level 1

    In El Capitan this behaviour has changed, and it caught me out at first too because it doesn't migrate your previously comma separated options in to the new format.

     

    What you have to do now is set up Aliases - which are in the drop down box just above the Email Address setting. In the drop down select 'Edit Aliases...' which opens a window in which you can enter as many aliases as you want, and also set the sender name for each one - an improvement on the previous behaviour. Once you have clicked OK on that window, just select the alias that you want to be the default sender and it will fill in your Email Address and Full Name from your selected Alias.

     

    Much better functionality and quite easily discoverable once you get away from the mindset of how it was done in previous versions of Mail!

     

    Hope that helps.

    Adam.

  • John Sunier Level 1 Level 1

    I just tried the above and it doesn't work. Only my business email address appears in one Account and my personal in the other. Yet when I send replies to emails that come in, it is automatically including also mm personal email address and one with just my Name. How do I delete those other two??

  • John Sunier Level 1 Level 1

    Dear Adam,

    That does not work for me. Under Alias in the El Capitan version are just my business email for one account and my personal email for the other.

  • mblocker78 Level 1 Level 1

    John, I too had issue with this until figuring out the following solution.

     

    1) In the Mail client go to Preferences

    2) Verify that Accounts are set up as desired, in this example let's have two accounts set up

    3) Go to the Composing tab

    4) Under the "Addressing" section, ensure that "Account of selected mailbox" is selected

    5) Exit out of Preferences

    6) Find the "Mailboxes" tab below the "Get Mail" and "Compose Mail" icons and click it to expand Mailboxes that reflect what is set up in #2 above

    7a) Click inbox of account 1

    8a) Compose new message

    9a) Send new message


    The email sent will go from inbox selected; in this case account 1.


    7b) Click inbox of account 2

    8b) Compose new message

    9b) Send new message

     

    The email sent will go from inbox selected; in this case account 2.

     

    Hopefully the issue has already been solved but just in case maybe this will help either you or someone else as it may be quite frustrating to figure out! Happy holidays!

     

    - Matt B

  • byluciani Level 1 Level 1

    Hello everybody,

    I'm experiencing same strange behavior. Just today I noticed that when I write a new mail I can't choose sender (I've got 3 different email accounts). Field "From" (with drop-down menu) has been removed.

    In "Mail->Preferences->Composing->Addressing->Send new messages from" it's set to "Account of selected mailbox". No other items are listed.

    I'm not able to set that option again. Before I could choose field From.

    Can you help me?

    Many thanks

     

    Max

  • Aitchb65 Level 1 Level 1

    El Capitan Mail9.2 (3112).

     

    Hi,

     

    I am also looking for a solution to this. The 'From' box says (in my case) <myname@icloud.com> I either want it: empty ;  just with my name ; or preferably my name with the email address of my own domain name : Henry B.... <myname@mydomainname.com>. Having one email address saves me the trouble of telling everyone I have changed my email address, if I change my internet provider. One day I may ditch Mail !

     

    I have tried everything above and Mail in the end just forces me to use either @iCloud.com or @me.com.

     

    Having a 'Reply to' line in the email is only a part solution.

     

    Having looked at the Mail folder in my Library I see various .plists etc. that have the email addresses and Aliases written. Is it possible to change these to get the result that I and others want as I cant see how even with the instructions above (that seem to have been squashed by Apple).

     

    Really hope someone can help.

     

    Henry

  • Marcella_UX Level 1 Level 1

    Thanks everyone - all your answers gave me a huge clue. What I found in my case, is that my husband's name was coming up which was odd. I checked iCloud, my apple account name and finally went into my:

    1. System Pref's
    2. My Admin account (me)
    3. Clicked on "CONTACTS CARD" and BOOM - it was pointing to a newly made card for my husband. Weird!
    4. In the Contact (Address Book) App - I deleted that card (no info on it, just husbands name), found my own card.
    5. With my card highlighted I chose Card -> Make this my card.
    6. SOLVED!
    7. Everything updated instantly with my own name.

    Thanks all!

  • Hawk118 Level 1 Level 1

    I was having this same problem, the "from" option disappeared in drafting emails.   I just went on my email accounts and deauthorized all of them except my main one, then I looked in Accounts/Composing and saw that the email listed to send from was the main one I use. Before it was only the iCloud email.  I then went back and authorized the iCloud email and went back to accounts/composing and in the drop down box both emails were there!  I began to compose an email and the from box was back with the choices.  It took me several attempts at various things in this chain and none work.  I think the key is to get the Composing tab in Accounts to list all your emails and then leave the selection "the account selected." Do not select one in that box, you will then get the drop down.