11 Replies Latest reply: Jun 6, 2014 1:28 PM by gracianadagostino85
Ryneeev Level 1 Level 1 (0 points)

I posted this as a reply in another discussion and have been getting "thank you" replies nearly daily, so I assume this is the correct fix.  This worked for me after my iMessage had not been working for a couple of months.  I was also not getting texts from a handful of my friends at all, but now I do.  This also worked for FaceTime.

 

Just update your date/time settings:

 

Settings

> General

>> Date & Time

>>> Set Automatically:  Slide "ON"...If it's already on, then slide it off, chill for a bit (maybe restart it), then slide it back on.

 

 

I am using an iPhone 4 with iOS 5.1, but other users with 3GS, 4S, and even iTouch devices replied that it worked.

 

If it works for you, give me some likes!


iPhone 4 (8GB), iOS 5.1