Previous 1 2 3 4 5 Next 108 Replies Latest reply: Oct 19, 2014 2:40 PM by Eventsportsmedia Go to original post
  • blah_z_blah Level 1 Level 1 (0 points)

    I had this problem with an exchange account. I found this solution on lifehacker, and it worked!

     

    http://lifehacker.com/5916375/how-to-mark-all-emails-as-read-on-your-iphone-with -one-simple-trick

     

    As a note, I used this trick to mark ALL of my email as "unread" and then used it again to mark all as "read." The offending email was fixed.

     

    Someone else in this forum mentioned it, too. Seriously. This was waaay easier than going through a hundred hurdles trying to find that one supposedly "unread" email.

  • bfatterton Level 1 Level 1 (0 points)

    I was having the same issue and this worked for me!! Thanks! It was driving me insane!

  • Benpalmason Level 1 Level 1 (0 points)

    bd1212 trick worked for me...

    I had reduced total emails in my Exchange account to only 4 emails, still there were 6 unread. The video was helpful.

  • JohnP106 Level 1 Level 1 (0 points)

    I have had the same problem.

    This fixed it for me.

     

    Go to settings>mail, contacts and calendars

    Go to whichever account is having the problem.

    Turn mail off then on again.

     

    Fixes it for me with iPhone 4 with most recent iOS 6.

    I found that this issue comes from searching for an email and the random unread messages appear even when I have no unread messages.

    Hope this helps some people.

  • Shirereiver Level 1 Level 1 (0 points)

    I tried all of the above but in my case they didn't fix it. I have a few different email accounts coming in to my iPad, what worked for me was going to email settings and changing Mail Days to Sync on my Gmail address (which was the one showing as having an unread address) to No Limit. Then switching it back. For some reason this worked. Hope it may help someone.

  • plummer1000 Level 1 Level 1 (0 points)

    The suggestion to turn the mail account off and back on was the right answer for me.  It worked like a charm on my two Exchange accounts that weren't working.  It also took way less time than any of the other suggsetions.  Bravo John.

  • chedkei Level 1 Level 1 (0 points)

    I've tried everything suggested but this is the only one that worked for me! Thanks! :)

  • RT11 guru Level 2 Level 2 (175 points)

    I recently had this issue with an exchange email account. Restarting the iPhone or switching the mail account off/on did not help. There were no unread emails as confirmed by the OS X Mail program. Finally, I logged into the Outlook web application and filtered the inbox according to unread emails. There was nothing in the list (no unread emails) but this immediately cured the unread email badge on the iPhone. Some funny business between exchange and iOS. YMMV.

  • mathchique Level 1 Level 1 (0 points)

    Same thing happened to me, only on my ipad though. My iphone, imac, and macbook all showed no unread emails.

    I went to problem gmail account via Safari and the google site and made sure that all emails were marked as 'read'.

    Then, on my ipad, I went to Settings > Mail, Contact, Calendars > on the problem mail account, I turned off mail.

    Then I turned off the ipad, turned it back on, went back to Settings > Mail, Contact, Calendars > on the problem account, I turned mail back on.

    Voilà, no more indication that there were unread emails in macmail.

  • sscheck Level 1 Level 1 (0 points)

    I had this issue but with 47 emails.  Here is what I did.

    1. Went into my email client (Outlook for Mac 2011) and marked everything in my inbox as unread.  I waited a few minutes until my iPhone showed that all emails in my inbox were unread.  I then went back into my email client and marked everything as read.  I was pleased to find that I know only have 1 mystery unread email on my iPhone which reminded me of the song about the monkeys falling out of the bed.
    2. To get rid of the last one mystery unread email, I went into my iPhone settings and changed the days of emails from "No Limit" to "1 Day" and went back into my emails.  I then changed the settings back to "No Limit" and found the one mystery email in my inbox so I deleted it.

    Hope this helps.

  • mari718 Level 1 Level 1 (0 points)

    Omg THANK YOU!!!!!! My iPhone Mail app kept showing that I had three unread messages even when all of my messages had been read, but this trick totally fixed my problem and it's back to normal. Thanks again for your help!!

  • nicentral Level 1 Level 1 (0 points)

    I did essentially the same thing, but because I couldn't remember what I had searched for, I used a really common word like "to". An unread came up pretty quickly.

     

    Thanks!

  • gotoEngland Level 1 Level 1 (0 points)

    Had this issue with 2 different accounts for probably 3 weeks. Very Frustrating!

     

    All I did to fix it was pick a random email in each affected inbox on my iphone, mark it as "unread", then mark it as "read" again. I was quite surprised when my badge app icon disappeared. I hope your solutions are this easy!

  • katchensw Level 1 Level 1 (0 points)

    Thanks for this suggestion.  I followed your instructions and it worked.  My mail app said that I had 13 unread emails and I have been searching for weeks on how to fix this without deleting my email account and adding it back.  I wonder why this happens.  It happened on my old iphone 4s and then again on my iphone5

  • linuxwil Level 1 Level 1 (0 points)

    For me, I logged onto the web client of my Exchange (office 365) site and it turns out there were some unread tasks that iPhone thought were emails. I marked them as read in my web client and the iPhone updates immediately. Hope this helps someone else! Happy 2013!

Previous 1 2 3 4 5 Next