Previous 1 2 3 4 5 6 Next 127 Replies Latest reply: Jan 16, 2016 5:14 PM by wetherbyss Go to original post
  • Isaac Ruiz Level 1 (0 points)

    After trying a lot of the suggested solutions, here's what finally worked for me. In the home screen, double click on the home button. Do a sustained depress on the mail icon. Click on the "-" that appears on the mail icon. Click on the home button again, just once. Restart mail. Good luck.

  • HarleyBoneDoc Level 1 (0 points)

    Brilliant solution!!!  Everyone with this problem on iPad needs to see your post!

  • nicentral Level 1 (0 points)

    Another solution, and the only one that I can consistently get to work. Go to Settings | Mail | Account with unread messages. Turn off mail and go back to the home screen. Them repeat and turn mail back on. This seems to force a complete sync of the badge and unread count.

  • paynemaine Level 1 (0 points)

    This was driving me mad! This worked for my situation, thank you Shaarp for bringing sanity back.

     

     

    Re: Mail app shows 3 unread emails when there isn't.

     

    22-Apr-2012 13:07 (in response to atyree)

     

    I just had this issue when setting up an email account on my iphone.. I tried everything that was mentioned but to no resolution. I then went into the Email Settings and switched "Mail" to OFF (Do Not Delete Account), then switched "Mail" back ON. This resolved my issue.

  • greenyoga Level 1 (0 points)

    Good thread,it's really helpful for the iPad users,thanks for your sharing.

  • JEL888 Level 1 (0 points)

    dbulter85 and activating/syncing all of the folders (if you have mulitple folders)  available for a mail address (then unchecking them all after the "unread" number disappeared) is what worked for me. (Note that these were MS live accounts).  Strange that the second option which I performed didn't work for the other account live account.  I htink because like numerous persons have mentioned, the problem mail has to reupload into the app for it to realize that they have in fact been read.  And I also agree that the error happens after a search as jessefrom east amhearst said only since I could remember the term and even trying to up the count to 1000, that solution didn't work for me.  I tried numerous solutions mentioned on this first page of answers, and finally dbulter85's worked for the second account.

  • Dominiricana Level 1 (0 points)

    I had the same problem twice and the only way I was able to get that annoying number off of the app was to delete my account and add it back on... It only happens with my exchange account though, so I had to do that whole set up again but it literally took about 30 seconds. It may not locate the email (if there were any to begin with) but I don't really mind I receive all my important ones so it's ok. Hope this helps!!!

  • erswims Level 1 (0 points)

    Thanks, worked for me!

  • ramcdoc Level 1 (0 points)

    Worked for me too, thanks.

  • Spammerboy Level 1 (0 points)

    Had the same "problem" too. Took me a while to figure out that some time ago I added a second account in the GMail app on my iPhone. That's where the new messages arrived. Signed out of all accounts on the iPhone and then signed in with just my account. Problem fixed, my bad.

  • tgav Level 1 (0 points)

    Awesome..that does it!

     

    Have to wonder how many other 2-finger-fixes are out there

     

    Thanks

  • AxeGrrl Level 1 (0 points)

    Isaac, thank you SOOOOO much! Your solution was the _only_ one that worked, and it was easy peasy :)

     

    Kudos!

  • osbole01 Level 1 (0 points)

    Thank you so much bd1212! Your method is the only thing which has worked!

  • Lianabanana15 Level 1 (0 points)

    Hey! Don't know if anyone is still having this problem or if it has already been solved, but I just googled to find the answer and couldn't find it. What I did was deleted my email account and re added it. All of my emails stayed in my inbox when I reconnected it, and it was fast and painless. Hope this helps :)

  • Lianabanana15 Level 1 (0 points)

    Ha just saw all of the solutions as my answer was posted to the end of the thread. Duhhh didn't read far enough

Previous 1 2 3 4 5 6 Next