Previous 1 2 3 Next 36 Replies Latest reply: May 26, 2014 5:49 AM by Sangoma
S. DI MAGGIO Level 1 Level 1 (10 points)

I'm using 10.7.3

iTunes 10.6

MacBook Pro 2.6Ghz 4GB ram

 

iTunes won't play my video anymore and it's been a while I'm not sure when it occured if it's after an update to snow leopard or iTunes updates...

 

When I double click a video I get "This movie requires QuickTime, which is not supported by this version of iTunes." ??

 

...and cannot convert the option doesn't work I get this other message when trying to convert a version for APPLE TV in advanced menu "None of the selected files were converted because they could not be found."??

 

But the movies are quicktime movies in my library and the MPEG-4 plays in iTunes but not on APPLE TV.

From all my videos I get one only going through APPLE TV and when I try opening it it says error occured why opening and never works??

 

It seems APPLE is regularly messing things up in updates to loose people so they have to pay for tech support, I didn't upgrade to iPhoto 11 and cannot import anything anymore into it so my entire library is a dead one ; not a cool way to do business than messing people software so they have to buy newer versions!!!

 

Any specialists that know how to fix this ??


MacBook Pro, Mac OS X (10.6.5)
  • Scripty Level 1 Level 1 (5 points)

    if you get this message, then simply open finder, go to applications, right click on iTunes, open 'Get info" and tick the ‘open in 32bit mode’ box.  If you have iTunes open, close it and reopen.

  • S. DI MAGGIO Level 1 Level 1 (10 points)

    iTunes 6 is 64bit mode if I set it up to run 32 then I loose features of 64bit mode I need to find out why my videos don't play anymore, do you know?

     

    It's saying that it requires quicktime and this version of itunes don't support quick time anymore ???

    This leaves millions people in the street is it really what APPLE just did?

     

    Any way to convert in a compatible format ; when I select the files I get a message saying cannot convert in apple TV compatible format because files could not be found ??

  • Scripty Level 1 Level 1 (5 points)

    No I have no idea why they don't play anymore.  All I know is it happened to me and I did a search online, found this fix and it worked for me.  They still won't transfer to my iPad though as I get the message that Quicktime doesn't run on it, or some such nonsense.

     

    What features of 64bit mode would you lose?  I am wondering if I lost something I will miss.

  • S. DI MAGGIO Level 1 Level 1 (10 points)

    I don't know all the details of 32 vs 64 bit for itunes and no time to search but 64 is an enormous enhancement for any app it's like dual core vs single core and this isn't quite a good example, 64 bit is very powerfull.

     

    It runs much faster and usually 64 bit apps by being newer get more features (or are more compatible with latests hardware) so reverting to an older version everytimes I want to play video isn't working especially if this is for apple TV sync, I'm trying to understand what changement APPLE did that leaves so many people having the same types of issues. Maybe there's some kind of plugins to install in order to fix it like maybe quicktime plugins in iTunes but I'm not good enough with plugins and Lion is new to me so i'm stuck.

  • Wyllyam Level 1 Level 1 (0 points)

    The 32-bit solution has never, I repeat, never worked for me.  I've even done a full reinstall on a clean drive of OSX Lion with a fresh install of iTunes downloading a video of "The Big Bang Theory" that just came out this last thursday and still get the error (just finished the full reinstall to a clean drive now and, no, I didn't do any backup restores.)

     

    The only solution I've found is to remove the video from iTunes, without deleting the file, then import the file back into iTunes.

     

    Switching to 32-bit iTunes to run the file causes iTunes to tell me it needs to open iTunes to play the file then it sits and waits for itself to open until I cancel the process.  The video then plays without audio.

     

    I have noticed that I can stream the files to my Apple TV to play even while getting the error trying to play them on the computer I downloaded the files onto.

     

    As a result of this error, I've had to reduce the amount of content I purchase from iTunes.  no more buying whole seasons at a time unless I do it at the start of the season.  Even then, I'm reconsidering it.  The amount of work required to get the files into a playable status on the computer is simply too great on an on-going basis.

  • ronyGR Level 1 Level 1 (5 points)

    Hi, the 32-bit solution has never worked for me also. I tried to open iTunes in 32-bit but the process hangs-out.

     

    My husband said to me once... I wonder if with the death of S. Jobs Apple products quality could be affected... now I am realizing is true... sorry but true...

  • PalleA Level 1 Level 1 (20 points)

    Thanks Scripty,

     

    That did the trick for me. I was already regretting my first (and probably last) movie purchase from iTunes.

     

    This sort of tweaks would be something to expect on a Windows platform. I'm so disapointed.

     

    Cheers,

    Palle

  • iquot Level 1 Level 1 (0 points)

    It just has happened to me. I buy a more expensive movie to have it in HD, just to discover I can't play it on my mac. This is not honest. What's the purpose to upgrade hardware and software then? They should at least give a notice or warning that if you buy that movie (almost 18 US$), you're going to have to downgrade your iTunes software, which make no sense any way. What's going on in Cupertino, they lost their minds???

    Running iTunes in 32 bits mode (i'll try later, I'm still downloading part of that useless movie, the extra content) it's a downgrade at any effect and it is totaly unacceptable that is required by Apple, the company who actually push to upgrade/update their software. The logic behind this eludes me, I'm extremely disappointed.

  • jkmclaren Level 1 Level 1 (0 points)

    I only started getting this Quicktime error only since I rellocated my itunes library over to a NAS drive. Not sure why this would cause an issue, or perhaps just pure coincidence? Anybody else recently relocated their iTunes library and got this issue, or maybe running their library from a NAS drive? Not saying for certain that this is the root cause but its the only major change I have made recently, all was fine prior to this.

     

    It only affects new movie purchases since the iTunes library move. After a purchased movie is downloaded, it appears in iTunes, but without the film cover picture, just a grey box. 

     

    The fix for me is as Wyllyammentioned earlier which is as he suggested "..remove the video from iTunes, without deleting the file, then import the file back into iTunes." The film cover picture now shows correctly and the movies plays perfectly.

  • gilbreen Level 1 Level 1 (0 points)

    jkmclaren,

     

    I just started getting the QT error and, like you, recently moved my iTunes library to my NAS drive.  I wasn't sure if that was the cause, but perhaps it is since you are experiencing the same thing.

     

    Unfortunately, my internal hard drive is not large enough to support my iTunes Library any longer so I am not sure about my options.

     

    I have also experienced the grey box instead of the movie artwork.

     

    I am able to successfully play back the videos on my AppleTV but cannot use home sharing on my iPad or iPhone.

     

    I have read in another forum that one can download the movie or TV show to their iOS device and have iTunes copy it back into the library and then the file will play as it should but I have not experimented with that.

     

    I did contact iTunes support but all they did was delete the files, have me redownload them, but the issue remained.

  • mdb76 Level 1 Level 1 (0 points)

    I also only started having this problem since moving my iTunes library to an external drive. I worked around this problem by moving the file and reimporting it.

  • Zakster Level 1 Level 1 (0 points)

    Confirming precisely what Gilbreen and mdb76 experienced and valid fixes. I had a large iTunes media library of 1.4TB running from a 2TB FireWire drive with nil problems to iPads and multiple Apple Tv2 units around the house. I have just moved it to a NAS. Got exactly the same issue with new purchased iTunes movie content as they describe.

     

    Deleting (But keeping) the file and then adding it back into the library was a 10 sec task that fixed the issue and I can also stream to iPad now on Home Sharing.

     

    Thanks to all on this post...this had me stumped for a few days.

     

    One thing I have noticed with the NAS mounted media library, is that if the iMac is rebooted or logged off and on, the iTunes preferences revert to the previous iTunes media location...I have to go in and reset the iTunes media location to the new NAS.

     

    Anyone else experiencing this that could shed some light on it would be great.

  • Wyllyam Level 1 Level 1 (0 points)

    The issue is that the drives aren't being mounted before the iTunes app opens.  What I noticed for my setup (Mac Pro with ReadyNAS), if iTunes opens without the drives being mounted then I try to download or update the iTunes database, it will revert the saved location back to the 'default' settings.

     

    I had to put the mounted drives into the start up options for the logged in user.  I had planned, if I couldn't get that to work long term, to setup a script which would mount the drives, wait for the mounted drives to appear, then launch iTunes.  Since I don't often reboot/logoff the computer and it runs on a UPS, I haven't had issues.  Any reboots typically involve me sitting at the machine doing system maintenance.

     

    Message was edited by: Wyllyam - Grammar.. sigh..

  • Zakster Level 1 Level 1 (0 points)

    Thanks Wyllyam, that sounds right. It would make sense that the FirWire connected drive would mount up in time to catch up with iTunes launch, but a NAS would take some additional time to map on the network.

     

    I had left the original media library on the older (direct connected) drive, until I was satisfied that the transfer to a NAS, and subsequent streaming performance to the various ATV's and iOS devices around the home was workable. It is logical that iTunes would detect and connect to the first "visible" media library on launch.

     

    The experiment with the NAS stems from the ever increasing size of the library, and needing to come up with a viable long term hosting solution with RAID redundancy.

     

    Thanks again for the suggested fix, which I will try out. Short of putting an armed guard stationed beside the iMac when I am not at home to prevent unauthorized reboot and log-outs, your idea sounds much more practical...

     

    It is still an irritation (minor), that newly purchase video content needs to be manipulated to show and perform correctly in the NAS mounted library, but I can live with that for the present.

Previous 1 2 3 Next