2 Replies Latest reply: Mar 27, 2012 11:04 AM by Eriksimon
King Nimrod Level 1 Level 1 (45 points)

I upgraded to LP 9.1.6 and when the app is launching it tells me it's running in 32-bit and not in 64-bit. I don't understand why, I am running the latest OS on the latest model MacBook Pro 15". Any ideas on why this happens and how to change it?





  • QtheMusic Level 2 Level 2 (360 points)

    If you mean how do you activate Logic in 64bit, the you quit logic, find Logic Pro in the applications folder (not any previous version, which will have a version number in the title). Press command i, which will open the information window. Uncheck the box that says, "open in 32 bit"





    But if you mean what's the advantage of 32 bit? Smoother running than 64bit if you have 32bit 3rd party plugins. 64bit does work for this, but you can only see a single 32bit plugin at a time. Pain. Plus if you want to stripe audio to a movie, it doesn't work in 32 bit.

  • Eriksimon Level 6 Level 6 (11,950 points)

    This happens because it is a default setting in Logic itself, it has nothing to do with the system it happens to be on. The 32 bit setting is (has to be) the initial setting because of 3rd party plugin software compatibility reasons.

    If you would start up Logic in 64 bit mode, Logic cannot  validate and use any of the 32 bit plugins that a user may well have already installed.

    That would render the 32 bit bridge, which is there to accommodate such 32 bit plugins in 64 bits Logic, useless, as logic cannot "offer" any 32 bit plugins to the bridge. For this very reason (the one time plugin validation by Logic) you will also have to start up Logic 32 bit mode every time you install any 32 bit plugin - and there are enough of 'm about.

    But, all this is not relevant if you have no 32 bit AU plugins already installed and never plan to do so. You can set Logic to 64 bit as explained here: