Previous 1 2 Next 26 Replies Latest reply: Nov 28, 2012 3:18 AM by tobystarr
WindSong Level 1 (55 points)

Java appears to be broken on my machine as a particular web app works on other machines but not on mine.  How do I delete and re-install java?

MacBook, Mac OS X (10.6.8)
  • X423424X Level 6 (14,215 points)

    How do you know it is "broken" and needs reinistallation?  How do you know it is even Java that is the problem with the web pages?   If the code is there odds are very high it isn't "broke".  Code doesn't "break" and if it is then odds are pretty high some other code in your system is borken as well.   But it could be some  data is corrupted some how and reinstallation of the code won't change that.  Anyway, assuming it is a Java problem try the following.


    In your Utilities folder you have an application called Java Preferences.  Launch it and click its Restore Defaults button.  Also probably have all the checkboxes checked (General tab).  See if that fixes your problem.

  • alexisjarome Level 1 (0 points)

    Hi There,


    I also have a problem with the Java installed on my machine.


    For this reason, I can't even open my Java Preferences. Please see attached console message.



    Console Messages.jpg

  • X423424X Level 6 (14,215 points)

    Not sure this will affect anything but try deleting (renaming, moving, whatever) the following file in your account:




    where the X's are a sequence of hyphanated letters and numbers.


    Also might try another account.  And also see if booting in safe mode has any effect.

  • WindSong Level 1 (55 points)

    Running Restore Defaults in Java Preferences was ineffective.

  • WindSong Level 1 (55 points)

    Neither removing the java preferences (plists) nor starting in safe mode made a difference.


    However, java worked when I logged in with another account.  What does this mean?  What clues does this offer about fixing the problem in my primary account?

  • X423424X Level 6 (14,215 points)

    However, java worked when I logged in with another account.  What does this mean?  What clues does this offer about fixing the problem in my primary account?


    Post the list of files you see in the following:


    your login items


  • WindSong Level 1 (55 points)

    Launch Agents:

    Launch Agents.png

  • X423424X Level 6 (14,215 points)

    login items (from yiour Accounts system preferences)?

  • WindSong Level 1 (55 points)

    I really have no idea what they are.  I'm not very familiar with the contents of the Library and their function.  I'm guessing you're going to recommend removing the adobe and google items to see what happens?

  • X423424X Level 6 (14,215 points)

    Open your System Preferences, Accounts, click Login Items tab, and there will be a list of applications that are launched when you log in (similar to LaunchAgents).


    Also, there's nothing suspicious in your LaunchAgents although as a personal rule I always trash  But that's just me. Leave the stuff in there alone.

  • WindSong Level 1 (55 points)

    My list of log in applications is below.  Nothings seems suspicious.Screen shot 2012-06-03 at 6.20.13 PM.png

  • X423424X Level 6 (14,215 points)

    Since you don't have a problem in other account and you do in yours my intial guess was that it might be due to something running specifically in your account that isn't running in the others.  Such things can come from your LaunchAgents and Login Items. 


    There's nothing suspecious that I would think would cause your problem in your LaunchAgents.  That left the Login Items.  You have two I don't recognize. 


    The vzwwirelessd, after a little googling, appears to come from  VZAccess Manager which I guess you use for Verizon.


    The other is Missing Sync Monitor.  I am not sure of that one since there's a whole bunch of different Missing Sync apps and I don't know which one you have.


    It is really hard to believe either of these login items could be the reason for your java problem.  You could try removing the Missing Sysc Monitor as an expirement (select the item in Login Items and click the minus).  It will probably come back when you use Missing Sync the next time. 


    Log out and back in to make sure that process is no longer running.  See f the java problem remains -- I'm guessing it will.


    So if not the login items, and not the LaunchAgents then something is wrong with some account-specific setting (e.g., a preference plist), or a cache, or some other piece of data and not a running process.  That's harder to flush out since there's a lot of this kind of stuff.

  • WindSong Level 1 (55 points)

    I've been using the Missing Sync for my Palm phone (yes, I still have one) for years before the java problem started.  So, I don't think that's the issue.


    Would doing an archive and install of the OS help or would that just keep the botched settings?

  • X423424X Level 6 (14,215 points)

    I think it would just "keep the botched settings".  That's essentially what I said in my first post.

Previous 1 2 Next