7 Replies Latest reply: Mar 28, 2012 3:10 PM by Klaus1
Akaki Level 1 Level 1

Hello. I have an iMac desktop. Recently, my kid tried to charge a helicopter battery using on of the USB ports on the computer.  This led to me getting the following message -"Because USB device was drawing too much power from you computer one or more USB devices have been disabled'. I turned the computer off, disconnected the device and restarted the system. Everything seems to work, but the keyboard. And since the computer is password protected I cannot go beyond the start up screen.

I've tried the procedure for resetting PRAM as described here (http://support.apple.com/kb/ht1379), but nothing happens as I suspect the computer refuses to see the keyboard and on every new startup produces the same error message.

I've tried to unplug the computer, same result.

I shall be eternally grateful if anyone can advise me how to deal with my problem.

Many thanks in advance for any assistance you can render me in this matter.

Reply by Klaus1 on Mar 28, 2012 10:33 AM Helpful

Something here may possibly help:

 

USB and Firewire information:

 

http://support.apple.com/kb/HT1151?viewlocale=en_US

 

http://support.apple.com/kb/HT4049?viewlocale=en_US

All replies