2 Replies Latest reply: Apr 1, 2012 3:16 PM by sueplaza
sueplaza Level 1 Level 1

Hi

After updating  itunes thsi morning I then tried to download Skype. It seemed to download ok but when I went to open it I got the message "You cannot open the application "Skype" because it is not supported on this architecture"  Help please, but can answers be in non technical language if pos!  many many thanks Sue


skype, Mac OS X (10.5.8)
Solved by Tom Gewecke on Apr 1, 2012 6:20 AM Solved
Your OS is perhaps too old for what you are trying to download.  In a couple months  most people will be using 10.8.   You might be able to find something here: http://mac.oldapps.com/skype.php?system=mac_os_x_10.5_leopard_powerpc
Reply by sueplaza on Apr 1, 2012 3:16 PM Helpful
Thank you so much Tom. I have Skype up and running now. You're a star! Thanks again.

All replies