4 Replies Latest reply: Sep 21, 2012 5:31 PM by Mudcat-66
bozdog08 Level 1 Level 1 (0 points)

Hi guys, so I have a bizarre problem where my iphone, my mums iphone and my dad's iphone are all getting each others text messages, it's completely bizarre. Yes we are all on the same account and I believe synced through the same computer. All using ios5 or later and my mum just received a new one today, where she previously only had ios 4.xxx and she didn't receive the texts that my dad and I are getting between each other.

 

An example;

 

I send a text to my mum, it goes to my dad too. My dad sends a text to a third party (only one specifically) and it gets sent to me, though I rarely see what she has sent back, only what he has sent to her.


iPhone 4, iOS 5.1
  • iinami Level 4 Level 4 (1,420 points)

    you all have to set up separate apple id's for icloud and imessage and anything else except itunes if you want to continue to share apps and music on the same itunes. each phone needs it's own email address/apple id or you will continue to receive each other's messages.

  • MssMi Level 1 Level 1 (0 points)

    I have the same problem between my iPhone4 and my husband's 3GS. We're both on ios5.1.1. Every few weeks, I'll receive text messages that he sends to his friends and I'll get their responses to him. We are on the same apple ID. I had AT&T reset our phones. Since this only happens every now and then, I won't know if this works. If this doesn't solve our problem, we'll have to set up separate apple IDs.

  • MssMi Level 1 Level 1 (0 points)

    I should've listened to iinami from the start. His advice was right. After spending an hour on tech support with AT&T and having them rule  out all any network problems, the tech figured out the problem was that my husband and I share one Apple ID and that the text messages were criss crossing as a result. Also, whenever he iMessages me, it shows up on my phone as if I'm texting myself. So I created a new Apple ID for my husband and attached it only on his Messages by going to Settings, Messages, Receive At. Then select Apple ID (it should show the Apple ID that is being shared) and then Sign Out. Then go back to Sign In, but this time enter the new Apple ID and password. This seems to have solved the problem. I was able to keep our shared Apple ID for all other things such as our music and apps.

  • Mudcat-66 Level 1 Level 1 (0 points)

    Go to settings, messages and select send and receive. Make sure just the 1 phone number is selected.