11 Replies Latest reply: Jul 1, 2012 2:51 PM by Ernie Stamper
Zeevkirshenboim Level 1 (0 points)

I have just received a new Nikon D800. Aperture and IPhoto both do not load all photos from the camera and many times the programs hand-up.

I have downloaded the latest add-on to be handle the Nikon D4.


Any available solution?

MacBook Air
  • Ernie Stamper Level 8 (37,545 points)

    Can you explain further was is, or is not happening?  I have the new D800, and am having no problems with imports.  I do however use card readers, and have yet to connect directly to the camera.  Unlikely to do that on any regular basis, as I have seldom done so with my D200 or D300 either.



  • Michael Leichsenring Level 1 (10 points)

    Hi, I'm still using Aperture 3.2.2 because of a lot of problems I have with the 3.2.3 update on my 27" iMac i7 (2009 model). The problems included application crashes and random system shutdown when using image masks.


    So, updated yesterday to the latest camera raw for Nikon D800 using 3.2.2. Today didn't have any problems both viewing and working on D800 images.


    Can you explain what you do when this happens? I can try to reproduce the problem if needed.

  • Jesper_matthiesen Level 1 (0 points)



    I am also having problems with Aperture 3.2.3 and D800 images. Zoom crashes the program every time. Imports works fine. I am using a Mac Mini i5, 8GB mem.


    How did you downgrade to 3.2.2 ?




  • Michael Leichsenring Level 1 (10 points)

    Hi, I have both the 3.1 Aperture trial and the 3.2.2 upgrade on my external disk. Have had some bad experience before with similar updates so I'm carefull.


    To downgrade I simply removed the Aperture application and reinstalled the trial followed by the update. If you search apple support you can still download the 3.2.2 update if you want. The trial can be downloaded from the Aperture product page.




  • léonie Level 10 (85,265 points)

    Michael, unfortunately the Aperture Trial has been discontinued:


    On the Trial download page you find this:

    The trial version of Aperture is no longer available. If you currently have a copy of the Aperture 3 Trial installed on your Mac, you must delete it from your Applications folder before downloading Aperture 3 from the Mac App Store.

    But you may be able to download the full version again from the App Store - I never tried it and would like confirmation: See this post:

    Re: Ap 3 on two computers?




  • Jesper_matthiesen Level 1 (0 points)



    Unfortunately only the 3.2.3 is available for download in the app-store :-(


    Just tried to remove Aperture and re-install. Makes no difference!  Aperture 3.2.3 crashes when I zoom in on D800 images.


    Guess I have to use my old Windows PC instead.




  • Michael Leichsenring Level 1 (10 points)

    Hi Jesper,


    indeed the link has been removed. I actually tested the trial download less then 2 weeks ago and it was working then. Not sure why they changed it now as the trial download was there for a long time. Google still seems to cache a download page but not sure whether it is operational (at Apple - Aperture - Download a 30-day trial of Aperture 3).


    From the App Store you can only download the latest version. So I'm not sure how you can downgrade otherwise. As I bought the original full version I never used the App Store for Aperture.

  • Leighton Level 1 (5 points)

    Hi Ernie

    I have a D800 (also D3 with D4 on order)

    I had no problems importing a folder with images from my D800, when I did a studio shoot two days ago.


    Now, after an outdoor shoot, some of the still images show up "Unsupported Image".

    The videos all show up, and some stills.


    Also the metadata from the camera are not present in Aperture.

    ON the stills that do NOT display the pixel size is 0.5 MP (instead of 36 MP) Maybe this is a thumbnail??

    I am not noticing any slower speed, but I am running 26 GB RAM

    (Running latest update of Aperture 3.2.3, RAW 3.11.0. MacPro)


    Btw interesting aside, shooting D800 with 16-35 4G lens in studio, I am positive I am in focus, yet Aperture does not display "RED" focus square. Possibly metadata issue??? Yet the outdoor shots DO display "RED" square in Aperture.

  • Michael Leichsenring Level 1 (10 points)

    Hi Leighton,


    also using a D800 and haven't experienced any problems with the image format after imports using Aperture 3.2.2. I import by using a standalone CF card reader and sometimes using the iMac build in SD card reader. I went back to 3.2.2 as 3.2.3 continuelly crashed (but there's another topic for that).


    As far as I have noticed all images imported without problems and all the metadata does seem to be there. This includes the focus points except for images I took with manual focus. As I shoot and import more images I will keep checking and let you know if I do experience problems.


    Did you retry to reprocess the masters when it failed to see whether it was a problem during import only?


    Often editing of the D800 files is similar to editing D700 on my iMac 2009 model - with Intel i7 and 8Gb memory. But I sometimes experience extreme slowdowns while (mask) editing D800 files. Not sure yet when it pops-up. Especially while masking it sometimes freezes for about 30 to 45 seconds with a very high cpu load (between 400 and 600%) and it seems without any disk activity. If I redo the same operation it doesn't happen again.

  • Tranchemontagne Level 1 (0 points)

    My pics load OK, but since I got the D800 a few days ago, I've uploaded about 100 photos and my Aperture keeps crashing. Today the library was rebuilt 3 times. Anyone know what to do to get this fixed? All these issues with Aperture (and previous ones) makes me want to switch to Lightroom, even though I love the functionality of Aperture. In spite of using the time machine for backup, I'm really concerned about losing all my images.

  • Ernie Stamper Level 8 (37,545 points)

    This is not happening to me, and my D800 images.  Which version of OSX are you using, and Aperture version?  How much RAM?


    OSX more so than Aperture, when repetively editing lots of images, like your 100, will allow Inactive memory to build up, and does not always surrender it properly to be used by Aperture or other apps.  Have you watched the memory allocation in the Activity Monitor to see what is happening there?  The very large files from the D800 complicate this behavior.