Previous 1 6 7 8 9 10 Next 230 Replies Latest reply: Dec 8, 2014 10:08 AM by bradmcconnell Go to original post Branched to a new discussion.
  • xJoe999 Level 1 (10 points)

    Hi guys, I have the same problem. Since June 2012 after update my Apple TV2 does not see my iMac. I have Mountain Lion 10.8.2 and iTunes 10.7 installed and the latest firmware in ATV2. I have Huawei 622u router. Apple told me it is a router issue but I do not believe them. When I turn OFF and ON Home Sharing in iTunes, they start to see each other. But after several minutes they lose connection. I tried almost everything. HELP PLEASE!

  • ArithonUK Level 1 (0 points)

    Okay, found several things.


    (1) HD Content caused drop out faster. Looking at the issue in detail, I found if I paused the playback allowing a buffer to build up, the network drop-out did not occur. It would seem BUG#1 is if playback overtakes buffer, the unit resets the network stack. This failure is easily replicated.


    (2) Apple Homeshare is lost if the ATV unit is in sleep mode and a restart is required to get it back. iTunes, the router and the PC are not required to be reset. Neither do other ATV units loose the homeshare unless they have also been in sleep mode.


    (3) The homeshare issues are common to other iDevices. Using the "Remote" app on my iPhone or iPad frequently fails to find either the Library or the three ATV units, unless the iPhone or iPad is POWERED OFF and restarted. This puts the issue firmly in the realm of a software bug on the devices. Since the PC running iTunes, the network, and router do not need to be reset to get the homeshare back. In fact resetting the router or restarting the PC or iTunes does absolutely nothing.


    Hope this helps others and Apple, please get your firmware sorted. Systematic testing would be a good start!

  • Dustin Smith Level 1 (0 points)

    I took the advice of another comment in these threads and downloaded a legacy Itunes version, 10.2.2, (in my case the 64 bit flavor) .  I uninstalled Itunes 10.7 and installed 10.2.2 and suddenly everything works.... this is nothing more than some kind of crazy bug in 10.7....  Apple is quite negligent in their slow response to fixing what is obviously a bug.....

  • colinfromdunstable Level 1 (0 points)

    I just uninstalled iTunes 10.7.0 and tried to install 10.5.2 but I get the message "The file iTunes cannot be read because it was created by a newer version of iTunes".


    What do I have to do ?

  • colinfromdunstable Level 1 (0 points)

    OK, I found iTunes Library.itl and renamed it, and iTunes 10.5.2 now starts and runs OK.


    It DOES NOT fix the ATV2 problem, however.


    Does anyone know how to obtain install an earlier version of the ATV software ?


    My ATV simply does not attempt to look for my iTunes system on the local LAN, although it has no problem accessing my apple account on the web. When I click on "Computers" the action is instantaneous, displaying a page telling me to turn on home sharing on my computer. This problem is definitely an ATV s/w problem as it all worked just fine with iTunes 10.5.2 last December.

  • Charmiepoo Level 1 (0 points)

    I've been using 10.5.2 all along and I've had the Home sharing problem since that big Apple TV update. If one goes back to the start of this thread it becomes rather obvious that the issue is with the ATV firmware.

  • HeyBruno Level 1 (0 points)

    Hi, gang. I'm new to this thread, but have been following it for some time as I am having the same issues described herein. Sadly nothing has resolved my issue, either - including getting a new ATV2 from Apple this morning (firmware version 4.4.4). ATV worked for 30 minutes and quit working again. The only thing that I have not yet tried is to downgrade iTunes (currently running 10.7), but I have no real hope that this will solve the problem either.


    Clearly, Apple has sold us a dog of a product, and seems unable (or unwilling) to spend the resources to fix it. We have all been beating our heads against this wall for months, but none of us (nor Apple) has come up with a viable solution to the problem.


    I think we have to recognize the fact that we have spent WAY too much time on this current Apple mistake (remember the Newton, the Cube computer and the hockey puck mouse?) and move on to one of the competing products - Roku, Boxee, WDTV.


    I'm headed to Best Buy now to check them out.

  • colinfromdunstable Level 1 (0 points)

    I have finally cracked my problem. Homeshare photos on WinXP iTunes 10.7 definitely works with ATV restored using this file: "AppleTV2,1_5.0.2_9B830_Restore.ipsw".


    It definitely DOES NOT work with the update which was applied two weeks ago. Sorry I did not take a note of the version number, but if it is dated a week or more ago it is rubbish.


    The restore procedure fails on a PC which has other USB devices connected (I didn't try to find which).


    You have to hold down the shift key when clicking Restore in order to use the file you downloaded, otherwise you just get the latest version from Apple.

  • pcsteve123 Level 1 (0 points)

    After weeks of network tuning, firewalling have finally managed to get ATV2 home sharing with Windows PC. Solution (tested) was:


    1. Open local TCP port 3689 and UDP port 5353 in the firewall(s).

    2. Assign fixed IP addresses on PC and ATV2.

    3. Disable IP v6 on the Network adapter.

    4. *** The Most Important *** disable all other LAN / WiFi adapters in Device Manager except one - only have 1 active adapter.


    iTunes 10.7 seems to try to bind to TCP stacks on each adapter and then alternates (attempting some form of load-balancing) across each one. If using a hard-wired connection you need to disable all WiFi adapters.


    This is not ideal and I can see why many people are frustrated - Step 4 was completely unexpected, but it solves the Home Sharing connection dropping issue for me.

  • colinfromdunstable Level 1 (0 points)

    I have never enabled wired and wifi adapters together, a good decision it seems.


    As I say above, my ATV2 sprang to life as soon as I loaded "AppleTV2,1_5.0.2_9B830_Restore.ipsw".


    I don't have ipv6 on my 6yr old hardware, and ZoneAlarm (free) doesn't appear to allow specific port enabling, but it was not involved anyway as it didn't work with ZoneAlarm uninstalled.

  • Matt_tulk Level 1 (5 points)

    It's got nothing to do its firewall configuration or PC configuration or Ipv6, I'm still running all of the above it has to do the Aptv firmware on the device as stated above.


    This has nothing to do with home sharing at all I have tested this on my IPAD to my windows machine running the latest version of iTunes and works perfect.


    As already mentioned its purely an issue with the Apple TV firmware Apple told me this on the phone.

  • sixand10 Level 1 (0 points)

    Firmware this, adapter that.


    It's a problem that only exists if you connect the AppleTV with wifi.


    Apple need to sort it out.

  • colinfromdunstable Level 1 (0 points)

    Absolutely wrong, I only use wired LAN connection. It is the current firmware - just restore the previous version abd all will be well:




    Google has numerous sites offering this.

  • TxHokie Level 1 (0 points)

    Like everyone else, I've experienced the same problem.  However, it seems to be on the iTunes side for me (I'm running iTunes on a Windows 7 PC).


    When Homesharing is down for me, its down on both of my ATVs, my iphone, and my ipads, and my itunes library doesn't shop up on my remote app.  So its across the board.


    So for me at least, it seems like it would have to be in iTunes, right?

  • Richard Philips Level 1 (0 points)

    I have been having the same problem. I have tried resetting the apple tv to original factory settins, restarting itunes, unplugging everything and then plugging everything back in after 30 seconds. I have also updated the firmware for my apple wireless routers and made sure all other software was up date. The only thing that works is to turn off hard drive sleep in energy saving system preferences while I am acessing iTunes library content.


    This will have to do until apple comes up with a more permanent solution.


    Richard Philips

Previous 1 6 7 8 9 10 Next