Previous 1 7 8 9 10 11 Next 230 Replies Latest reply: Dec 8, 2014 10:08 AM by bradmcconnell Go to original post Branched to a new discussion.
  • to1 Level 1 (0 points)

    Can someone confirm that a laptop not hard wired but using the same wifi signal as the appletv is not working as well. I have two friends set up like this and they are fine.

  • RocketRobster Level 1 (0 points)

    Apple products use multi-cast packets to "find" iTunes on the network. Some wireless routers don't allow multi-cast by default. Go into your router configuration and enable multi-cast or IGMP.


    In my D-link DI-825, under Advanced Network settings, I enabled "IPv4 Multicast Streams". Everything worked after doing this.

  • ArithonUK Level 1 (0 points)

    I've used two routers (both of which support multicast), my iTunes PC is connected wired (only the ATV units are wireless).

    Often you can be watching a film on one ATV, while the other crashes and reports "no network" for a few seconds, then detects WiFi, then Homeshare then comes back up. All the while the other ATV unit is playing just fine.


    Doesn't matter if one, or all three are running. A TV program or film will just randomly stop playing and the ATV reports "no network" - usually in the first minute or two of playback. After that the problem doesn't occur until the next programme or film is selected.


    I tried the "manual DNS of" which made absolutely no difference.


    The 5.1.1 firmware update seems to have made the detection of the homeshare more stable, but made the network drop-out worse.


    My question is this: Why do the ATV's need internet access to play locally streamed content? Is Apple performing some kind of web-based audit or logging, which if failed causes playback to stop?

  • Ryan Samoheyl Level 2 (185 points)

    I think I've finally figured out what was causing problems with my Apple TV home sharing connection. After having my home sharing work intermittently for months I finally traced the problem back to my Canon PIXMA Wi-Fi printer. I also had another family member who is having issues and after unplugging their Wi-Fi printer their home homesharing now works flawlessly just as mine does.  It's been about three days and still no hiccups. Hopefully this advice maybe able help others.

  • p_n Level 1 (0 points)

    I've had similar issues with my Retina MBP'2012 with Mountain Lion v10.8.2 and both my gen 2 and gen 3 Apple TV's v5.1.1. Airplay and home-sharing would work intermittently and usually after a reboot of my netgear router and/or laptop. After much online research, I've tried two changes that seem to have resolved the home sharing issue and airplay issue respectively:


    1. Force my netgear wireless router to use a specific channel as opposed to Auto (default);

    2. Restarted my Apple TV through Settings->General->Restart


    Lastly, a restart of my laptop and voila.


    Since then, both home sharing and airplay is working as expected. Hope this helps.

  • ghost08 Level 1 (0 points)

    Having same problems, none of my Apple devices iPhone 3GS, iPad1, iPad2, iPhone5 connect to AppleTV now, it worked two weeks ago.  Thanks Apple for jacking up the Apple Remote App and AppleTV usefullness.  AppleTV is seen by network and is on LAN.

  • Ryan Samoheyl Level 2 (185 points)

    My experience has been that this is caused by network interference. Try unplugging any wireless devices such as wireless printers and see if this fixes the issues.

  • Lee Besse Level 1 (0 points)

    My configuration is a simple 4 port hardwired netgear router (with Wi-Fi), Apple TV, Macbook Air with external hard drive which contains the iTunes library.  I have no internet connection at the remote use site, so I initially had to turn home sharing on with an internet connection. 


    After disconnecting the internet and moving the gear to a remote site, it worked well for a short time and then lost the home share connection - even though the Macbook Air still had home sharing turned on.  I could still drive the video to the Apple TV using iTunes, and the Apple TV clicker still worked to control the movies, but I could not access the iTunes library from Apple TV. 


    I took it home to troubleshoot and turned Wi-Fi off at the router.


    It has been trouble free since then.


    Thanks, Ryan, for the great ideas!



  • Aurorlite Level 1 (0 points)

    I realize that this is a fairly specific resolution, but you could try similar things depending on your system and OS.


    Sharing system (important bits):


    Windows 7/8 PC

    Latest itunes

    atheros wireless interface

    intel gigabit ethernet interface




    Apple TV 3 starts homesharing fine but then flops out after a run of about ten minutes. You may think that it lasts for longer , even as much as a full length movie, but in most cases that's because the entirety of the media that you watch is actually buffered before the link conks out. So you can finnish your film and then it doesnt do anything else after that.




    In both the wireless and hard-line interface settings (in windows 7 or 8 under Device Manager) there are options for power savings. "Allow windows to shut down this device to conserve power" or something along those lines. In the intel card case they are even more specific and more advanced than that. In both cases, wired and wifi, disabling the power saving features solved the problem and made homesharing run like sap in spring.


    Again, this might not help for people who are having issues with their router etc., but I noticed some people still experience issues with an airport extreme base station, and that really shouldn't be. In cases like this you might want to try this given you're trying to home share with PCs in the loop.

  • ArithonUK Level 1 (0 points)

    Okay I am posting this on all four threads that describe this issue.




    • This is not a DHCP issue. Changing your router, network, DNS settings, re-installing iTunes, wearing a foil hat etc. won't fix it.
    • Repeated reboots of the ATV unit are a temporary fix, but the issue returns - usuallly after being on standby - because most of the proposed "fixes" involve a reboot at some stage, this gives the impression they've worked, but they have not.
    • Using a wired network connection removes the problem, so it is primarily a WiFi issue.
    • The last two firmware updates have made the problem worse. I have four ATV 3's and can confirm this, since they are all using the same iTunes and network but have three different firmware versions between them. Although the iOS "remote" App finds all the ATV's faster and more consistently since the last iTunes update (
    • All four Apple TV's are now all but unusable on WiFi.
    • The problem occurs in the first 60 seconds of playback. If you get past that point, in all but a few cases, the film or TV show then plays to the end.


    If this isn't a memory leak or similar bug in the network stack, then it is most likely a timeout issue with ATV DRM verify to iTunes. So WHY Apple haven't you admitted the problem and FIXED it?

  • Charmiepoo Level 1 (5 points)

    Finally! A voice of reason! :-)


    For some it works better using wi-fi, for others it works better hard wired......and on and on. The one constant here is the ATV itself. There have been several firmware updates since this problem began, yet none of them have included a fix for the issue. I'm beginning to think Apple's tech don't know what they're doing anymore.

  • Boris Rio Level 1 (0 points)

    My Home Sharing connection is dropping while watching TV show episodes I purchased from the iTunes Store - and I think that is unnaceptable. It is also happening when sharing movies from my computer's iTunes Movie Library to the ATV.


    This Apple is not smelling good.

  • Simon69 Level 1 (30 points)

    Mine is now working perfectly.


    Everything broke when the Apple TV update came out - so I blamed this originally.

    Please note that a Mac OSX update came out at around the same time.


    I noticed strange errors in the Mac Mini console log about network sleeping.


    I did this:



    "Mac OS X v10.5.6 or later: A Safe Boot deletes the dynamic loader shared cache at (/var/db/dyld/). A cache with issues may cause a blue screen on startup, particularly after a Software Update. Restarting normally recreates this cache."


    It fixed it on the next reboot, and it's been working for several weeks now.


    For me, a happy ending. I wish you luck.


    (I'm using Time Capsule for my network, Mac Mini for my media, and several Apple TV3's - it you are using Windows then your issue may be different to mine.)

  • colinfromdunstable Level 1 (0 points)

    AppleTV2,1_5.0.2_9B830_Restore.ipsw fixed it for me, never looked back:

  • Monkey28 Level 1 (0 points)

    I just bought the latest version of Airport Extreme, and no drop connection since past 2 days, even no problem after ATV wake up from sleep.


    Also fixed the Airplay problem from iMac too.


    Will update if problem comes back.


    My setup is: wireless using 5Ghz network.


    Mountain Lion


    Itunes: 11.0.1


    Cisco Router DPC3825.

Previous 1 7 8 9 10 11 Next