Previous 1 2 3 Next 37 Replies Latest reply: Jul 28, 2012 9:05 PM by jasonyoumans
t_bard Level 1 (0 points)



I have been trying to upload my iBooks Author ibook for 2 weeks now and no luck. I received the checkmark and the activity log said I had completed everything, but no appearance in iTunes connect. I have communicated with iBookstore Support, but was told to re-upload and when that didn't work was told to be patient (5 days now).


Finally I found some others in these forums with the same problem and have found the errors in the Package History, so I have tried re-uploading, re-uploading without video, and re-uploading with misc. religious relics in my hands. 

My latest Import Error is on the Validation Page and reads:


"Internal error: unknown protocol: bundle schema/20/rng/opf.rng" at Book (MZItmspBookPackage)"

but now the Package History says I am "uploading," which I think means there is just a bad connection, but really I have no idea and even less hope. Also, the Book Assets (book and sample) have a new "repair" button that had never appeared previously. Tried re-applying the assets and uploading but am getting same error message.


So it appears I am losing ground.


Any advice would be appreciated and also, can someone confirm that I should see my submission in itunes Connect within the hour.



iBooks Author, Mac OS X (10.7.3)
  • David Bourne Level 2 (345 points)

    I got that same error. Interesting because there isn't any java in the ibook ;-)


    I tried a ferw things so I'm not sure what worked. I THINK is was the way I added the xxx.ibook and other pieces (screenshots, book cover) to iTunes Producers. I had dragged them on to the iTunes Producer window from the Finder when I got the error. When I chose each item and 'imported' from the open dialog box it worked. Again, not sure if this was the cause of the problem but worth a try.

  • t_bard Level 1 (0 points)

    Thanks David, but I have been trying things like that for awhile. I did try it again just in case, but no luck. With all of these different solutions I am reading (no one of which works for everybody), it sounds to me like the process is just very buggy and, with this latest error message, getting buggier.


    Please someone prove me wrong!

  • cerebos Level 1 (5 points)

    Hi... We have been getting this error for the last 6 days and nothing we tried works... I have emailed apple several times and after recieving a load of generic replies, the last one has acknowledged that they know about this problem and are trying to work it out. Once they fix it they "say" they will email us and let us know... It is very frustrating... books need uploading and we can't then it's taking over 30 days to get approvals for books now when it used to take less than a day...

    What's going on apple??

  • t_bard Level 1 (0 points)

    FYI, I even tried submitting under a different ISBN. No luck


    Let me know if you ever find a solution.



  • ibooks author Level 1 (35 points)

    We had a similar problem and were only able to 'fix' it by starting with a new 'package' and a new isbn.   It confused Apple and resulted in delays, but it did get us past the error message. Flag the old title not ready for sale.


    Our book was finally approved and is now out.


    My hunch is that there is/was a bug in iTunes Producer 2.5 so make sure you are using 2.6.


    Charles Stack


    iBooks Author Guide

  • kevangogh Level 1 (0 points)

    I've got this exact same error, did you find a solution?

  • cerebos Level 1 (5 points)



    I have found that this must be a network IP issue perhaps package drop off etc.. I have managed to upload 14 books this morning from home yet  when I am at the office (which uses a different internet service provider) they do not upload and I get the above error... I suggest (if you can) trying to upload them from somewhere different to where you are having this issue... I have been doing this for the last 2 days... when at work I cannot upload them so I come home and I can... strange!!

  • danielrhc Level 1 (0 points)

    I am experincing the same issue...

  • mmadness Level 1 (0 points)

    yesterday itunes producer was working fine. (itunes connect wasn't but that's another story altogether)



    today, itunes producer on the machine with mac osx lion  started off with an error message that referenced java 1.6 - said i needed to update. i checked -- everything is updated. then the error message got even more esoteric. the epub wouldn't  verify (even though it was not an epub but an ibook file), etc etc when i followed the links that kept referring to epub errors even though the file was ibooks (to add insult to injury the page suggested i work with an apple approved aggregator  to solve these issues)


    so i tested itunes producer on my mac pro tower with mac osx snow leopard 10.6.8 .

    it connects fine. so i'm going to ahve to move all the files to snow leopard machine and see what



    keep in mind that this is on the same network, same isp, so it makes no sense right?

    this is a new development since the latest updates - itunes producer 2.5 worked like a charm...


    itunes producer 2.6 on both machines...


    so the question is:

    what OS is on the error-ing machine?

    which itunes producer version?

  • t_bard Level 1 (0 points)

    Cerebos, you're connection theory looks good, but, unfortunately, my home is my office and while I have tried to install Producer on someone else's machine,  it won't take.


    I also spent a lot of time learning about port forwarding and made sure the iTunes Producer ports were all opened, but that did not change any results.


    Still looking for that magic bullet...



    Thanks all!

  • kevangogh Level 1 (0 points)

    Okay, figuring this out.   I tried to upload on the iMac 27 and got many failures.  Then tried it a few minutes ago on my spare MacBook Pro 13 and it worked! 


    I don't think it's a network problem because the MacBook Pro is on the same network and it worked - it's a computer specific problem. I am pretty sure it has something to do with the recent java update.  The next step is to completely removed iTunes producer from the iMac and try a re-install.  

  • kevangogh Level 1 (0 points)

    Removed iTunes Producer, re-installed - still doesn't work. 


    The difference between the machines - the MacBook Pro has the version of Java from last week, the iMac 27 has the recent java release from a few days ago. I think that is where the problem lies...


    I suggest you not upgrade to the latest java if you wish to upload books, at least until they figure this out.

  • mmadness Level 1 (0 points)

    I reported my issue to apple and i received this email yesterday:


    "We are experiencing a temporary issue with our iTunesProducer uploads, which results in the error below.  Please try to upload again and if you continue to see this Java error, please use the following steps to correct:


    Open the Terminal application, add the following string until Terminal:

    cd /System/Library/Frameworks/JavaVM.framework/Versions

    sudo ln -s CurrentJDK /System/Library/Frameworks/JavaVM.framework/Versions/1.5

    sudo ln -s CurrentJDK /System/Library/Frameworks/JavaVM.framework/Versions/1.5.0


    Press enter or return, then open iTunesProducer and attempt a redelivery.  Let us know your results and thanks!"



  • danielrhc Level 1 (0 points)

    I tried that, but with no luck...

Previous 1 2 3 Next