Skip navigation

Non-Apple Software No Longer Works

4820 Views 50 Replies Latest reply: Apr 13, 2012 4:11 PM by walterfromct RSS
  • Linc Davis Level 10 Level 10 (107,660 points)
    Currently Being Moderated
    Apr 12, 2012 5:16 PM (in response to walterfromct)

    If you can run today's Java updater (it's actually more than a Java updater), it may solve your problem.

  • MadMacs0 Level 4 Level 4 (3,320 points)
    Currently Being Moderated
    Apr 12, 2012 5:25 PM (in response to walterfromct)

    walterfromct wrote:

     

    It looks like Apple has released its Flashback fix via a software update.

    ...

    I'm not sure it'll help me, though, because I can't boot/log-in as the infected user because of the script that went awry.

     

    Will give it a try, though, via the un-infected user.

    Let me know if it doesn't.

     

    As I said earlier, your situation is fixable and I tested it something yesterday, but I'd rather give Apple a chance at it first. I'm hoping they designed it to be multi-user.

  • MadMacs0 Level 4 Level 4 (3,320 points)
    Currently Being Moderated
    Apr 12, 2012 7:54 PM (in response to walterfromct)

    walterfromct wrote:

     

    I'm temped to run a back-up from Time Machine to a point before I ran the Kaspersky script and then try the update.

     

    What do you suggest?

    Best to restore to a point before you were infected, but in checking back I guess you don't know when that was. We can usually tell that by the creation date/time of one of the component files, but Kaspersky probably deleted all but the one we can't see.

     

    If you want to try this first, it might unlock your account.

     

    Open the Terminal app (found in /Applications/Utilities/)

    Carefully type the following command into a Terminal window after the "$ " prompt, substituting your infected user name  for <infectedusername>, followed by the return key:

     

         sudo defaults delete /Users/<infectedusername>/.MacOSX/environment DYLD_INSERT_LIBRARIES

     

    Guess I need to figure out how to put that in a scroll as it needs to be all on one line with spaces between sudo & defaults & delete & /Users..., as well as between environment and DYLD_INSERT_LIBRARIES

     

    At the Password: prompt, enter your current admin account password and hit return (you will not see any typing)

     

    If it says nothing it was successful and you should be able to log out and log back in as the infected user, otherwise it will give you an error message.

1 2 3 4 Previous Next

Actions

More Like This

  • Retrieving data ...

Related Articles

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.