Previous 1 2 Next 26 Replies Latest reply: Jun 7, 2014 11:17 AM by Omniasoft
Jeffrey Fose Level 1 Level 1

I finally figured out how to enable AirPlay with a DLink Dir-655 router. 


The Apple TV when it is not allowing AirPlay ony uses IP/UDP ports 3689 and 62078, but when Airplay is enabled it provides services on IP / UDP ports 7000 and 7100.    7000 is listed as a AFS3-fileserver,  and 7100 is listed as an X Font Services.  (3689 is for Rendezvous Zeroconfig, and 62078 is for apparently used for iphone-syncing).  For some reason ports 7000 and 7100 are not listed by Apple in their well known port list article so it really needs to be updated.  I found out that those were the ports that were being used by using the Fing application (available for free on the iphone and ipad, and if you need to use it, it is a really, really good app BTW).  The other thing that I did on the DLINK Dir-655 was to enable the opening of those ports on IP and UDP.  I don't know if it just needs to be open for IP, but perhaps the good people at Apple can tell us...



Now for the DLink router here are the things that I enabled (note not all of these may be necessary but it works for me now so I'm not changing this now) If you go to slow in entering in the data the Dlink may log you out, so you might want to save your changes between steps. 

1) Advanced >> Firewall settings FILTERING

     a) Endpoint Independent should be checked for both UDP Endpoint Filtering and TCP Endpoint Filtering

     b) Check the Enable SPI box

     c) Click the Save Setting button towards the top of the screen

2) Advanced >> Application Rules

    Make sure that you check the enablement box on the far left to ensure that the the port will be opened when you save the changes.

    Going from Left to right

     a) Check the box at the far left.  This enables the ports that you are opening.  If left unchecked nothing will be opened when you save the changes.

     b) Type in any name that you want in the Name box.  I used AppleTV 3689 so that I would later know why that port was opened.  So just put the number of the port you are opening after the AppleTV text if you find this system helpful.

      c) The Port column has two items one is  Trigger and the other is Firewall set them both to the number of the port you want to open.  3689 is the value you should use here.

      d) The Traffic Type column has one value for the Trigger port and another for the Firewall port.  Set them both to Any. (Note it might work to just open TCP per my opening paragraph.

     e) Under Schedule at the far right set it to Always.

3) Repeat section 3 times.  The first time change 3689 to 7000. The second time change it to 7100, and the third time change it to 62078.

4) Click the Save Settings button towards the top of the screen 

5) Advanced >> Advanced Wireless

    a) Make sure that Transmit Power is set to High

     b) Check the box next to WMM Enable (This is good for when you stream data over your local network to reduce jitter)

6) Advanced >> Advanced Network

     a) At the bottom where it says Multicast Streams check the box where it says Enable Multicast Streams. (You need this to stream music or video etc from your iPad 2, iPad 3, or iPhone 4S )

    b) Click the Save Settings button towards the top of the screen  

7) I rebooted my DLink router at this point by pulling out the plug.  This might be optional, but sometimes the devices need to have this done in order to be seen.

8) Make sure that your AppleTV2 or AppleTV3 is on and that you have enabled AirPLay on them.  If they are not on, they don't appear as an option for me when try to use AirPlay

9) AirPlay dosen't show up as a little app button.  Instead you have to hunt for it.  You do this on your iPad 2, iPad 3, or iPhone 4S by hitting the home button twice quickly. What comes up is your most recently used apps.  If you swipe with your finger to the right you can scroll through all of you most recently used apps, but if you scroll to the right, just after you pushed the home button twice quickly, up will come a little bar for playing video/music etc. Off to the right a bit you will finally see the AirPlay logo that looks a bit like an evelope. Push it and up should list an option to display stuff on your iPad or on your AppleTV2 or AppleTV3.  You will see multiple AppleTV's listed if you have them. if you do, I recommend that you give them different names under the settings for the AppleTV.  You will also see the switch for mirroring.  If you click that everything that you do on your iPhone/Pad will show up on the TV.



iPad 2, iOS 5.1, iPad 3, AppleTV2
  • Sarahtrin Level 1 Level 1

    Thank you so much for this!! I kept calling D link technical support but they did not help me the way this article did. As soon as I completed the steps, my apple tv worked! Thank you thank you!!

  • stevemeister Level 1 Level 1



    Just doing step 6 Enable multicast streams did the trick for me.




  • CathyR Level 1 Level 1

    I have been trying to get my Dir-655 to work with Apple TV for months........NO success at all until I saw your post.


    You are awesome!!!!!!! It works!!!!!!!!!




  • ADay72 Level 1 Level 1

    THANK YOU SO MUCH!!!  My old DIR-655 (hardware version A) had recently died.  I had replaced the router with a new version (hardware B) of DIR-655.  When that happened, both apple tvs (3rd generation) could still access the internet but not my itunes music, movies stored on my shared local drive.  Going with both of your suggested Firewall Settings has me up and running again!



  • fetrobban Level 1 Level 1

    NICE!! I´ve been looking for two weeks for a resolution of the problem of using airplay from my pioneer vsx-922 together with the d-link but didnt find any till now! I also just did the "step 6" and it worked instantly. BIG THANKS!

  • Buegie Level 6 Level 6

    Another "Thank You" for the comprehensive post.  It cleared up both my AppleTV access and my AirPort Express AirPlay access.


    Enabling Multicast Streams got the ATV recognized by my Laptop.


    Opening the Ports got AirPlay re-enabled on my iPhone and iPad.


    Glad to see I did not have to wast too much time in re-inventing this solution on my own.


    Best of Luck

  • Busra Buskari Level 1 Level 1

    MUCHAS GRACIAS!! it worked for aTV3 as well.

    Previously i've tried port forwarding, but failed since i have dynamic IP.

    Apple need to take this as their official troubleshooting.

    Thanks again.

  • pmiller25 Level 1 Level 1

    I thought I'd share a bit of what I've learned about airplay/airprint using Apple TV 3 with the DIR-655 (Hardware B1, firmware 2.03NA) related to the steps in this post.  We also use a software called Fingerprint (from Collobos) that hosts printers from our server to apple devices as if they were airprint enabled.  Works great in the office and is cheap.  However, enabling either SPI firewall (Step 1) or WMM (Step 5b) breaks the airprint functionality.  Airplay to aTV3 worked with either setting on these steps. Otherwise I'd leave WMM enabled for the "increased" performance. Step 2 didn't matter for me, Step 6 is a must for any airprint/airplay setup. 


    To sum up, step 6 may be all that's needed for aTV3, unless you're also using airprint.  For airprint I also had to forward TCP&UDP ports 6631 and 5353 to the computer hosting fingerprint and disable the SPI firewall and WMM.


    Thanks for the great post.

  • Jarlund Level 1 Level 1

    Dude I love you, it totally fixed my problem. Now I can finally move my amp away from my computer, and stream audio over wifi!


    Thanks for taking the time to write this down, been trying to solve this problem for months! :-)

  • Laumon Level 1 Level 1

    Thank you very much for the solution !!! A long time that I have been trying to solve the problem...

  • Mike Sours Level 1 Level 1

    Thanks for the post!  This fixed my airplay issues instantly. I went to go and use AirPrint and it worked the first time. Then it has disappeared...


    Do I need to open up ports for the printer as well?

  • pmiller25 Level 1 Level 1

    AirPrint is also intermittent for me. Not sure what changed- possibly ios6.1. I am running fingerprint 2 and updated firmware to 2.10. Still the same results. If you wait a bit on the printer selection, eventually the printers will appear.

  • Mike Sours Level 1 Level 1

    What is fingerprint 2?


    I am trying to use an HP wireless printer with a desktop and laptop which work just fine printing.  My iPhone 4, iPhone 5 and iPad will not work with AirPrint.

  • pmiller25 Level 1 Level 1

    See my post above for description of fingerprint, which enables non-airprint printers to talk to apple devices over the network (without buying new printers!).  I also tried airprint on an HP printer for awhile, but had mixed success.  As I recall you have to have the printer on wireless for airprint to work, not a wired connection.

Previous 1 2 Next