9 Replies Latest reply: May 20, 2013 12:29 AM by EJW Tas
EJW Tas Level 1 Level 1

Has anyone successfully set up a D-Link DNS320 NAS on their network? The DLink manuals provide minimal to nil instruction for Mac setups.


I have setup the NAS with 2 3TB WD Caviar Green drives, but everytime I drag files to folders on the NAS, the Finder either asks for a password or tells me outright I don't have permission to read/write files on the NAS. Other times when I try to dismount the NAS, I need to reboot the Finder to release the NAS so it can be unmounted.


None of my folder settings (vies, location, view options) stick from one view/setting to the next. I can't see how the drives were formatted (I am assuming Windows-specific formatting, over which there is no control or access to options).


I have set up the read/write access using the DLINK web interface ( and all appears to be normal until I try to use the NAS.


I have tried to fix ACLs and permissions etc with individual folders and with the volumes themselves using Terminal command "sudo chown -R `id -un`:`id -gn` " but this hasn't worked.


Various other sites have been visited (eg http://andycroll.com/2011/07/26/setup-dlink-sharecenter-dns-320-on-mac-os-x-lion / and http://forums.whirlpool.net.au/archive/1617761) but no help there. The DLINK web pages are near-totally useless.


Unless someone else has gotten theirs to work, its going into the bin and I will have wasted $$ in buying the box

MacBook Pro, Mac OS X (10.7)
  • Linc Davis Level 10 Level 10

    That thing looks like a piece of junk, but this might help:


    OS X Lion: Connecting to legacy AFP services

  • EJW Tas Level 1 Level 1

    err, thanks - why a piece of junk - what specifically is yhe issue (or are you basing yr opinion on my problems?)


    I spent a lot of time looking for a NAS that would talk with macs - Time Machines etc are way too expensive for what you get in storage in my opinion.


    the link you provided looks useful but is probably beyond my Terminal expertise - but I will try


    thanks for your efforts and assistance


  • rodney_robles Level 1 Level 1

    You seem to be using Lion, hence, you can check this out:


  • EJW Tas Level 1 Level 1

    Thanks RR for your effort, but I binned the NAS a long time ago.


    I spent a LOT  of time working on it, dealing with DLink techs  here in Australia, and by the end of the game, none of the solutions/strategies offered by DLink or others worked, so it ended up being a complete waste of money and the NAS was binned.


    A shame because I really do need a working NAS (around 6TB) and to date, there is little out there for mac users. Would recommend all Mac users to be wary/avoid DLink NAS unless the situation imprves - A LOT.

  • tonyb1986 Level 1 Level 1

    i was having the same problem and with a bit of fiddling on my part its actually extremely simple to setup and use flawlessly when you know how


    Under the Applications tab there is an icon for Local backups

    enter that then to the left is the time machine option, enable this (AFS will automatically be enabled if it is not already)


    then under time macine settings, share the drives you require and its as simple as that, from there use finder on your mac and you should have 2 or 3 dlink devices (depending on the name or how many drives you have) and you can now freely browse, delete, copy etc and even use the time machine backup utility on your mac!!


    hope this helps as its been a headache for me too!!!!

  • EJW Tas Level 1 Level 1

    Hey TonyB

    thanks for your posting but I trashed the NAS a long time ago - it was such a massive PITA and DLink Aust were unable to help. I am pretty sure we tried all sorts of options and configurations, but in the end it was wasn't worth the stress and angst, so I threw the NAS out - literally binned it. Waste of money and time for me, and lesson learned - keep clear of DLink.

    thanks again, would have been good to have a working NAS..

  • tonyb1986 Level 1 Level 1

    yea i read earlier in the post that was the case! hopefully it may help others too, all round im very happy with my NAS and would recommend them to anyone looking for an easy storage/backup option without paying the price of apples time caplule!


    from what i have heard, the Netgear NAS devices are the best to use and even more so as they are simple to upgrade memory as well as make modifications.

  • luke.lindsay Level 1 Level 1

    (Using OS10.8.3) I too have had no end of problems with my DLink NAS 320. EJW, I know you have trashed yours in frustration and I nearly did the same, but hopefully to help others I am posting this. My goal was to create a password protected backup disk using the NAS. I tried all sorts of formatting and shares combinations and each time copying files failed at some point. The posting by TonyB1986 helped and most of the files transferred ok but I still had permission problems/failure moving old application installers/files from PowerPC days.

    The solution that has so far worked was I reformatted the NAS  as JBOD then using Disk Utility I made a password protected SparseBundleDisk image and saved it to the NAS Volume. I didn't set up any users or shares and just connect to the Volume as Guest. I then open the Sparse image with a password and this setup hasn't failed to copy anything yet and all is secure!

  • EJW Tas Level 1 Level 1

    Hi Luke - interesting to read of your frustrations - you have my sympathies...


    Maybe I am wrong, but doesn't your setup remove some of the benefits of NAS? Are you not functionally equavalent to a couple of password-protected external mounted drives? Am I missing something (happy to be proven/shown where I am wrong) ??

    all best

    Eric (EJW)