Previous 1 2 Next 27 Replies Latest reply: Jun 28, 2015 3:00 PM by Simulator
BrendanfromQLD Level 1 Level 1 (0 points)

Hi,

Since I updated my Apple TV to the latest OS, it only shows the settings and computers icons. This problem seems VERY common and the only advice Apple seems to have been able to offer does not work.

I've tried home sharing on and off, signing in and out, turning on and off, resetting the unit etc. Nothing seems to work.

Anyone got any suggestions other than 'reset your apple tv'?


AppleTV 2, iOS 5.1
  • themarxx Level 1 Level 1 (5 points)

    in Settings, set your location.

  • BrendanfromQLD Level 1 Level 1 (0 points)

    Please, some suggestions that aren't bleedingly obvious. I can change the location to not Australia and all of the icons come back however if I set it to Australia, just computers and settings. If its not set to Australia, it logs me out of the iTunes store and wont allow me to play any content.

  • themarxx Level 1 Level 1 (5 points)

    I've tried home sharing on and off, signing in and out, turning on and off, resetting the unit etc. Nothing seems to work.

    Anyone got any suggestions other than 'reset your apple tv'?

     

    I looked through the list of things that you said you did and did not do. If, in fact, you had listed 'setting location' as one of the things you tried, the sarcasm would be deserved. Are we always to assume that people who ask for help on this forum may not have missed the obvious?  I fail to see how such obnoxiousness will engender a helpful community.

     

    So, a little maturity, if you please. Lest people think poorly of our country.

     

    I had the exact same problem, but when I set the location to USA, I was able to access my Photostream, Youtube, Internet Radio and a whole bunch of silly man-games. I use the US itunes store because someone gifted me a bunch of iTunes Cards from the US to start me on this appdiction.

     

    Apple TV gen 2, iOS 5.1 updated yesterday.

  • Dave Calhoun2 Level 1 Level 1 (70 points)

    Doing a restore was the only thing that would fix mine. Btw, I had two of my appletv's do the same thing on the same day. So I don't believe this is a network issue. It's a problem with the appletv software. If it was a network issue then the restore would not have fixed the problem.

     

    dave

  • ramjifromcoimbatore Level 1 Level 1 (0 points)

    I was advised to go to <Settings> ,  <i Tunes store> and choose <location> and tick ".

    Unites States". I did that and the problem was solved. btw I live in India.

     

    Ramji

  • HACKINT0SH Level 5 Level 5 (5,755 points)

    I see this problem a lot on even 3'rd gens. Power-Cycles sometimes helps.

  • Wallabebe Level 1 Level 1 (0 points)

    Here is the strange thing that I have seen: where computers and settings are the only options, the normal lag I experience when streaming from a local computer disappears. Please explain that!

  • gee-1 Level 1 Level 1 (10 points)

    hey this seems happened a month ago... have u found any solution... i am experiencing the same issue... updated apple tv and nothing else except settings and computer... and i changed location but then i couldn't log in since it says that my apple id doesnt allow me to purchase things in usa... (( pls help... in this way i cannot even access icloud

  • BAMedia Level 1 Level 1 (0 points)

    Hi Brendan,

     

    Have you tried going to Settings --> General --> Restart ?  It worked for me on this problem. Try that first.

     

    If that doesn't work, you can also unplug power and your network cable (for about a minute), reconnect everything, and then do the above.

     

    If that doesn't work, then go ahead with a Reset, which is a pain.

     

    Good luck,

     

    BAMedia

  • devryoctane Level 1 Level 1 (15 points)

    This happens to me when I've lost the network connection on the Apple TV.  A router change for instance can cause this.  You can always go in the settings of the Apple TV and check the current connection to verify this.

  • aquinta Level 1 Level 1 (0 points)

    I did use the Restart option and it worked!!! Thank you

  • brookswholloway Level 1 Level 1 (0 points)

    We just initiated a 1-1 at our high school and I have been trouble shooting a lot of the problems with the iPads I see here. Some of them coming from the company that installed them, some of them being from the network at our school. The "computers and settings" issue for a majority of the Apple TV's that I have troubleshot has come from a problem in the CAT5 cap that was put on from the company that installed. The problem being that the wires were showing past the end of the cap. A simple file down of those wires to make them flush with the cap solved a lot of the problem. Where the CAT5 was not the issue, resetting the device, updating the software, setting the location, and even setting a static ip were all strategies the solved this issue.

  • peaceJ Level 1 Level 1 (0 points)

    Yes I to had the exact same problem (UK) with all itunes everywhere in the house Apple Tv 3, Mac itunes and Iphone Itunes.

     

    What you need to do is access your router settings online for example mine is 192............ into your adress bar and then the rest of the digits (if not sure look it up). once in there you need to head on to the advanced settings and from there you need to reset your enternet cache.

     

    Then hopefully it will work! dont ask me why it worked, it just worked for me

     

    Jack

  • ex razorfish Level 1 Level 1 (0 points)

    I had the exact same issue appearing for the first time today. I have two Apple TVs 2nd gen with iOS 6.0. Both have been working great for over a year. Did the iOS upgrade a few weeks ago and didn't notice a problem. But today both devices showed the Computers and Settings optins only. As I searched the web for a solution one of the devices fell into screensaver mode and when I woke it up (by pressing the center button on the remote), all the menues were back. Verified the same thing with the other device. Strange, but it worked for me.

Previous 1 2 Next