9 Replies Latest reply: Sep 14, 2012 11:45 PM by seasthesky
nickbald Level 1 (0 points)

I have recently updated from a 3GS to a iPhone 4S with IOS5.1.  I run my small business using Microsoft Exchange 2003 hosted by my ISP.  This arrangement worked fine with the 3GS but I'm having problems with the 4S.  When opening mail it is either endlessly "connecting" or "checking for mail". Push mail works OK but often only downloads the header and not the full message - when you open the mail it is always "loading" the rest of the message.  I have tried deleting my iCloud account and resetting my networks as recommended by others but neither have solved the problem.  I've also checked my mobile provider's (Vodafone) website and also my ISP's (BT) website to see if others have the same problem but no-one is reporting the problem on either site.  So it seems to be with IOS5.1.  Help Please!

iPhone 4S, iOS 5.1
  • jawec Level 1 (0 points)

    I bought the new 4s mid feb, set up four email accounts (all using different webhosts)  to be pushed to iphone - all good for 6 weeks , able to send and receive emails from my 4s.


    For no reason 2 days ago a problem occured with sending email from my 4s and also the phone started to continually check for mail. Firstly unable to send emails on just one of the email accounts from the 4s - went to outbox and sat there. Then today unable to send emails from the other two email accounts from the 4s. 


    Receiving mail sent from elsehwere has experienced no problem.


    had to resolve problem by enabling the alternative server for gmail on the 4s given the primary servers for the three affected email accounts no longer worked.  Successful.

    I have this question too

    Is there any other solution so that the primary servers work as they should do?

  • nickbald Level 1 (0 points)

    In the 24 hours since I first posted this question I have continued to have the same problems.  i have also had the email app freeze on me and had to restart it.  Tonight I have done a complete restore of the software via itunes but the problem persists.  I'm now very frustrated and out of ideas how to get this problem fixed.  Help gratefully recieved! 

  • saltrun Level 1 (0 points)

    This is the first time I have been able to find others with nearly the same problem I have been fighting now for months! I have the 4s and am using Sprint. Have added 2 Exchange accounts. Exchange server is 2010 and from GoDaddy. I installed the two accounts and it seemed fine for a few weeks and then all of the sudden I started getting hung up at "connecting" or "checking mail" for long periods of time and the battery would drop quickly when this happened too. Once that started I also had loading issues where the email wouldn't fully load or it it did it took forever. When I go to forward and email it sometimes takes forever to load before I can send it. Sometimes sendning takes forever too. I also notice that synchronizing of contacts stops whenever these emails problems start too. Sometimes turning the phone to airplane mode helps and other times a full restart helps but then it doesn't seem to matter at all. It doesn't seem to make any difference if I am using the mobile or a Wi-Fi connecting when it goe into this mode. The real tough part is that sometimes it works fine at random times throughout the day or night. In working with Sprint, GoDaddy, and Apple the only thing that has seemed to work is to remove the account, then create new passwords for the email accounts, and then add them to the phone again. It works like new but then within days it's back to the same problems. I am on a mission to figure this out for sure. Sprint has confirmed they have no issues with their network in my area. GoDaddy has installed my accounts on other Iphones and they worked fine and I had the Apple store "restore" my phone last weekend. Right now I am trying to run only 1 Exchange account on the phone and I installed the other on my wifes 4s Sprint. Both appear to be working normal (good) right now but we'll see how long that lasts. My only other idea is to try this on an AT&T or Verizon and see if I duplicate the same issues. All my employees run 1 Exchange Account on the same 4s on Sprint and don't seem to have any issues. Another friend has 2 Exchange boxes from GoDaddy on the 4s with AT&T and has no issues. All I know is that is has been VERY frustrating and I am wishing I had my Blackberry back in regards to the email relaibility I had then. I hope we can find the fix!!!

  • nickbald Level 1 (0 points)

    I solved my problem by leaving the UK for a weekend break in Europe. When I returned and my phone reconfigured my 3G settings everything started to work normally again. I went to the Apple Store genius bar in London where they explained the impact of resetting the 3G settings. They advised that if it happened again I should go to Setttings>General>Reset>Reset Network Settings which would have the same effect. I hope that this helps.



  • saltrun Level 1 (0 points)

    Thought I would share the latest. After getting with Sprint and having them so a Data Provisioning on my phone, the email seemed to work fine again but only for a few days and then back to the issues I described above. I now have the same issues regardless of on 3G or WiFi and on the Iphone and Ipad 2. I had it narrowed down to GoDaddy at that point since I have exhausted Apple and Sprint options. I called GoDaddy today and they finally advised that their servers have exceeded capacity and they are trying to add more and bring them online to help with this issue. They also said their calls for my same issue have greatly increased in the past 30 days. This makes some sense as I notice that sometimes of an evening, when I would guess email traffic is slower, the email works better in synchronizing like normal. Still a VERY frustrating scenario and one I'm not sure I can wait for them to debug. I had moved our Exchange from Intermedia back in January thinking that GoDaddy would be just as reliable while a major cost savings. Now I am starting to see where the 50% savings came from. I'm not 100% sure that this really is the problem but will advise once I have more to share.

  • EnotsIT Level 1 (0 points)

    Saltrun, do you have any updates on this? I am having the same issue, but it is with our own Exchange server (2003) and others iPhones are working correctly just one is not. We have deleted the email account and added it back, which fixed it for about a week, but now it is back.

  • saltrun Level 1 (0 points)

    I use multiple Exchange accounts, all Exchange 2010 and hosted on Go Daddy. After no improvment from the scenario laid out in my 4/27/12 post, an additonal call to Go Daddy, I was connected to a "Exchange specialist" this time, who I found to be VERY experienced and helpful. After reviewing the history on all the actions taken and symptons, they advised that my computer had likely corrupted the Exchange Email Boxes at some point and that I needed to delete them. I did do this and did not recreate them for 7 full days to make sure they were completely deleted from all Go Daddy servers. I recreated them on May 10th and since that time I have had zero issues. I believe at this point the Exchange boxes were indeed corrupted. I will post anything else that develops.

  • abratt Level 1 (0 points)

    Having the same probelm with Icould and Exchange from Intermedia. Works for a week or two and then stops.  I have gone to using a print app that checks the icloud email and abandond the mail app.  Saltrun.  Has deleting the account on go daddy and waiting solved the problem?  Seems to me it a problem with the OS on Iphone 4s.


    any update from anyone would be helpful

  • seasthesky Level 1 (0 points)

    just bought an iPhone 4S today and I use Fetch settings with a Gmail account and this is happening to me


    tried multiple reboots, powering down several times, etc. also tried reducing to "1 week" the back emails, deleting everything from the inbox -- nothing worked


    I did what @nickbald suggested -- Setttings>General>Reset>Reset Network Settings and it worked for a minute (email stopped "Conntecting..." interminably) until I went in to change the setting back from 1 week ...


    SO -- I went in and changed the sync back to No Limit first then Reset Network Settings again, and although my inbox is not restoring the emails older than one week, they are in All Mail now and both by Gmail accounts are getting mail and then ... stopping! which is all I can ask for at this point.