Previous 1 2 Next 23 Replies Latest reply: Jul 19, 2013 6:44 PM by redryderharlequin
gobucksgal Level 1 Level 1 (0 points)

There are six albums in my music library on Itunes (10.6.1) that do not have artwork. When I try to add the album artwork manually, under "Get info" for the songs, there is no option for artwork, no place to paste it in. If I try to paste the artwork into the large window in Itunes (on the left menu) for the current selction (drag here), the artwork does not save. These are all imported from retail CDs directly into iTunes, so how can I add the artwork?


Windows 7
  • simujoe Level 1 Level 1 (5 points)

    I have just started having the same issue.  I even tried to restore to the last version but after the restore, I still had the newest version of iTunes.  I knew I shouldn't have updated my iTunes without checking the message boards!!  When will I ever learn? 

  • turingtest2 Level 9 Level 9 (56,395 points)

    What format are the files in? You can't add artwork to .wav files. iTunes will also fail to add art to files that are read-only or for which it doesn't have the appropriate security permissions. (Your account and system need full access rights).

     

    tt2

  • gobucksgal Level 1 Level 1 (0 points)

    I'm not sure what you mean by "read only files'? and Account and System "full access rights"?

    All of my iTunes albums with this issue were imported via iTunes. But I also have many other albums in my library with Artwork that were imported via iTunes with the very same settings!

    Most of the albums imported with iTunes have artwork. Some added art automatically, some allowed me to add art in the large artwork box or small box under get info, but some did not have an option at all for album art to be added at all or wouldnt paste the file in the small window that was available under "get info". What I discovered is that, even though I had artwork for 95% of my albums imprted via iTunes,  the default setting was for them to imported into iTunes as wav files,  The only way that I found to add artwork ,to the albums without, is to re-import all of the albums that had issues and change the import settings to apple lossless. I just now changed the import file settings. What a pain!

    And this still doesn't explain why all the other albums imported as wav files allowed me to add artwork! I also have a single that is an MP3 file and cannot add artwork to that. Thanks : )

  • turingtest2 Level 9 Level 9 (56,395 points)

    If iTunes can find a match between your .wav album and one in the store it can associate downloaded store art with the album. There is no other way to connect art with .wav files.

     

    For your mp3 file that won't take art right-click on it and then select Show in Windows Explorer. Right-click on the file and click Properties. Check the file is not marked as Read Only. See the security tab for details of access rights. If that doesn't fix things then examine the file with mp3val.

     

    .wav files take up a lot of room, and can't store art and other tag information. You might find my script ConvertFormat useful. If you opt for Apple Lossless encoding you should be able to halve the size of the files while not losing any audio quality, or you can choose mp3 or aac at 320k or 256k if you are happy with the results and want to be able to squeeze even more tracks onto your devices.

     

    tt2

  • gobucksgal Level 1 Level 1 (0 points)

    My mp3 file is not marked as read only. I don't feel comfortable with the mp3val. I will try the ConvertFormat script  for the song that doesn't have an artwork option. This is more work than it should be to add artwork to an mp3 on itunes. Thanks for your help.

    Apple, please fix this glitch. Artwork should be a feature that is easy for an average user to enjoy!

  • turingtest2 Level 9 Level 9 (56,395 points)

    mp3val is perfectly safe and will detect & repair errors in mp3 tag structures. Alternatively you can try right-clicking on the file in question and using Convert ID3 Tags > None a couple of times then Convert ID3 Tags > v2.3. You may then find you can add art.

     

    tt2

  • Be-atleRJE Level 1 Level 1 (0 points)

    I am using iTunes 10.6.1 on a new Mac and having the same artwork issue. While manually copy/pasting JPG artwork via any method (one at a time in the large artwork pane, all album cuts at once, etc.), it appears to work. However, when you move to another song in the playlist and click back to the song with the new artwork only a "solid black image" fille the artwork pane. This is the same exact issue apple caused in a previous update of iTunes (i think during the 9.x era). You'd think they would test this basic functionality.

  • philipfromsa Level 1 Level 1 (0 points)

    I had this problem and it drove me nuts but I finally worked it out.

     

    For some reason the albums that would NOT accept their artwork had tracks in itunes that were aliases, not the actual song file itself.  No idea why.

     

    But as soon as I found the 'original file'/folder for the album, I deleted the alias files, reimported the 'real/original album/tracks and all was great.

     

    So make sure your rogue albums are not using aliases to play

     

    Good luck

     

    Phlip

  • surfkbunk Level 1 Level 1 (0 points)

    After much searching.  And after much frustration!  I have found the magic solution!   Add artwork to the WAV files that iTunes does not recognize.  No more grayed out artwork tab.  You will, however, need to re-download the music file from the CD

     

    1) Insert Music CD

     

    2) When iTunes pops up, Exit iTunes

     

    3) Next, either access the CD file from "Finder" or the "CD Disc Icon" on your desktop

     

    4) Double click the CD

     

    5) Drag all songs to your desktop

     

    (I consider myself an audiophile, so note: these will transfer as AIFF files, not WAV.  AIFF is stilll a lossless format.  There is absolutely no compression here.

     

    6) Click the song on your desktop.  And wallah.  If you go to iTunes, get info, and you now have the option to add Artwork!! 

     

    Optional: Goto Finder, then search iTunes.  Click through until you get to your music folders.  Then create new folders for each new CD that is downloaded. All music now resides in your your iTunes folder.   You can drag the files directly to the newly created folder as well and eliminate the step to your desktop.

  • Granite Apple Level 1 Level 1 (15 points)

    Having same issue with iTunes 10.6.3 on some (but not all) songs I burned from CDs.  In my case all of the song meta data for these tracks is read only.  Other songs recorded using the same settings and formats let me edit meta data and attach pictures without issue.

     

    File permissions look fine, iTunes isn't pointing to aliases, and I'm using m4a format, so WAV isn't an issue.

  • surfkbunk Level 1 Level 1 (0 points)

    I just discovered an alternative way to convert existing WAV files to AIFF files without re-downloading the CD.  This assumes the file on your MAC is a WAV file and does not have artwork.

     

    1.  Goto iTunes -> Preferences -> Import Settings

     

    2.  Select "Import Using" filed drop down menu, and select AIFF encoder

     

    3.  Got to iTunes library and highlight the song(s) you want to convert to AIFF files

     

    4.  Goto the menu bar at top of iTunes and select Advanced -> Create AIFF version

     

    You will now have 2 files of the same song.  The original WAV and an AIFF version. 

     

    You can now add artwork to the AIFF version.

     

    I then delete the WAV version.  Again the point is you don't have a lossy formatted song.

     

    If you need to download from a CD, you can download this directly as an AIFF file by following the steps above.  Do not download as a WAV.

     

    Sorrry for giving a more round about way of getting to the same place in the previous post.

  • surfkbunk Level 1 Level 1 (0 points)

    To Granite Apple,

     

    If you do want to download to a lossy file, such as m4a, I would suggest trying to convert the m4a format to the standard Apple lossy format, which is AAC.  You can follow the same steps above, but instead of choosing AIFF, choose AAC.

  • sandwichman Level 1 Level 1 (0 points)

    I've found a way that seems to work for me;

     

    1) Create an MP3 file (I used 'Audacity') that is 2 seconds of silence. Keep this file as a template that you can edit the tag of again and again using something like 'MP3Tag'.

     

    2) For an album of interest, take your 2 second MP3 file and edit the tag with album, artist and artwork in question.

     

    3) Add the album folder to your iTunes library (it will pull in the mp3 file and .wav files).

     

    4) Select the .wav files in iTunes and right click to choose 'get info'. Then fill in the album and artist, and set the track numbers. That seems to be enough to tie the .wav files to the MP3 file when it all gets indexed.

     

    5) Adjust the track number of the MP3 file to be the last track of the album.

     

    6) Sync the whole album (with the MP3 file) across to your device (Ipad in my case).

     

    This works for me, presumably because the software looks in every file for some artwork and finds what its looking for in the dummy mp3 file, and applies it to all files withe same album and artist file names.

     

    ... or something like that.

  • turingtest2 Level 9 Level 9 (56,395 points)

    I'd still recommend switching to Apple Lossless, but that's a nice trick.

     

    tt2

Previous 1 2 Next