Previous 1 2 3 Next 105 Replies Latest reply: Mar 24, 2014 9:43 AM by amitd
jjosep Level 1 Level 1

Hello, and thank you for your time.


I have been having problems with home sharing; my apple tv 3 disconnects randomly ( at least I think randomly) from home sharing.


I can be in the middle of a movie and it disconnects. I cant use Airplay either, the airplay icon dissapears from iTunes.


I sometimes get the iTunes error (-15006) when trying to connect via airplay from my MBP to the ATV3.


When the ATV 3 is disconnected or "failing" to connect to home sharing and the cursor is hovering on the "Computers" section of the ATV3 it reads: "iTunes libraries that have Home Sharing turned on using will appear in Computers". It tells me to turn on Home Sharing on iTunes... IT IS turned on.


I have tried turning on/off the modem, restarting the apple tv, restarting my laptop and it doesnt seem to help. I've tried connecting the ATV3 with wi-fi and ethernet, it still haves the problem.


I've read that my modem could be the problem, some issue with the ports. I have a Thomson TG585V8 modem/router issued by mexican internet/phone company TELMEX. Maybe setting the ports to the correct ones could fix this?


Devices involved:

Apple TV 3

MacBook Pro with OS X Lion

Vaio Laptop with Win7

Thomson TG585V8 modem/router.


Any help is greatly appreciated.

Apple TV (3rd generation)
  • manpowre Level 1 Level 1

    go to your network adapter, either wifi on computer which hosts Itunes, and disable IPV6.


    This solved it for me, and been working for hours now this morning, streaming out the favourite shows to my kids.


    I read this in another thread and tried it, and now its been working for as long as I even has had since I got my new ATV3.

  • Leduromax Level 1 Level 1

    I'm sorry to  you exactly turn IPV6 off ?

  • manpowre Level 1 Level 1

    on windows 7, go to control panel,

    then choose network and sharing center.

    on left side choose change network adapters


    if you use local network cable, there should be a icon called local network connection. right click on this one and choose properties.


    deselect IPV6. (IPV6 is the new TCPIP protocol replacing IPV4. but many routers in home network doesnt support it, and we are still all using IPV4, atleast until apple comes with a fix for this).


    good luck..


    mine ATV3 has been streaming just fine all day, except that itunes crashed mid day, but that is a different issue most probably anyway.

  • Kelly670 Level 1 Level 1

    I'm having exactly the same problem. I've also got Lion OS, Apple TV 3 and the Thompson TG585 router from Telecom. I'm pretty sure it a problem with the router

  • jjosep Level 1 Level 1

    No, I don't think it's a problem with the router, as a huge amount of users are getting this issue, you can search for threads on the forum and get an idea of how many people are affected.


    This seems to be a firmware issue with the Apple TV and/or iTunes.

  • ZenFury Level 1 Level 1

    I have this, among many other issues with the ATV 3.  I drops home sharing, cannot airplay, has buffering issues when watching content, cant use the ios remote app more than once,, etc.


    something is wrong with apple tv 3.  i have two ATV 2's, and they have none of these issues, both work perfectly (well, except that one of them wakes itself from sleep somehow, but thats not a huge issue for me).


    setup is all apple


    iphone 4s

    2 iphone 4


    2 ipad 2

    imac 2012 (one month old)

    5 ipod touch 4th gen

    2 apple tv 2

    apple tv 3

    airport extreme (one month old)


    all are up to date with software, firmware, etc. . .  I had sooo many problems when itunes was on my toshiba laptop.  so many many problems, so i bought the imac.  now everything works, except this dang ATV3.  at first i thought i might have gotten a bad one.  but i started to see daily that my same issues popped up for many many other people.


    unfortunately, because the atv3 is the 1080 hd and the only one that takes advantage of my tvs' capabilities, its in the living room, so affects the whole family.  its the only one used daily.  this is so frustrating.  i spent months dealing with issues, and to have them all fixed, up until i got this atv3, well its just sad really.  please apple.  turn back the clocks to a time when the user experience wasnt just something you talked about being important, but actually *believed* was important.  please fix this.  and quit putting out products that seem to bet buggier with each new iteration.

  • bregosanto Level 1 Level 1

    Hi, my ATV3 went on the blink last night. It suddenly lost internet connection and therefore resulting in the loss of AirPlay.

    Reset and Restarted the device and my wireless box (an Airport Extreme). The ATV3 can see my home network but it cannot connect to the internet via it.

    My Macs and ipads can so the internet is working.

    Seems that there is an issue with ATV3?!

    Apple can you help?

  • SoundForSound Level 1 Level 1

    Home sharing with the new Apple TV / iTunes update is just broke.  Only works for a bit unless you restart iTunes or disable / re-enable Home Sharing.  Use to work great until the last updates.  This is not a network (router, firewall, ...) issue - just a (bad) regression in Apples software.  Hopefully they fix this soon, hard to believe its been broke this long already.  The Remote app update also fails to connect to Apple TVs (but does connect to iTunes) for many people as well.  Poor QA all around. :(


    I have yet to see any suggestion that actually works other than reverting to previous versions of fwr / iTunes - which is a pain / joke to do.


    There are a *ton* of posts about this:



  • ZenFury Level 1 Level 1

    well, it was, up until today, possible for me to connect to home share with my ATV3 if i restarted.  now that no longer works.  no matter what i do, i can no longer homeshare.  infuriating!!!!

  • modey Level 1 Level 1

    I'm having the same problem, bought this today, tried connecting to my iTunes library, connects, plays a bit of a song and then drops out, it then says home sharing must be turned on..IT IS!


    Sometimes it loads the library, other times it just says cannot load library .


    I presumed it was a problem with my router?

  • bonnie289 Level 1 Level 1

    I, too, have this problem of intermittantly disconnecting from the iTunes library.  I have an Apple TV 3, which was just installed.  The Library being used is on iTunes  At first it worked great, then the problem started.  Interestingly, though, we could access the movies from the Movie icon sometimes, even though we couldn't access it through the Computer icon.  Sometimes it was just a bluff - it looked as though we could access it, but the wheel just kept turning.


    Could it be that the is creating the same connectivity issue as the  This is maddening! 

  • yohst Level 1 Level 1

    I too have ATV3 slowness issues though not as severe as some of you here.  It did drop home sharing from time to time but it would come back after a while (a day). It would also come back when I did a hard reset on the router (Linksys). I had experienced slowness issues from my PCs as well which a reset of the router fixed also so therefore I contributed all this to a crappy router and replaced the dang thing with an airport extreme.  After that, no more home sharing issues.


    But still slow, extremely slow start ups and spotty connections to Netflix i.e., stops for a while than picks back up.  The overall network speed internally as well as outbound connections from my PCs and Macs is fast so I don't think this is a router issue. Watching netflix show from the PC or Mac never fails.  It seems rather plausible the dang Apple TV3 has problems...

  • ZenFury Level 1 Level 1

    Could this be why ATV3 is having so many problems?  Read down, they are using A5's where one core tested bad, so they didn't have to throw them away.  Terrible . . .


  • yohst Level 1 Level 1

    @ZenFury: That is not a very informed article how the silicon industry works. Manufacturers always optimize their processes such that all "scrap" can be used. When producing a die with lots of CPU chips on it, it is not uncommon to find that some parts of the intended design blocks do not work as desired. Turning these off and branding the chip for a lower rating is the standard procedure. You are not getting "degraded product" though it may make you feel you do :-)


    It would be a surprise to me that Apple's TV firmware would utilize the second core in some instances and not in others based on the second core being available. That would result into a widely varying response from the entire design; i.e., different QA and debug behavior.


    The bad behaviors described in the thread here seem the result of firmware produced with less than Apple quality firmware to me...

Previous 1 2 3 Next