Previous 1 8 9 10 11 12 Next 255 Replies Latest reply: Dec 14, 2014 8:29 PM by Malvoe1 Go to original post
  • Shootist007 Level 6 (16,660 points)

    Actually there aren't many day that go by on this forum without a post about a 2009 MBP drive problem and most of the time it is the cable that has failed. So Apple used Low End parts in the original building of that model and this is why so many people have had problems, not only with the Seagate XT series drives.

  • merlep00 Level 1 (0 points)

    It would seem so, As a test I got a WD drive an couldn't get anything installed on it either. 

  • Raj Level 1 (100 points)

    I ran into many of the same issues listed here and on the Seagate website. Stubborness and experimentation finally led the way to success.

    It was not about a 'bad' drive, underpowered ribbon cable, etc. Read through the steps I took and hopefully it will help some other soul out there.

  • Crash Report Level 1 (0 points)

    Like most, I've had issues with this drive too (mid-2009 MBP).  I may have solved the issues, we'll see.  Here is what I've been able to figure out:


    1. The problem seems to be related to user accounts.  I noticed that over time, returning from sleep state produces random results (beach balls), yet bootup seemed to go well.  I was able to create another user account and when I logged into that account there weren't any problems.

    2. Reinstalls sometimes fixed the issues...only if the user accounts were deleted and recreated.

    3. Ribbon replacement (most recent) seems to have fixed some issues.  At least, I've not had any repeats of the beach balls...and the machine does feel snappier.  It is booting and returning from sleep blazing this may have fixed it.  I'll know more over then next few weeks...

  • clintonfrombirmingham Level 7 (30,000 points)

    Some good tips - I've noticed some have problems with the drive and for other's it's smooth sailing. But I've bookmarked your tips and the next time we get questions on that particular drive, I'll share your notes.





  • merlep00 Level 1 (0 points)

    Rag, I did all that and still couldn't get even Snow Leopard Installed properly.   The new Ribbon Cable worked like a charm, I've been up an running know for weeks without any problems and My Battery is know showing normal instead of needing service! 

  • saitken Level 1 (0 points)

    I've had one working for at least 12 months until very recently. It failed (well I thought so)


    First spiining beach balls and after a restart failure to start up software wise.


    I've actually found the error to be with an EFI update on the 2009 mackbooks (or around that time)


    you need to manually downgrade from the 1.7 to 1.6 version.


    What suprises me is why this has affected me now? this software upgrade was released some time ago.


    Seriously, I was about to get some cable off ebay as has been suggested on this thread many times.


    Look at these instructions:


  • saitken Level 1 (0 points)

    sorry should add, this is a firmware change not software lol


    friday night

  • merlep00 Level 1 (0 points)

    It took less then an 1/2 to put in the new cable once I got it, haven't looked back since.



    Article: HT3561

    About the MacBook Pro EFI Firmware Update 1.7 and iMac EFI Firmware 1.4 Updates


    MacBook Pro EFI Firmware Update 1.7 addresses an issue using drives based on the SATA 3Gbps specification with the MacBook Pro introduced in June 2009.  This update allows drives to use transfer rates greater than 1.5Gbps, however Apple has not qualified or offered these drives for Mac portable computers, and their use remains unsupported.  All previous and current Apple portables with a SATA drive interface include a SATA 1.5Gbps hard drive.


    per d/


    Interface Options750 GB drive  - SATA 6Gb/s500 GB drive - SATA 3Gb/s


    I maybe missing something but if your making it work by reverting back to a different firmware - could you be also loosing the speed - instead of upgrading the ribbon cable to SATA 2??   

  • thecrazyhorse Level 1 (0 points)

    I too have joined the leagues of sufferers, here's what I've tried:


                  Attempt                                      Result            

    Clone Swap:                                            Failed        

         Questionmark folder


    Clean Install and file restore from disk:     Failed        

         Flashing folder/stop sign, then boots, then beachball


    Jumpered                                                Failed         

          Questionmark folder

         (I just wrapped wire around pins though not a real jumper)


    Firmware Downgrade:                              Works        

          Data transfer rate negotiated to 1.5 Gb/s though


    Just ordered the cable/ribon, I will post an update when I try it.

    What a nightmare! 



    2.53 GHz Intel Core 2 Duo, 8 GB 1067 MHz DDR3, NVIDA GeForce 9400M 256 MB, Mountain Lion 10.8.2

  • thecrazyhorse Level 1 (0 points)



    Cable/ribon replacement:                     Failed

           flashing questionmark folder and error, then loads forever


    I googled the cable name posted by merlep00 and got the first one from Ebay that was listed, perhaps I got the wrong one? Anyone have any success from a specific supplier?

  • merlep00 Level 1 (0 points)


    Did you boot to your install disk and if so does the drive show in disk utility's?  are you able to formate it as mac os x extended ??

  • thecrazyhorse Level 1 (0 points)

    Thanks for hte response merlep00, I didn't intend on calling you out or any ill will, I just referencing what cable I looked for. I was actually thankfull you posted what you got.


    I don't have install disks anymore, so I booted from the old drive in an extrenal enclosure, then used Mountain Lion Installer to install the OS on the 750 momentus XT in the computer.  Next I turned the machine off and tried a reboot from the internal disks.  The startup screen did the flashing icons thing between the circle with the slash through it, a folder with a questionmark, and an apple, for about 2 minutes.  Then it stayed on the apple and proceded to load for about an hour.  I stopped trying at that point.  I'm not sure what Mac OS X Extended is.  I can try again this evening and see if I can find that setting.


    I should also add that while it was in the computer, the computer said I had negotiated speeds of 3Gbs which matches the machines capabilities.

  • Csound1 Level 8 (46,880 points)

    Mac OSX Extended (Journaled) is the disk format you should be using for OSX. Why did you bring that up?


    Do it this way, reboot from the external drive and use CCC to clone the external to the internal, assuming that you formatted the new drive correctly it should be bootable then.

  • merlep00 Level 1 (0 points)

    No worries, Were all just trying to help one another.  The drive will have to be formated in Disk Utilities to beable to install the operating system on.  The proper format is Mac OS X Extended (Journaled).  So if you can boot to the original drive - go to disk utilities ( the utilities foder in applications ) and then select the Momentus drive to format it.   I did a quick search for how to and found this which may help you out    - Give it a better name.


    You may still need the original disk - if you call apple they will have them but for a fee. 


    I was worried about ordering that cable too - but did email the seller first to verify that it was an SATA2 - he responed that it was then I put my order in.   

Previous 1 8 9 10 11 12 Next