5 Replies Latest reply: May 30, 2013 8:47 PM by wardhippie
SoCal Cal Level 1 Level 1

I have a Pioneer Elite VSX-52 receiver and have performed the learn remote function on my AppleTV 3rd gen. The problem is when I use it, the AppleTV registers two presses instead of one. I thought perhaps I was holding the buttons down too long when learning, so I've repeated the process holding the buttons down just long enought to fill the progress bar. Same problem. Anyone else having this issue or know of a solution?  Thanks!

  • moogleii Level 1 Level 1

    I had the same issue with my Pioneer VSK-1021. I would recommend teaching the Pioneer remote how to control the apple tv rather than teaching the apple tv to understand the remote. That worked for me.


    I don't know if the codes are the same between Pioneer receivers/remotes, but code 2058 worked for me. Consult your Pioneer manual to find out how to teach your remote, but for me it was:


    1. Hold down RCU Setup and the number 1 for three seconds until the remote LED starts flashing.

    2. Select the source button on the remote (whichever corresponds to what input your apple tv is connected to on your receiver). For me, this was the HDMI button.

    3. Enter the code 2058. The led should do one relatively long pulse, then resume flashing.

    4. Hit RCU Setup again to end programming.


    The manual says you can confirm it took by hitting the Source Power button on the remote, but I don't think the apple tv actually accepts remote shut down? At least the apple tv remote itself can't even do that. It didn't work for me anyway. However, after I exited programming mode, the Pioneer remote was able to control the apple tv. Woohoo!


    It's not clear what corresponds to what, so you kinda have to press around. The arrow keys, play pause, skip etc, all match up. But the Select and Menu keys corresponded to Video Parameter and Return on my remote I think.


    Hope that helps! If all else fails, you can also teach your remote to manually mimic the apple remote, but I didn't try that since the code worked.

  • Mr__J Level 1 Level 1

    Hello, I have a similar model (VSX 1022) I read the manual and I found ot the Apple code is listed under DVD and I set my remote with that code but I haven't been able to pair my computer and the pioneer remote. Maybe I'm pressing the wrong buttons. Could you please tell me in your remote which button acts as menu and next button?

  • wardhippie Level 1 Level 1

    I had the same problem with my Pioneer receiver remote issuing double commands to my Apple TV (when I trained the Apple TV to use the remote). Using the 2058 code to train the remote to control the Apple TV, though, did the trick. Thanks!

  • SoCal Cal Level 1 Level 1

    This works for the cursor keys and the enter key, but I can't seem to find the menu button on my remote.  I think I'll stick with using the apple remote and just use the pioneer remote to control volume.  Not that big a deal...  Thanks for the tip, though!

  • wardhippie Level 1 Level 1

    You likely have a different remote, but for me it was the Video Parameter button (just NE of the up/down/left/right keys).