8 Replies Latest reply: Apr 10, 2012 5:26 AM by mkj722
amibenat Level 1 Level 1

Error: Internal error: java.net.MalformedURLException: unknown protocol: bundle schema/20/rng/opf.rng" at Book (MZItmspBookPackage)

 

what is it about

i send it to apple

Solved by amibenat on Apr 9, 2012 11:48 AM Solved

this is the solution found in the above link

 

 

I had the same problem with iTunes Producer: My book would not upload to the Apple store with this error:

 

Java 1.5, 1.6, or 1.7 is required. Currently, java is the default java version. Please upgrade.

 

In my research on the web, I have found that there is a bug with the latest Java upgrade from Apple. This bug prevents the iTunes Producer scripts from connecting up with the Apple store.

 

Thanks to mmadness quoting an Apple email that explains a workaround to create a symlink.

 

I typed the following into the Terminal and hit return:

cd /System/Library/Frameworks/JavaVM.framework/Versions

This command moves me to the correct folder.

 

Then I typed in and then hit return:

sudo ln -s CurrentJDK /System/Library/Frameworks/JavaVM.framework/Versions/1.5

And I got this rather intimidating response:

 

WARNING: Improper use of the sudo command could lead to data loss

or the deletion of important system files. Please double-check your

typing when using sudo. Type "man sudo" for more information.

 

To proceed, enter your password, or type Ctrl-C to abort.

 

Password:

 

I entered my mac's admin password, hit return, and it accepted the command.

 

Then I typed in the second command and hit return:

sudo ln -s CurrentJDK /System/Library/Frameworks/JavaVM.framework/Versions/1.5.0

 

This command was accepted as well.

 

I quit Terminal and started Producer. The delivery went right through. Thanks to all and I hope this helps.

  • MichiHenning Level 4 Level 4

    The same error, and possible work-arounds, are mentioned here:

     

    https://discussions.apple.com/message/18048796#18048796

     

    Michi.

  • K T Level 7 Level 7
    expertise.publishing
    Publishing

    Did you install the latest JAVA update?

  • Alzem Level 1 Level 1

    Yes sir I installed the lateste java update and I still have the same error

    I tried also the above link but no progress

    Has anyone succeeded to resolve this error

    apple did not answer my request.

  • amibenat Level 1 Level 1

    this is the solution found in the above link

     

     

    I had the same problem with iTunes Producer: My book would not upload to the Apple store with this error:

     

    Java 1.5, 1.6, or 1.7 is required. Currently, java is the default java version. Please upgrade.

     

    In my research on the web, I have found that there is a bug with the latest Java upgrade from Apple. This bug prevents the iTunes Producer scripts from connecting up with the Apple store.

     

    Thanks to mmadness quoting an Apple email that explains a workaround to create a symlink.

     

    I typed the following into the Terminal and hit return:

    cd /System/Library/Frameworks/JavaVM.framework/Versions

    This command moves me to the correct folder.

     

    Then I typed in and then hit return:

    sudo ln -s CurrentJDK /System/Library/Frameworks/JavaVM.framework/Versions/1.5

    And I got this rather intimidating response:

     

    WARNING: Improper use of the sudo command could lead to data loss

    or the deletion of important system files. Please double-check your

    typing when using sudo. Type "man sudo" for more information.

     

    To proceed, enter your password, or type Ctrl-C to abort.

     

    Password:

     

    I entered my mac's admin password, hit return, and it accepted the command.

     

    Then I typed in the second command and hit return:

    sudo ln -s CurrentJDK /System/Library/Frameworks/JavaVM.framework/Versions/1.5.0

     

    This command was accepted as well.

     

    I quit Terminal and started Producer. The delivery went right through. Thanks to all and I hope this helps.

  • Dan-o ™ Level 2 Level 2

    Everyone will want to update to the latest Apple Java standard anyway due to some recent security concerns. They've had two updates in teh last week I believe.

  • MichiHenning Level 4 Level 4

    I think you have the wrong idea here. 1.5.0 is not the latest version, but 1.6.0 is. The above instructions trick all software installed on the machine to believe that 1.5.0 is the latest version.

     

    The problem is caused by installing the latest Java version, not fixed by it.

     

    Michi.

  • Dan-o ™ Level 2 Level 2

    Ah. Well in any case the security concern trumps any bug in the iBA ecosystem that is not compatible. Here's Apple's latest tech notes in case anyone needs it.

     

    http://support.apple.com/kb/DL1515

     

    http://support.apple.com/kb/HT5055

     

    If the new update is really screwing things up for people you should all use the Feedback / Bug Report option in the iBA menu and let Apple now. The more people who complain the faster it will get fixed.

  • mkj722 Level 1 Level 1

    I had this same error. Tried fixing it with the changes in Terminal, but it didn't work. I brought my computer to another location, tried it there, and the book uploaded fine. Perhaps a change in network is all that is needed sometimes?