Previous 1 2 Next 19 Replies Latest reply: Apr 9, 2012 1:26 PM by Robert Sutton1
Robert Sutton1 Level 1 (35 points)

I downloded clicktoflash plugin 1.5.5 for Safari.  (Safari 5.0.2 OSX 10.6.4 MacMini)


I use this on my macbook pro  and it works great. However, with this installation, not only does Clicktoflash not work but now I see NO flash content whatsoever. I've tried re-installing, restarting the computer but no luck. I can't find a way to un-install this plugin.  Suggestions would be appreciated.




  • b noir Level 9 (72,060 points)

    I can't find a way to un-install this plugin.


    If you've got the ClicktoFlash extension, head into the Extensions tab of your Safari preferences, select ClicktoFlash and click the "Uninstall" button.

  • Linc Davis Level 10 (192,472 points)

    You installed an obsolete version of ClickToFlash. Remove it from the Internet Plug-ins subfolder of the Library folder in your home folder, or the one at the top level of your startup volume. Then install the ClickToFlash Safari extension, which you can find by selecting Safari > Preferences > Extensions > Get Extensions.

  • Robert Sutton1 Level 1 (35 points)

    Thanks for the reply


    I got the extension, deleted the plug-in. But I still get no flash content or any sign of the ClickToFlash functioning. I just get a grey area where the flash content would normally load. Firefox on this computer shows flash no problem. So I suppose my flash is current.  ?????

  • Linc Davis Level 10 (192,472 points)

    Select Help Installed Plug-ins from the Safari menu bar. Besides the following, what plugins are listed?



    Java Applet Plug-in

    QuickTime Plug-in

    WebKit built-in PDF

  • Robert Sutton1 Level 1 (35 points)

    There are no installed plug-ins.

  • Linc Davis Level 10 (192,472 points)

    Safari > Preferences > Security > Enable plugins

  • Robert Sutton1 Level 1 (35 points)

    Plug-ins are and have been enabled all this time. It seems that the flash plug-in is not being installed properly.

  • Linc Davis Level 10 (192,472 points)

    If you have no plugins listed at all, not even the built-in ones, and plugins show as enabled in the preferences, then something else is wrong.

  • Robert Sutton1 Level 1 (35 points)

    Very strange indeed. What could it be? Do you think the combined update to 10.6.8 would be helpful?

  • Linc Davis Level 10 (192,472 points)

    Please read this whole message before doing anything.


    This procedure is a diagnostic test. It won’t solve your problem. Don’t be disappointed when you find that nothing has changed after you complete it.


    The purpose of this exercise is to determine whether the problem is localized to your user account. Enable guest logins and log in as Guest. For instructions, launch the System Preferences application, select Help from the menu bar, and enter “Set up a guest account” (without the quotes) in the search box.


    While logged in as Guest, you won’t have access to any of your personal files or settings. Applications will behave as if you were running them for the first time. Don’t be alarmed by this; it’s normal. If you need any passwords or other personal data in order to complete the test, memorize, print, or write them down before you begin.


    Test while logged in as Guest. Same problem(s)?


    After testing, log out of the guest account and, in your own account, disable it if you wish. Any files you created in the guest account will be deleted automatically when you log out of it.

  • Robert Sutton1 Level 1 (35 points)

    AHA!  All this time I had been working with my wife's account on this machine. When i loggged on as another user (admin) all the plugins were there and flash works as expected. So .... What now?  How do I get her account working?

  • Robert Sutton1 Level 1 (35 points)

    Is there a prefs file on her account I could trash and let it be re-created?

  • Linc Davis Level 10 (192,472 points)

    Back up all data if you haven’t already done so. Before proceeding, you must be sure you can restore your system to the state it’s in now.


    Last warning: DO NOTHING unless you have a backup and you know you can restore from it.


    Read this whole message before doing anything.


    Quit Safari if it’s running.


    Step 1


    In the Finder, press the key combination shift-command-A to open the Applications folder. Select the Safari icon in that folder and press the key combination command-I to open the Info window. There’s a checkbox in the Info window labeled Open in 32-bit mode. If that box is checked, uncheck it. Close the Info window and the Applications folder.


    Open the Library folder in your home folder as follows:


    If running Mac OS X 10.7 or later, hold down the option key and select Go ▹ Library from the Finder menu bar.


    If running an older version of Mac OS X, select Go ▹ Go to Folder… from the Finder menu bar and enter “~/Library” (without the quotes) in the text box that opens.


    Delete the following items from the Library folder (some may not exist):






    Saved Application State/


    Leave the Library folder open. Try Safari again. If it works now, stop here. Close the Library folder.


    Step 2


    If Safari still doesn’t work right, quit, go back to the Finder and move the following items from the open Library folder to the Desktop (some may not exist):










    (Note: you are not moving the Safari application. You’re moving a folder named “Safari.”)


    Try again. This time Safari should perform normally, but your settings and bookmarks will be lost.


    If the issue is still not resolved, quit Safari again and put all the items you moved to the Desktop back where they were, overwriting the newer ones that will have been created in their place. You don’t need to replace the files you deleted in step 1. Stop here and post again.


    If Safari is now working normally (apart from the lost settings), look inside the “Safari” folder on the Desktop for a file named “Bookmarks.plist”. Select File ▹ Import Bookmarks from the Safari menu bar. Import from that file. Recreate the rest of your Safari settings. You can then delete the items you moved to the Desktop.


    Note: This step will remove your Safari Extensions, if any, and their settings. If you choose to restore them, do so one at a time, testing after each step to make sure you haven’t restored the problem.


    If you don’t like the results of step 2, you can undo it completely by quitting Safari and restoring the items you moved or deleted in that step from your backup, overwriting any that were created in their place. If you followed these instructions, you have a working backup and you know how to restore from it. If you didn’t follow the instructions, I can’t help.

  • Robert Sutton1 Level 1 (35 points)

    I just made a backup so I'm good on that point. I'm going to print out your instructions and try this tomorrow. I'll report back.


    Thanks for all the help



Previous 1 2 Next