Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: Self assigned IP address

I am in desparate need f some help from anyone. My macbook pro will not connect to the internet. All I get is a self assigned IP address. I have tried renewing the DHCP, restarting the computer, resetting the network, etc. Nothing seems to work. I have the Mac OS X 10.7.3 version. Please help!!!

Mac Pro, Mac OS X (10.7.3)

Posted on

Reply
Question marked as Helpful

Aug 31, 2012 5:16 PM in response to CammoP In response to CammoP

I have been having the same issue with my computer and the only time I could connect to the internet was when my Firewall was off. I was luckily still under warranty so I called apple care today and she told me these steps that fixed my problem. When you are at your desktop screen go to the tab labeled "GO" and click on Computer. Once you are there follow these steps:


1. Click on Macintosh HD

2. Click on the file labeled "Library"

3. Click on the file labeled "Preferences"

4. Click on the file labeled "SystemConfiguration"

5. Then move these three documents to the trash (don't delete them just in case but your computer should remake these documents on its own

1. com.apple.airport.preferences.plist

2. com.apple.network.identification.plist

3. NeworkInterfaces.plist

6. Then restart your computer and you should be good to go and if you are you can go ahead and delete those documents in your trash (that is what I did) because one of those documents was corrupted.


Hope this helps and let me know if it worked!

Question marked as Helpful

Jun 6, 2012 10:45 PM in response to joepark14 In response to joepark14

I know you seem to have got things sorted, but for others for whom this may not have worked, here is how I got over the "self-assigned IP" problem


system preferences>network>


with airport selected, go to "advanced" and then select TCP/IP


In the "DHCP Client ID" box (which is usually empty) put any random string of numbers


THEN renew the DNCP Lease,


It worked for me after trying a lot of other ways


PL

Question marked as Helpful

Aug 19, 2012 8:45 PM in response to joepark14 In response to joepark14

Hi, all! I had the same problem too, and I had tried all the things, but it does't work. It is so unbelievable. I set up my phone as a Wi-Fi hotspot, my mac connect it successfully, but try to connect my router, it get self-assigned IP problem~ what is the matter with my mac?

Question marked as Helpful

Apr 16, 2012 8:42 PM in response to joepark14 In response to joepark14

I had this happen to me twice and the solution for me was to delete the wifi network and keychain password.

The first time i fixed it by restoring from Time Machine which took a long time. I also tried the renew DHCP, delete com.alf.plist etc to no avail. The second time I found a better solution from someone on this forum:

Go to Network Settings

Turn Airport Off

Click Advanced tab

Select my wifi network and hit minus sign to delete

Click Okay

Click apply

Go to Keychain access in Applications/Utilities

Find your network name in the list and delete that password login

Then go back to Network settings and turn airport back on

Click Advanced

Click plus sign then Show Networks

Choose your network and re-enter your password

Click Okay

Click Apply

Then airport should work again, this is what fixed it for me.

All the best

Question marked as Helpful

Mar 28, 2014 2:54 PM in response to joepark14 In response to joepark14

I struggled with this for six hours and finally decided to call my router manufacturer (TP Link), and got a solution. It was a problem with the settings on my router. The combination of the signal width and security type on my wifi settings didn't seem to work with my iMac even though they worked with a MacBooks, iPad etc. I'm not sure if this was due to the age of my system or not but here's what I was told to do:


Reset the router to factory settings (you can probably try without doing this, but I'd recommend it to isolate this from any other issues)

Go to System Preferences - network - WiFi - advanced, click the minus next to your old network

Set the IPv4 option to DHCP

Try and sign into the router login page (usually 192.168.0.1 or 192.168.1.1), to test if you can connect to it, if you can:

Change the router signal width from 40mhz to 20mhz

Change the wireless channel to 11.

Rename your network.

Change the wireless security type to WEP and set a password of ten numbers

On your mac:

Remove your network from network settings again, then reconnect with the password you just set

Try and connect to the internet

It should work now, but change back the security to WPA/PSK again and set a password, as this is much more secure than WEP.


I believe that random 169..... IP address is because for some reason there is a failure in connection between the router and mac, and it is essentially a 'wild guess' built into OS. So I think for many people this is likely to be a problem with your router settings rather than your Mac.


Hopefully this helps somebody, I felt like it would be looking for a needle in a hay stack otherwise.

There’s more to the conversation

Read all replies

Page content loaded

Question marked as Helpful

Apr 9, 2012 11:45 AM in response to joepark14 In response to joepark14

Try a wired connection, if that's an option. If you can connect wired, but not wirelessly, then the following support articles may help:


Joining an encrypted WEP or WPA Wi-Fi network

Troubleshooting Wi-Fi issues

Apr 9, 2012 11:45 AM

Reply Helpful (2)
Question marked as Helpful

Apr 16, 2012 8:42 PM in response to joepark14 In response to joepark14

I had this happen to me twice and the solution for me was to delete the wifi network and keychain password.

The first time i fixed it by restoring from Time Machine which took a long time. I also tried the renew DHCP, delete com.alf.plist etc to no avail. The second time I found a better solution from someone on this forum:

Go to Network Settings

Turn Airport Off

Click Advanced tab

Select my wifi network and hit minus sign to delete

Click Okay

Click apply

Go to Keychain access in Applications/Utilities

Find your network name in the list and delete that password login

Then go back to Network settings and turn airport back on

Click Advanced

Click plus sign then Show Networks

Choose your network and re-enter your password

Click Okay

Click Apply

Then airport should work again, this is what fixed it for me.

All the best

Apr 16, 2012 8:42 PM

Reply Helpful (12)

Jun 1, 2012 7:17 PM in response to ericdy In response to ericdy

Excellent solution. Thank you!


It helped me after a day of frustration: my mac would not connect to home wi-fi network at all but would to everything else.


One of the clues should have been the keychain password entry for the network as it was much longer and incorrect, compared to another mac's keychain entry which was connected to the same network. As soon as I saw your instructions I felt relief.

Jun 1, 2012 7:17 PM

Reply Helpful
Question marked as Helpful

Jun 6, 2012 10:45 PM in response to joepark14 In response to joepark14

I know you seem to have got things sorted, but for others for whom this may not have worked, here is how I got over the "self-assigned IP" problem


system preferences>network>


with airport selected, go to "advanced" and then select TCP/IP


In the "DHCP Client ID" box (which is usually empty) put any random string of numbers


THEN renew the DNCP Lease,


It worked for me after trying a lot of other ways


PL

Jun 6, 2012 10:45 PM

Reply Helpful (16)

Jun 7, 2012 10:55 PM in response to ryanhaldy In response to ryanhaldy

Glad to be of help. I cannot claim credit but unfortunately have lost the original source for this (another, non-apple forum). It really is strange how many "final solutions" there are for this problem, that don't actually work in all cases.


Anyway - spread the word - maybe YOU can help someone get over this annoying problem


PL

Jun 7, 2012 10:55 PM

Reply Helpful (2)

Jun 8, 2012 10:30 PM in response to ryanhaldy In response to ryanhaldy

So sorry to hear that. The only other trick I have is the following. I don't know if it will help for you


Applying a manual IP under the Configure IPv4 selection should work. In your home router this will be 192.168.1.X . However, this for me is not where the problem lies - for me it is when out on the road using a third party WiFi, what IP to use?


You may find that your iPhone can pick up the network. If so, check your phone under settings / WiFi right arrow on chosen network and see what IP your phone has picked up. Put the same IP into your laptop using "Manually" - just use a different last digit


That the extent of my suggestions I am afraid!


PL

Jun 8, 2012 10:30 PM

Reply Helpful (3)
User profile for user: joepark14

Question: Self assigned IP address