Previous 1 6 7 8 9 10 Next 189 Replies Latest reply: Apr 28, 2016 12:20 PM by Patrick1982 Go to original post Branched to a new discussion.
  • VTFItz Level 1 Level 1

    OK, I tried all the solutions involving zapping the network from the previous Airport connection history, the Keychain & everything else I've seen here.  Still no connection & the blasted self-assigned error message. I was so frustrated, I just threw up my hands and have been using my Ethernet cable to connect to the router, which I was pleasantly surprised to see worked... and ultimately led to the fix.


    Tonight, after rubbing my sore butt from being chained to a seat at the dining room table for the last two weeks, I googled the problem AGAIN & was directed to this thread AGAIN. 


    FINALLY, I found my solution when I went to a YouTube link from a suggestion here, which didn't work; then I tried another video that popped up at the end of the first, which didn't work; but the third one that popped up at the end of the second was the charm:



    I don't know why this didn't occur to me by myself.  It needs an Ethernet connection to work.


    Background: The problem was with my MBP connecting ONLY to my router at home.  For 2-3 years, never had a problem.  Suddenly, wham! I didn't download or update anything, just no joy on my home network <<insert salacious remarks here>>. Only MY MBP didn't work.  All the other bizzillion Mac devices my kids use around the house, and my iPhone too, worked fine, so I knew it wasn't the router.  Insult to injury: My wife's PC worked fine too.  My MBP has continued to work at all the other places I normally get wifi away from home.  MOST IMPORTANTLY, I could connect to the internet through the router using an Ethernet cable.


    Again, I don't know why I couldn't try this one without the suggestion.  You must have an Ethernet connection to the internet via your router working.  Here we go:


    1) Open Network preferences.

    2) Click on Ethernet. Write down the "good" IP Address indicated.

    3) Click on Airport. Select the troublesome network.

    4) Click on Advanced.

    5) Click on TCP/IP tab.

    6) In first dialogue box, select: Using DHCP with manual address.

    7) The IPv4 Address box will now allow you to type in the good IP address you found your Ethernet connection was using.

    8) Click OK and you should be… OK!


    My only concern is I WON'T be OK when I am away from home.  In that case, I'll just follow the same path and go back just to Using DHCP.  I'm hoping my MBP will be smart enough to know what to use when it encounters those familiar faces & places.


    It's so amazing how crippled we are when our technology breaks down... and how euphoric we are when it gets fixed.  I'm sure it says something terrible about our species.


    I hope this might be the euphoria-inducing solution for some of you. Good luck!

  • VTFItz Level 1 Level 1

    Sorry, folks, I was premature in trumpeting my success.  I should have worked with it more.  It's not working.  It says I have a connection -- not the self-address error anymore -- but I can't conect to internet.


    Will reply to this post if I can fix it.  Too tired & demoralized just now...

  • BritchiV Level 1 Level 1

    do you tried to change the wireless mode from 11bgn to 11bg ? I had the same problem with the self assigned IP address...but when I changed the wireless mode I was the happiest man in the world it worked..try and yourself you can do this from router settings...wireless settings Hope it will work for you,good luck

  • CDawggehhh Level 1 Level 1

    Hey everyone,

    I was stuck on this problem for a long time and for me to connect to my wifi I had to turn off all my other connected devices, I actually had to get Tesltra to come and fix this for me. And turned out not only was my router set to nat or bridged mode &amp; my router was also faulty. So he basically said depending on the mode the router is set in will limit the ip addresses, and he also re assigned a new MAC address, deleted all known networks from the list and then joined the network again and it worked.

  • BrendanCO Level 1 Level 1

    After trying everything suggested here for several hours, nothing worked. I noticed that someone had mentioned they use CenturyLink for their Internet. That peaked my interest as I use CenturyLink. I decided to call their tech support. They did the usual annoying text-book troubleshooting techniques but then the guy got into the router settings and disabled WPF. Bam. It worked! My Macbook 2,1 OS 10.5.8 connected like a charm and I'm back in business.


    Unfortunately, I could have narrowed it down earlier if I had driven to another WAP with a different ISP. Drats.

  • allcomm21 Level 1 Level 1

    I FIXED IT! After two full days of trying and searching, and about an hour on the phone with Applecare, I was about to completely lose my mind, when I discovered that my anti-virus program, VirusBarrier X6, had blocked an address at about the time my Airport stopped connecting to the internet. Sure enough, I "de-authorized" VirusBarrier, and suddently I'm back on the internet!  The blocked address was my router! (


    Look in MacintoshHD > Library > Preferences > Intego > VirusBarrier, and sort by "Date Modified" and look for the date your problem started. I found a file called StopList.plist. It opens in Text and you can see what it's blocked and why. (It would probably show that to you in the dashboard, but every time I tried to open it, the program crashed.)


    To disable VirusBarrier,  run the app from Applications and you'll see the option to de-authorize it. This solution explains everything -- why all my other wireless devices had no problem with my Wi-Fi, and why my iMac got right on the internet when I took it to the Apple store. Their wireless router must have a different address. Whatever... I'm just thrilled to be back online.


    I've read a lot of comments from people having this same frustrating problem. Hope this will work for at least some of them...


    Not sure what to do about virus protection... not inclined to reactivate VB... I'll think about that later.

  • VTFItz Level 1 Level 1

    After just using a hardwired Ethernet connection for over a month, I still hadn't figured out the initial problem, but here's my work around.  I setup a Guest network (password protected) on my home wifi router & my MacBook Pro will talk to it fine.  I'm using it now.  It's an inelegant solution, but a solution nonetheless.

  • Bob Kerstetter Level 1 Level 1

    About virus protection, the Macintosh is not the target of most viruses so why bother? Well, there are several reasons to bother. The primary reason is to not spread email viruses you receive from others and forward on to others. Your Mac likely cannot be infected but you can spread them.


    Having said this I don't use virus protection. Here is what I do instead.


    I set up a standard account to use for everyday work. From this account I can also update most software by just entering my administrator ID and password when asked. I set this up by creating a new account for the administrator, logging out of my old admin account, logging into the new admin account and making the old one—the one with all of documents, music, etc—into a standard account. This way, if I happen to get something bad it cannot do much damage since I am no longer an admin. On the rare times when I need to be admin I log in as admin.


    Also, I don't open email attachments from people I don't know. If someone sends a Word attachment I send them hate mail, remind them to use PDF and then open it with TextEdit or Pages, copy the content and paste it into a new Word document, if necessary. I don't use Excel, but do something similar with PowerPoint attachments. I stay away from pirate sites for music, anime, or whatever. I stay away from **** sites and gambling sites and political whining sites. I also turn off Java in the web browser. I turn it on if necessary for a trusted site then turn it off again. This takes paying attention to where you are and what you are doing, but no more so than the attention you need for driving, bicycling or walking in any city.


    Mac OS X is a Unix OS. No matter what the Windows folks are saying, it is still the most secure OS for the consumer market. It has a great family history in the military and education settings so it is by design secure. What I do to it makes it even more secure. I have been running Unix systems since 1998. This is stuff I learn from Unix admins.

  • TarvemeisterUK Level 1 Level 1

    I am currenlty experiencing this problem and have tried all the fixes suggested but am unable to find the three files under sytem configuration that several users have suggested I should delete to test this method, can anyone offer any ideas? I am running on OS 10.6.8. maybe the files are named differently or in another folder? Any other new found fixes would be greatly welcome as well, nothing is working! Thanks

  • allcomm21 Level 1 Level 1

    I fixed it on my computer... Do you have an anti-virus program installed? My program VirusBarrier X6 was blocking my wireless router. Not sure why it thought it should do that, but it did. This kept Airport from getting an IP address from the router. If you have an antivirus program, disable it to see if that fixes the problem. As soon as I did that, BAM, I was back in business!

  • TarvemeisterUK Level 1 Level 1

    No sadly that is not my issue, thank you for the reply though. Currently wokring around my issue with a very long cable!

  • ARgriff Level 1 Level 1

    I had a similiar issue with my home network and nothing worked for long that I tried above.  I reset my router and than had trouble finding my wireless network, i shut off WEP security...stil nothing...turned on WPA security in my router and it came up on the network search and now everything is connected.  For some reason no mac products wanted to connect or find my router using a WEP password.

  • diedoggie Level 1 Level 1

    after now 6 hours and trying everything on this post I finally found one that worked.


    I just guess 166224 Views, and 116 replies is just not enough for apple to fix this !!!


    I have tried everything listed here and only now just found a fix.

    The MacBook Pro does not have a working ethernet port and apple have already told me £400 + to fix that.

    I can connect to outside networks (cafe etc) no problem, but at home on my own network nothing.


    - deleted keychain

    - deleted plist files

    - restarted computer

    - restarted router (in every order possible)

    - checked firmware on router

    - checked updated on Macbook

    - no antivirus

    - random numbers in DHCP client ID


    finally one that worked.

    - set to manual IP address

    - connect

    - now set back to DHCP

    - reset with 123 in DHCP client ID

    - now have proper IP with correct internet connection




    now how do I get 1/4 day of my life back !!!



  • Eeljen Level 1 Level 1

    This 'Self assigned IP address' problem has plagued me for weeks. I looked all around the web, googling for solutions, alas, to no avail. I've even reinstalled the OS, but after a few days the problems were back again.


    Until I found a reference somewhere that it could be related to bluetooth interfering with the wifi signal. And surely, the problem mostly occured when I used my MacBook Air at work, where I also often use a bluetooth trackpad & keyboard. At home, when bluetooth is turned off most of the time, I rarely ran into problems (after the reinstall).



    When bluetooth is turned of, 9 times out of 10 there is no problem with the wifi connection. After it is connected, I can turn BT back on again and start using trackpad & keyboard. From time to time, my wifi signal drops, but when that happens I just turn of bluetooth, turn wifi off and on again, and start using bluetooth again.


    TL;DR: Bluetooth interfered with my wifi connectivity, turning it off (until wifi is connected) resolved my problems.


    I hope it can help several of you, who are still struggling with the self-assigned ip problem.

  • 4ExpandingBliss Level 1 Level 1

    Whew, thank you, finally a solution that worked for me!

Previous 1 6 7 8 9 10 Next