Previous 1 7 8 9 10 11 Next 186 Replies Latest reply: Nov 29, 2015 2:22 PM by Eddie Epic Go to original post Branched to a new discussion.
  • GingerT055 Level 1 (0 points)

    I have a very wierd set of data on this problem...


    1. 3 of us with MacBook Pros working on a ship

    2. There is 1 ethernet cable connection in our office to provide us with internet.  To use it we simply plug in and go.

    3. 2 of us can do this fine, 1 cannot, the self assigned IP problem crops up.


    4. My computer was one of the working macbooks but 2 days ago it developed serious hard disk/startup problems.  I had an old spare macbook pro from 2 years ago as an emergency spare for the 3 of us.... I had also prepared us with a small external drive with a LION installation partition.  I booted the spare computer from the external drive, erased the hard disk and re-installed LION then re-installed my computer from my time machine backup (last backed up 3 hours before the crash!).


    So now my spare computer was restored to the same state as my dead computer.


    5. When I plugged in the ethernet cable, my spare computer has the self assigned IP address issue.


    SO.... Take a deep breath!


    6. I tried to fix my dead computer with my external drive but it stayed dead.  I decided that the hard drive would probably be ok so decided to remove it and swap it for the drive in my external drive case (same type of drive).  For safe keeping I put the drive from my external into my dead mac.


    When I tried to start up my dead mac, it was now alive again... as if by magic!  I therefore suspected that a loose hard drive connection may have been responsible so plugged in (via USB) the external drive (which contained the original drive from the computer) and re-booted from that drive.  My computer with its original data came back to life.


    With my old drive booting my once dead computer via USB, I connected the ethernet and hey presto... it worked.


    Now for the WACKO part


    7. I shut down my once dead computer and plugged my external drive into my spare computer and re-booted from the external drive.  My spare computer woke up in exactly the same as way as it did on my once dead computer... as it should have.


    8. I plugged in the ethernet - My spare computer STILL has the self assigned IP address issue.




    2 computers, 1 external hard disk drive.  Boot one computer with the drive and the internet works, boot the other with the same drive and the self assigned IP address issue arises.


    Ideas anyone!?!

  • allcomm21 Level 1 (0 points)

    Maybe there's a limit on the number of different computers (two) that can use the ethernet connection. If it's coming through a modem, check the configuration on the modem.


    Another suggestion (that you've probably already tried) would be to copy exactly the network settings from one of the working computers to the one that's not.


    If that doesn't do it, is there an anti-virus barrier on the non-working computer/drive? That can also block the network connection.

  • delia84 Level 1 (0 points)

    WOW thank you to everyone. Collaboratively, all of this has helped me so much. I am now back on my mac after MONTHS of not being able to get online. It kept happening over and over and finally just totally clocked out on me. I went to mac who said, "well it works fine here, so without us being at your house there's nothing we can do. here's a reference number so you can call machelp and they can assist you further." "thanks" I said, "What about my t not being able to be capital?" "Can't say much about that."

    so thanks for that macstore.


    i did each of these things more than one time. Resetting the location. deleting the wifi network, going in the keychain access and not only deleting the current networks and passwords, but all the old ones. turning it all back on again. turning EVERYthing back off and on again over and over. restarting. changing my IP adresses,finding them on my phone,  changing from WPA password, to trying all of them listed. Everything i read on the first handful of pages on here i tried. FINALLY

    i read a post about how someone went in and changed the type of password and it lead me to finally just try to log into my router. Never done this before and I think that's what finally did it. I went it and got all the IP addresses (just to be sure) and put them in as the DHCP manual. I reset the password on my router website, and the region said Europe, not sure why so i changed that too as im in chicago. Made sure it was on the WPA2 password setting. went back into my network preferences and did the same. Once again, i deleted the netowrk from the list, turned wifi off, closed all browsers and went back in. turned wifi on, put in network, set it to the WPA2 password security and put in password again. FINALLY SUCCESS!!!!! it took me over 2 hours but here i am. I don't know which of those really worked alone, I think it was all of it together. What a pain in the ***. Got a mac to avoid **** like this. Pff. Good LUCK!!!!

  • kiwipaulw Level 1 (0 points)

    After weeks and weeks of changing settings on the mac with no joy. I logged into my router and changed the network mode from MIXED to B/G only.


    I then renewed the lease on the wifi connection on my mac and it worked !!

  • James Shaw Level 1 (5 points)


    I’m glad these peer-to-peer Apple discussion groups exist, otherwise I’d still be trying to deal with my “self-assigned IP address” problem. Like others here I wasn’t able to get online and kept getting that message on my screen. Unlike most others who have commented, however, I use an older Powermac PC G5 (non-Intel) desktop running OS 10.5.8 (Leopard) and connect via ethernet.


    I’ve dealt with a lot of connections issues over the years and always managed to muddle through, but this one wasn’t like any of the others and the usual fixes didn’t work. It was compounded by a number of false clues:


    -- The date and time periodically would reset to 1969. This usually indicates the PRAM battery needs to be replaced, so I put a new one in.  The IP address problem remained. There was a I kept getting a message about a problem with the “AppleVNCserver.bundle.” And there were others.


    I tried many things: Rebooted the router and modem. Trashed some network preferences. Swapped out ethernet cables. Spent long hours configuring and reconfiguring the Network setup. It told me that a) I wasn’t connected to the Internet (I knew that) or b) The ethernet cable was not connected (but it was).


    I even called my ISP (Time Warner) but they had no ideas – and they don’t want to know about Macs anyway.


    Finally, I came to this forum where I found suggestions for every conceivable kind of fix, many of which sounded like they were worth checking out, so I tried a few.  I did two of the suggested things today and one of them– or maybe both – was the solution.


    -- I found the file and trashed it.

    -- I opened System Preferences, went to Security > Firewall and changed the option from “Set access” to “Allow all incoming connections.” (The options might be different in versions of the OS other than 10.5.8.) Immediately my Mail inbox began filling up and I could get online.  So, many, many thanks to whoever it was who suggested those fixes.

  • Denny6968 Level 1 (85 points)

    I ran into the same thing today after replacing three Airport Extreme devices. A MacBook Pro and a virtual machine were not getting an IP address anymore from the router that has DHCP enebled. Just extending the DHCP range with some extra addresses solved the problem.

  • omegapatten Level 1 (0 points)

    I've tried ALL other methods I can think of and this was the only solution that worked for me.


    I have a 2012 Macbook Air.

    A Belkin N300 Router (I believe the router to be the main issue here).


    I just logged into my router and turned the firewall off and then connecting wasn't an issue.

  • O2BNTEXAS Level 1 (0 points)

    Thanks Ericdy for the great solution.


    I would like to add to this new 2013 Mac Book Pro laptop had the same problem. After several attempts to establish a WI-FI connection and failing, I noticed that the Mac Book was telling network settings...that it had an IP address of As it turns out, that IP address was to my wireless printer. I turned the printer off and followed Ericdy's instructions. Mac Book immediately picked-up my WI-FI network. After signing in, I locked the network then turned the printer back on.


    Hope this helps someone down the road...

  • Pankajbhai Ahmedabadi Level 1 (0 points)

    I had this same problem after software update 10.8.5.

    After trying all the tricks mentioned one worked.


    MacMini running 10.8.5

    Internet via Huawei USB Dongle.

    Shared via Wifi.

    Wifi was assigning fixed IP address and all other devices could connectto network but no internet access.


    I disabled all sharing except internet sharing.

    Copied the IP address Huawei was giving.

    Pasted this in the WIFI(advanced set up) TCP/IP.

    Now, all devices have access to internet as well.

    Disconnected internet and re-connected.

    This time the IP address in Huawei is different, the WIFI shows the previous IP address but the internet is being shared properly.





  • DudsMac Level 1 (0 points)

    I've had this issue for days, and finally found a dead-simple solution that I haven't seen many (any?) people talking about... a hard reset of the wireless router.


    In my case, I'm using an Airport Extreme Base Station, so I followed the instructions for a hard reset here:


    Worked like a charm. After days of frustration, I'm back up and running. Hope this helps someone!

  • Ellips Level 1 (0 points)

    Ah thank you ever so much. Would never have occured to me to try this.


    Shall definitely pass on the info to anyone who needs it.


    Also, you write your comments in a very friendly and supportive manner



  • iamedwardmont Level 1 (0 points)

    i hope this one helps..


    regardless of what router u are using the "ROUTER MODE" on the router should be on DHCP-NAT

    most common errors for mac users is when the airport extemes "router mode" say off. so u may need to access that and check if its on dhcp-nat


    sorry for my grammar but i hope this one helps.



  • Gravity Spot Level 1 (0 points)

    Like so many others here, my wireless stopped working out of the blue. I finally made some time to try to troubleshoot/remedy the problem - and I came across this forum. I spent hours - hours and hours - trying pretty much all of the remedies set forth in one or another post. Unfortunately, unlike so many others who have posted here, nothing I did worked. I replaced my old D-Link router with a new Airport. I was able to get the wireless functionality of that to work, and for my iPhone to connect wirelessly to the new network I created via the Airport. And I was able to get online on my Mac Power Book BUT NEVER WIRELESSLY - only via an Ethernet line that ran through from my cable modem through the Airport, then to my MPB.


    Then I tried overwriting the 169 IP address, by manually putting in the IP address of my Ethernet line.


    But not only did the manual IP address stil not remedy the problem - it caused my iPhone to ALSO take on a 169 IP address, and for me to no longer connect wirelessly via my iPhone.


    I finally gave in and called Apple Care (800.875.2273). The first time I'd called somehow I got a message that advised that I'd have to pay $19.99 just to talk to someone, and that so irritated me that I hung up. But I gave in today - and, to my surprise, when I called back, I was NOT advised that I would have to pay to speak with someone. After about a 10-minute wait, I got a tech guy to whom I explained the situation - and made very clear that I had spent hours on the forums and could see that this was a well-known problem. To his credit, he heard me out, then stayed on hold along with me until he could get an Airport/wireless specialist on the phone. He briefly explained my problems to that specialist - sketchily, so I went over it all again.


    The specialist quickly got down to business - it was EXTREMELY clear to me that the specialists are highly attuned to the problems. I tried to take notes as we were going along, to relay here. Alas, I didn't do a very good job writing down excatly what we were doing as we were doing it, so this does not set forth exactly what we did, but roughly:


    - Delete my network name from the list of Networks (we did NOT delete the Wi-Fi listing in the previous screen).

    - THIS IS REALLY THE KEY THING: We went to HD > System > Library > Preferences [I believe - I'm sorry I'm not 100 percent certain] and sent to the trash the ENTIRE System Configuration folder. I had not found anyone on this or any other forum advising to do this - just to delete one or two files from that folder. But this seemed to be absolutely critical to the remedy - at least for me - and is not something I myself had tried to do.

    - The Apple tech guy then instructed me to turn off my MPB, and then to hold down CTRL+OPTION+SHIFT + the power button for 10 seconds. I did that - absoluely nothing happened during that time.

    - We then turned WiFi on, and went through a cycle of resetting my Airport, and then also my cable modem (which involved unplugging every wire connected to the cable modem, and leaving everything unplugged from the modem for a full 2 minutes).

    - I think after we did that we AGAIN reset the Airport, and I had to re-create the network all over again.

    - We then turned WiFi on, and, voila, I  finally, finally, finally again had wireless connectivity on my MPB - and then I was able to connect on my iPhone (the Apple tech explained that DHCH and NAT must both be enabled in order to connect on multiple devices).


    I am not an IT person at all - as this post probably makes clear. As much as I appreciated all of the posts here, not one post provided the solution to my problem. All this stuff being what it is, I'm sure there's no one remedy for everyone's problems, as similar as they may be.


    I pressed the Apple tech about why the problem - and he confirmed that it's likeliest to develop after a system update, which was the theory I had developed, based on all that I read here and on other forums. And, again, just to say, it was COMPLETELY clear from speaking with him that Apple is completely aware of this - and have the protocol in place to remedy it.


    If you are experienced troubleshooting Apple problems, and have IIT-y skills, and this problem develops, then try sending your System Configuration folder to the Trash and try completely re-setting your cable modem and your Airport/wireless modem. If you aren't super-comfortable dealing with such stuff, then I highly recommend calling Apple and getitng connected as quickly as possible to an Airport/wireless specialist. Why I was advised I would have to pay $19.99 the first time I called, then not the second, I have no idea. I was so ready for the problem to be fixed, I was ready to pay, as irritated as I was that I was going to have to pay.


    Good luck.

  • WaddeHaddeDuddeDa Level 1 (0 points)

    I had the same problem on my OS X 10.5.8.

    I tried to remove the system preference folder, removing the airport and ethernet from the Network utility etc.

    At the end, it was a error of the firewall. I deactivated air port -> deactivate firewall -> activate airport -> it worked! -> deactivate airport -> activate firewall with the same blocking list as before -> activate airport -> and it still worked!


    Strange bug.

  • edlucas Level 1 (5 points)

    after reading many posts on how to fix this problem, desigurl03 solution saved the day. her solution worked great. I've reposted her solution below , but i did 2 things different.


    1. after i found those 3 files i immediately deleted them.

    2. before restarting mac, i went back to network preferences window and deleted all the options for me to connect to the internet which was wifi and ethenet.


    after restarting i went back to network prefs clicked the "+" symbol and added just the ethernet. i then hit "apply" and after a few moments i finally had internet again.


    here is her solution.


    I have been having the same issue with my computer and the only time I could connect to the internet was when my Firewall was off. I was luckily still under warranty so I called apple care today and she told me these steps that fixed my problem. When you are at your desktop screen go to the tab labeled "GO" and click on Computer. Once you are there follow these steps:


    1. Click on Macintosh HD

    2. Click on the file labeled "Library"

    3. Click on the file labeled "Preferences"

    4. Click on the file labeled "SystemConfiguration"

    5. Then move these three documents to the trash (don't delete them just in case but your computer should remake these documents on its own



         3. NeworkInterfaces.plist

    6. Then restart your computer and you should be good to go and if you are you can go ahead and delete those documents in your trash (that is what I did) because one of those documents was corrupted.


    Hope this helps and let me know if it worked!

Previous 1 7 8 9 10 11 Next