Previous 1 8 9 10 11 12 Next 176 Replies Latest reply: Jul 13, 2015 3:01 PM by harrynmalone Go to original post Branched to a new discussion.
  • Wintour Level 1 Level 1 (0 points)

    Solved!

     

    After trying every solution I could find, without success, I did the following and am now back on-line!

     

    In my case my iPhone could connect but my MacBook would not. My MacBook gave the "No IP address assigned" error followed by the "Self-assigned IP address...cannot connect to the internet" error.

     

    To get around this:

     

    1. On my iPhone I looked up the network settings (Settings > Wireless > small, blue "i" icon next to the wireless network) and noted the IP address.

     

    2. On my MacBook I opened the System Preferences > Network > and clicked the Wi-Fi "Advanced" button.

     

    3. Under the TCP/IP tab I selected "Using DCHP with manual addres" on the "Configure IPv4:" drop-down menu. *Note that my Subnet Mask and Router information had already been established while my computer tried to connect initally. While these values matched the ones on my phone, if I entered them all thorugh the "Configure IPv4: maunally" option I was unable to connect. Go figure?

     

    4. I entered the IP address as shown on my iPhone, but incresed the value of the final number by one on the hunch that there would not be another device using this IP. So, for example, my iPhone's IP was 888.888.8.8 and on my computer I entered 888.888.8.9. *Note that if there was a device using this IP address, I think a dialouge box would warn you and you could just continue incresing the IP address until it wasn't an issue.

     

    5. I clicked ok and Apply to the new Network Settings and was online!

     

    Hope this helps.

  • jahjahjah Level 1 Level 1 (0 points)

    Ok, here's some strangeness.  Had a momentary power outage last night.  Took down modem and router but not Macbook or monitors on UPS.  Internet was gone but I figured it would be back after modem and router rebooted. I use the ethernet port for home use.  Preferences said the ethernet port was self-assigned IP.  I could manually specify an IP address and it would work fine.  Wireless worked fine acquiring a DHCP address.  On ethernet, DHCP would come up with a self-assigned IP 169. address no matter what I tried including resetting the NVRAM and SMC (and correctling monitor arrangement after that) and other things with no logical connection :-).  I deleted the Ethernet network and added it back(+).  Same results except now a manually specified address would not work but it could tell when the cable was connected.  I took the Macbook to the router and plugged it in directly with a patch cord.  Bamm, back to normal with my router defined segment address assigned  Next stop, ethernet switch at my home entertainment area.  The TV, PS3, and Directv all working fine here but Macbook returned to self-assigned IP.  Power cycled the switch.  Bamm, Macbook worked fine and so I returned it to its shelf under my desk.  For some weird reason, the old Linksys hub and Macbook were unhappy after the power outage even though everything else worked, all with DHCP.  Also, it was weird that I could not get a manual IP connection to work after rebuilding the ethernet network in Preferences when it did immediately before.  I was comtempating a restore but the risk was averted.

  • cbeni83 Level 1 Level 1 (0 points)

    ericdy,

     

    Thank you. Your solution fixed my macbook pro right up. I was getting highly annoyed as i had about 6 other devices connecting to my parents wifi network without any problems. Removing the network from memory and re-entering the pw did wonders.

     

    Thanks again!

  • Vikrant Sood Level 1 Level 1 (0 points)

    Hi Guys

     

    I have tried everything and finally found out that my router was faulty. I changed my wifi router and everything works fine now. No wonder apple isn't bothered about this post. Ha! Cheers!

  • IdriVlam Level 1 Level 1 (0 points)

    Hey guys,

     

    Apparently there is a number of different issues that can cause this. My specific example was in a set-up where a DSL modem was connected into Airport Extreme that created an extended network for all kinds of devices I use at home. I got the same problem after a reboot of Airport Extreme.

     

    The solution is to go into Airport Utility, Edit the set-up of the Airport Extreme and then go into Network tab. Turns out that after some reboots Airport Extreme goes into 'Bridge' mode of the network, which does not allow it to receive an IP address from the DSL model. No amount of Airport / Mac reboots, deleting previous wireless networks, calling ISP, screaming at your hardware, etc - none of that acutally helps. Simply change the setting to DHCP and NAT in the Network tab of the Airport Exteme settings and then ignore 'Double NAT Issue' that will be flagged by the Airport Extreme. Works in five seconds. Good luck.

     

    V.

  • -MAIN- Level 1 Level 1 (0 points)

    Everyone stop what you're doing.  This is a firewall issue. To fix the problem you must delete the firewall preferences. To do that, go to the /Macintosh HD/Library/Preferences/ folder and remove the file called "com.apple.alf.plist," and then restart your computer. After the system boots, you may be prompted to allow incoming connections to numerous programs and services, so accept these for now (you can always go to the Firewall settings and deny or remove entries later on) and then try connecting to the network again.

     

    I tried 3 different methods that others suggested and they didn't work. Deleting the firewall preferences worked.

     

    Source: http://reviews.cnet.com/8301-13727_7-20050793-263.html

  • jahjahjah Level 1 Level 1 (0 points)

    There are many sources for this generic "self-assigned IP address" message.  Congratulations on finding out your solution.  The article was posted about three years ago so it has helped a number of people but it only solves one of the possible problems.  I don't think anyone knows how the preferences file gets corrupted during a power outage but that starts it for many.

  • jbirken Level 1 Level 1 (0 points)

    Do this ...

    Remove IPFW File to make sure WiFi works

    1. Open the Terminal app located at /Application/Utilities/Terminal
    2. Copy the following text and paste into the Terminal window and press enter:     sudo rm /usr/local/etc/ipfw.conf
    3. You should be prompted to enter your Mac password, please do so.  Note that as you type your password nothing is shown on the screen
    4. If the file was there you will receive no error or output.  If the file was missing you will receive an error.  Either way this file is no longer present which is good.

     

    It happened to me and this works.  You may need to tell the Mac not to remember the network bu this file needs to be removed.

  • Festee Level 1 Level 1 (0 points)

    I struggled with this for six hours and finally decided to call my router manufacturer (TP Link), and got a solution. It was a problem with the settings on my router. The combination of the signal width and security type on my wifi settings didn't seem to work with my iMac even though they worked with a MacBooks, iPad etc. I'm not sure if this was due to the age of my system or not but here's what I was told to do:

     

    Reset the router to factory settings (you can probably try without doing this, but I'd recommend it to isolate this from any other issues)

    Go to System Preferences - network - WiFi - advanced, click the minus next to your old network

    Set the IPv4 option to DHCP

    Try and sign into the router login page (usually 192.168.0.1 or 192.168.1.1), to test if you can connect to it, if you can:

    Change the router signal width from 40mhz to 20mhz

    Change the wireless channel to 11.

    Rename your network.

    Change the wireless security type to WEP and set a password of ten numbers

    On your mac:

    Remove your network from network settings again, then reconnect with the password you just set

    Try and connect to the internet

    It should work now, but change back the security to WPA/PSK again and set a password, as this is much more secure than WEP.

     

    I believe that random 169..... IP address is because for some reason there is a failure in connection between the router and mac, and it is essentially a 'wild guess' built into OS. So I think for many people this is likely to be a problem with your router settings rather than your Mac.

     

    Hopefully this helps somebody, I felt like it would be looking for a needle in a hay stack otherwise.

  • Lukemac89 Level 1 Level 1 (0 points)

    Thanks to AbnoSpam for solution posted on 22/feb 2013, worked perfectly after nothing else would!!

  • SFDJD Level 1 Level 1 (0 points)

    Thank you for posting this! I've been sitting in a cafe troubleshooting this problem for close to an hour. Your solution worked for me!

  • Reid1801 Level 1 Level 1 (0 points)

    Some people in these forums claim that the problem in 169 cases lies in router passwords.  My question is: is this relevant in my case?

     

    My iPad2 connects (or did until it started giving my a 169 address instead) directly to my iMac via wifi, which in turn is connected to the internet via a cable which goes through a modem (a SpeedStream 4200).  I do not have a wireless router: all I have is the modem.

     

    Since my iMac allows me to surf the web, I think the problem must be in the connection between the iPad and the iMac (and not the modem).  Is this true?

     

    By the way, I've tried all the usual things:

    . resetting the iPad

    . forgetting the network on the iPad

    . inserting a static IP address on the iPad

    . changing the password on the iMac's internet sharing network. (I upgraded to system 10.9.2, which allowed me to switch to WPA2 security.  That fixed the problem for three days, before it reappeared.)

    . changing the security mentioned above to 'none'

    . changing the wireless channel

    . lowering the brightness of the iPad's screen

    . cursing Steve Jobs and threatening to desecrate his grave.

     

    I'm reluctant to change settings in my modem because it is working perfectly well with my iMac, and I fear that I may just end up stuffing up things completely.

     

    I suspect that the problem is a bug in the Mac OS wifi security software. Does anyone have any thoughts?

  • veryokay Level 1 Level 1 (0 points)

    I have never posted on the Apple Support Community before, but I wanted to share what worked for me in when I ran into this situation.

     

    Background:

    I use a Belkin N+ Router that is probably 4 or 5 years old.  I've never had any problems with it.  I have multiple devices that are connected to the WiFi at any one time, including my MacBook Air (3 1/2 years old), my iMac (14 months old), my work PC, my iPhone, and my iPad.

     

    Earlier this afternoon, I was watching a video on the iMac when it suddenly stopped working.  I immediately reset the modem and the router which did nothing.  I realized that every other device was connect to the router and had an active internet connection.  For some reason, and with no warning, my newest computer (the iMac) just started self-assigning the IP address and acting like it couldn't see the router.  The iMac would connect to other, open WiFi hotspots in my neighborhood with no problem.

     

    I found this thread and started working my way through all the different solutions.  Only one of them worked - the suggestion to manually set everything up and mimic the settings of a working connection on another machine.  I still had a problem, though.  I use my iMac to RDP into my work PC since I prefer to work on the Mac and use it as my primary computer during the day.  Setting everything up manually, although it gave me an active internet connection again, did not allow me to RDP into my work laptop.  So frustrated!

     

    SOLUTION (that worked in my very specific case):

    I logged into the router from my MacBook Air since it was connected with no problem.  I poked around in the settings there a bit and finally decided to use the setting in the Navigation Panel to Reboot the Router.  Now keep in mind that I had manually unplugged and rebooted the router that way at least 10 times over the course of the afternoon, and it never seemed to make a difference.  Doing it this way, though, from within the router finally worked.  I could immediately tell that something was different, and the iMac connected to the router and established a working IP address!

     

    I hope this will help someone else!

  • Reid1801 Level 1 Level 1 (0 points)

    I solved the problem, at least for the moment, by buying a new wi-fi router to replace my old no-wi-fi modem.  Now my iPad talks directly to the new router.  It still refuses to talk to my iMac's wi-fi, even after employing the services of techie for two hours.  Essentially, because Apple hasn't fixed the 169 bug, I've had to spend several hundred dollars on a work-around.  Thanks for that, Apple.

  • spencefromwashington Level 1 Level 1 (0 points)

    Long time listener, first time caller.  I ran into the self-assigned IP issue a few days ago and have tried nearly everything in this post (and others) but still can’t get online.  I also spent 2 hours on the phone with Apple tech support who, at the end of the call, suggested I get a network expert to look at my configuration.  So frustrating. 

     

    Network Configuration: I’ve had this configuration set up for about 2 years with no issues.  I have a Verizon FIOS router and a time capsule as well as several networked (via Ethernet) devices that connect via a 16-port Netgear switch. Current configuration is Ethernet cable from LAN port on FIOS router to the WAN port on the Time capsule. Separate Ethernet cable from one of the Ethernet ports on my time capsule to the switch in my basement. Separate Ethernet cable runs from the switch in the basement up to my iMac. Wifi is switched off on my FIOS router. I use my time capsule for backups and for wifi.  I use Ethernet, not/not wifi to go online from my imac. 

     

    Current situation: The issue began when I clicked “renew DHCP lease” a few days ago.  Ever since then I continually get a self-assigned IP on my iMac and I’m unable to connect to the internet via Ethernet.  When I turn on wifi on my iMac it connects and I’m able to get online. This, to me, suggests the Fios router and the time capsule are communicating appropriately.  (iphones and ipads also connect via wifi to the time capsule.)  In addition, when I directly connect my iMac into the FIOS router (with time capsule and Ethernet switch disconnected) I get a normal IP and am able to connect to the internet via ethernet.  Furthermore, when I connect my iMac directly to the Ethernet port on the time capsule, I am also able to connect to the internet via Ethernet. 

     

    I’ve power cycled the Fios router and tried resetting to factory defaults.  I’ve also power cycled the switch and reset the time capsule. Nothing seems to be working. The only thing left that I can think of is to try a new Ethernet switch in case that is what’s preventing the iMac from getting a valid IP.  I’d welcome any other thoughts/ideas to try.