Previous 1 2 3 4 Next 176 Replies Latest reply: Jul 13, 2015 3:01 PM by harrynmalone Go to original post Branched to a new discussion.
  • m7med4ever Level 1 Level 1 (0 points)

    simply,

    1- change DHCP to DHCP with manually address

    2-enter new ipaddres

    3-reset to DHCP again

  • ryanhaldy Level 1 Level 1 (0 points)

    This solution is not working for me. The random string in the DHCP worked once but has not worked since. Any other ideas? Would replacing the network card have an effect or is it software/settings issue?

  • ericdy Level 1 Level 1 (0 points)

    Hi have you tried deleting the keychain password as described earlier in the thread?  I had previously tried all the other methods and the problem kept recurring until that solution and I have been fine since.

  • ryanhaldy Level 1 Level 1 (0 points)

    Yes I deleted the network and my keychain passwords. I did it again a second time today just to be sure, still no connection. I used time machine to go back a few months and that didn't help either.

     

    SO FRUSTRATED! Is anybody else still disconnected with the self assigned ip address? Any news from Apple on a fix? Maybe Mountain Lion will fix it, if I'm able to get connected so I can even upgrade!

  • Tm1488 Level 1 Level 1 (0 points)

    Having the same problem. Have done all of the above suggestions. Have even tried hooking Ethernet to computer and still get self assigned ip address message. It's so frustrating. I work from home and am losing $ every minute I can't get online. Any other suggestions??

  • nickee812 Level 1 Level 1 (5 points)

    You should get a model that is something like EnGenius ESR9850. It aslo happened to me but when I bought the router, it worked fine.

  • ryanhaldy Level 1 Level 1 (0 points)

    I have CenturyLink and they claim I have to use their particular router for their service. I don't know if that is completely true, but it's what they tell me, so changing the router is not an option.

  • romache Level 1 Level 1 (0 points)

    I've had the same issue and tried all of the described methods to no avail. Then I've found mentions of firewall blocking airport from obtaining ip address from dhcp server here and here and it was it. Basically what I did was:

    1. turn firewall off (allow all connections);
    2. turn airport off;
    3. turn airport on - see how ip address is properly get;
    4. turn firewall on.

    Hope it helps.

  • sanchay Level 1 Level 1 (0 points)

    I had the same problem on mac lion 10.7.4.

     

    The solution mentioned in this thread didn't help.

     

    Then I solved it with a Keychain repair. Before using Keychain, I turned the wifi off.

     

    1. Open Keychain Access

    2. Select the "Keychain Access" menu item.

    3. Select "Keychain First Aid"

    4. Enter your password, select "Repair" and click "Start".

     

    After completion, I turned the wifi back on again and my mac was able to connect properly to the network.

     

    Hope this helps.

  • SLSROACH Level 1 Level 1 (0 points)

    My situation is slightly different, in that I use my Mac as my wifi router via my Airport. So, my Mac is connected to internet via ethernet, and then I have airport turned on and my other devices connect to internet through the Mac.  What is even stranger was that I was ON the internet on my PC when suddenly I could not connect to the internet anymore.  So, it was working one moment, and then not working the next.

     

    I have tried all the fixes listed in this forum and everywhere I can find on Google and in Apple support, but nothing works.  I am running OS10.5.8.  It is very discouraging to read about such an extensive problem that has no real solution.  Has anyone come up with anything new in the last week, since the last post here?

     

    Sheri

  • snoodis Level 1 Level 1 (0 points)

    Thank you Ericdy,

     

    a solution that works.

     

    x Craig

  • oiser Level 1 Level 1 (0 points)

    Thank you very much,

    This solution fixed my problem!

  • sliqjonz Level 1 Level 1 (0 points)

    I've tried all of these suggestions and I stil can't connect

  • ryanhaldy Level 1 Level 1 (0 points)

    None of the suggestions have worked for me either, still have the self assigned error.

     

    Has anyone updated to Mountain Lion to see if that fixes it?

  • MrNinja Level 1 Level 1 (0 points)

    Hi

     

    I am running 10.7.4 and my MacBook Pro won't get any IP address via DHCP on wifi.

     

    If I reboot into win 7 boot camp wifi works fine.

     

    I have made sure the firewall is off, I've cleared the keychain, set the DHCP ID, tried connecting to differemt routers and networksetc.

     

    If I set an address manually things work, but its very difficult guess DNS server addresses.

     

    Its just like the dhcp service on Mac OS X isn't working.

     

    Extremely frustrating. If I admit defeat and go to an Apple shop and talk to one of their techs I will get even more frustrated as they never know how to fix any thing even slightly technical - in my experience.

     

    Please help. I was in the middle of downloading Mountain Lion too when it stopped working. Started downloading at work, came home and no more DHCP.

     

    Liam

Previous 1 2 3 4 Next