Previous 1 8 9 10 11 12 Next 175 Replies Latest reply: Mar 25, 2015 7:12 PM by Motorcycle Michael Go to original post
  • Azusa_ Level 1 Level 1 (0 points)

    Thank you! Thank you a lot! This is the second time this problem happend while I'm traveling (which is pretty critical) and the solution which has worked last time didnt so I was totally terrified. But thanks to you it solved!

  • ralphy Level 1 Level 1 (0 points)

    .

    Thanks ericdy

     

    Yes, I had the same annoying problem:

    Quote:

    "Wi-Fi has the self-assigned IP address …….. and will not be able to connect to the Internet."

     

    The remedy by ericdy on page one sorted it out.

     

    Thanks for that.

     

  • unsubscriber Level 1 Level 1 (0 points)

    OK, so I hit this problem yesterday and I thought it was just one friend's mac. This morning I found that several macs were having the same problem on wifi. (Ethernet was OK, but not wifi.) I have SOLVED it for me - so here's the info in case it helps!

     

    NB - I have tried most of the solutions on most of the help threads. (Once, years ago, I had the same problem, and one of the fixes I found back then did work. I think it was either deleting the  wifi setting from Network Preferences or fixing the keychain or both. But this time, those fixes were achieving nothing.)

     

    Anyway, the solution was simple! My modem-router included a setting for its DHCP server that was limited to 20 addresses. In other words, it was offering addresses from 192.168.1.1 to 192.168.1.20.  At first I dismissed that possibility, since you'd think 20 would be plenty for one house! However, I was very wrong. Here's why.

     

    1. Yes, we do own several Macs, and some of these are connected by ethernet AND wifi, so those ones use two addresses each.

    2. Yes, we own several iPhones, iPods, an AppleTV etc.

    3. Yes, we had visitors in the house. My daughter's friend had brought her iPad; my parents had brought their laptops and their phones!

    4. I have an Airport Extreme and a Time Capsule, both connected (in Bridge Mode) to the modem-router, so that's two more addresses.

    5. Remember that DHCP leases last for 24 hours (or whatever your router is set to), so even when visitors are gone or machines are turned off, those addresses might not become free.

     

    SOLUTION? I changed the router's setting to offer all addresses up to 192.168.1.40. (I might even go back and offer even more than 40 - no reason why not).

     

    My wifi macs had no trouble from that point. Hope this helps!

     

    [NB - The reason my ethernet was always OK was that those connections had been running a long time. But if an Ethernet connection had gone down, and I had reconnected it at a time when its address had been stolen by another device, then I likely would have hit the same "self-assigned IP" error. In other words, in my case I don't believe the issue made any real distinction between wireless and wired connections.]

  • ralphy Level 1 Level 1 (0 points)

    .

    Thanks ericdy

     

    I reported earlier that ericdy had solved my problem (page one).  But it kept coming back again and again.

     

    Ok, I think I have a solution now.  Before you do ericdy's solution, delete all the multiple locations (I had six locations)

     

    >>System preferences  >>Network  >>Location drop-down   >>edit locations

     

    Delete all the locations. Then do ericdy's reset.  Then it might work.

     

    Grrrrrr to Apple.

  • ralphy Level 1 Level 1 (0 points)

    .

     

    Ok, back again.  That fix lasted all of one day, then back to the normal "self-assigned IP address" routine.

     

    Grrrrr.

     

     

    I went through each fix, one by one.  This one appears to be holding up for three days now.

     

    By jcdill on page 5:

    a.  Open your   >>Preferences   >>network settings  >>Advanced   >>TCP/IP tab for your wifi connection.  The bad IP address is on line two. 


    b.  In the TCP/IP tab click "refresh DHCP" until it refreshes to empty (no IP address). (Try with new client ID or ID empty, wifi on or wifi off.)  -  I had to hit 'refresh' nearly 20 times before it was empty.


    c.  Eventually, you will get the IPv4 Address to be empty.  Stick with that.  Press 'OK' and 'Apply', and try to reconnect with the router in the normal manner.



    .

     

     

    I hope this is a permanent fix, because this is B annoying.  Especially as my two iPads have had no problem whatsoever with this router…. !!!

     

     

    Cheers,

    Ralph



  • ralphy Level 1 Level 1 (0 points)

    Grrrrrrrr.  Back to square one, and locked out of my router. 

     

    i have resorted to a 25m ethernet cable, to link to the router, which works fine. But why is technology going backwards, to cables??

     

    Does Apple not have an answer to this problem yet?  And this is not a router problem, it is an Apple problem.

     

    I have two ipads that will talk to the router.

    I have a signal booster that will connect to the router, and both ipads will happily talk to the booster.

     

    I used to have an iMac that would talk to both for a year.

    But it first stopped talking to the booster, and now it has stopped talking to the router too.

     

    What is going on here, Apple??

  • sjaiman Level 1 Level 1 (0 points)

    Maybe clearing the keychain is the trick but what worked for me was "safe boot" the mac, connect to wifi.  This should work.  This would modify your wifi settings for the access point you are trying to access.  Re-boot.

     

    PS.  To "safe boot" the MAC, press the "shift" key while the system is booting.

  • EmConn Level 1 Level 1 (0 points)

    Background: A few days ago a number of laptops/computers internet stopped working. Both PC and my MacBook pro. Now, a few days later, all the PCs have managed to connect by either changing the IP Address or other methods. We have changed the router as our technician thought that was the problem. My mac is still not able to connect.

     

    Methods i've already tried: Changing the IP Address, deleting the memory of the network in keychain access, system preferences>network, configuring IPv4 manually, using DHCP and renewing DHCP lease, deleting the WiFi network in system preferences and restarting before making a new one.
    Basically, everything i've read in forums, i've tried and nothing is working. Other than the methods i've seen, it seems to me that it's a problem with the router but as that was changed yesterday I don't see why it would be a problem.
    Also, because there were a number of computers that had the same problem and the others have now been fixed, I don't understand...

     

    Any more options would be greatly appreciated because though I can borrow other peoples laptops for internet, it would be much more convenient to use my own.

     

    Also, is this a problem that will affect connecting only with that network or will it still be an issue connecting to other networks? If it's only on this network, I will worry less as in 3 weeks I will move home to England and not have to worry about this network again. I can probably survive 3 weeks without a connection here but will still be frustrated.

  • jahjahjah Level 1 Level 1 (0 points)

    As I posted before, my description could have matched yours.  For me, it turned out that I had a switch between the router and my Macbook (and other devices).  All of them worked except the macbook.  Swapping in another router cured it for everything except the macbook,  Then I remembered the switch and power cycling that immediately fixed the error with the macbook.  You must have at least one other friend with a router/swicth you can plug into to see if the problem is persistent on all networks.

  • EmConn Level 1 Level 1 (0 points)

    Thanks for the reply jahjahjah.
    Do you mean trying to use a different router all together? What do you mean by power cycling? I am currently living in Indonesia and don't really have access to another router/switch (though i don't think i'm clear on exactly what a switch is?)

  • jahjahjah Level 1 Level 1 (0 points)

    Routers are connected to 2 networks, typically a WAN (wide area network-internet) and a LAN (local network).  A switch is essentially a hub for connecting nodes on a network with more intelligence than a simple hub about what's hooked to each port.  Most routers that are not server based have a switch incorporated in them so you can connect nodes (PC, printers, etc) to them directly but it is very common to have one or more other switches in a network between the router and your PC.  In my case, the router caused a problem in the switch down stream from the router, upstream from my macbook.  Since I had forgotten about that switch, I spend hours trying to find the problem on my macbook when a simple power cycling (unplug the power to the switch for a minute or so and then plug back in - do this instead even if the unit has a power switch) cured the problem.

    Making a lot of configuration changes on the mac is risky because you do not know that something you tried hasn't broken the ability to connect as well and when you find the solution, you won't know it when you try it.  Try to reverse anything you do that does not help before trying something else.

  • Dr Ethan Level 1 Level 1 (0 points)

    I had the same problem on just some of my networks (specifically at work) and it was very frustrating.  I tried all the other solutions posted here and none worked.  I am using Norton for mac and found that Norton Firewall was blocking the internet connection from my work's network.  Goto Firewall Status in Norton and if you see a red X for your Network, if so, try clicking on this and "allowing" connections from this Network.  This solved my problem, the other solutions on the page did not.

  • jahjahjah Level 1 Level 1 (0 points)

    Well, of course, if you run Norton on a Mac or a PC, for that matter, you'll have lots of problems that will eventually resolve in the removal of Norton.

  • aliciamy Level 1 Level 1 (0 points)

    I have this problem today for the first time and I tried several solutions proposed here by other users but nothing worked.

     

    What it worked was the following:

    Network Preferences

    Advance

    TCP/IP

    DHCP with manual address

    Type an IP from other computer that is using the same network

    Change the last digit of the IP you chose (two users don't use the same IP)

  • jahjahjah Level 1 Level 1 (0 points)

    I hope you went to the DHCP server and exempted the address you used.  You said you had at least one other computer, assumedly also a DHCP client, on your network so there is a chance it will get assigned the same address as the static address you assigned to your MAC.