Previous 1 2 3 4 5 Next 190 Replies Latest reply: May 4, 2016 3:22 PM by JohnGlasgow Go to original post Branched to a new discussion.
  • MrNinja Level 1 Level 1

    As an update to my issue.


    It would seem DHCP ( & possibly DNS too) is totally dead for my user account.


    If I run nslookup and manually enter a known DNS server IP address to query for hostsnames - no results come back - it just times out.


    If I start as the Safari user then i can logon to wifi and get and IP address fine. It also works fine from a Boot Camp OS and if I set a Virtual Machine in Fusion to bridged networking it can also get a DHCP address.


    At the moment I have a feeling a file permission could be broken - but I've run the verify and fix permissions in Disk Utility which did not help. I've run a disk check this morning and no errors were found.


    ********* Odd thing just happened, right this very second, as I'm typing this message inside a Windows XP Virtual Machine running on my 'broken' Mac OS. It has all started working again ... extremely bizarre.


    DHCP works - DNS works. The world is good again. If I get to the bottom of the problem I will post an update.



  • condor9 Level 1 Level 1

    i am one of the many hundreds victims of this unbelivable nigthmare "self assigned ip" who finally got a solution with this trick.

    Hope this work for others as well. By the way .. do you have an explanation for this lack of serious answer from Apple???

    best regards

  • SLSROACH Level 1 Level 1

    Which solution was that?

  • peeke Level 1 Level 1



    This did the trick.

    I was getting self-assigned ip addresses on Airport as well as on Ethernet.


    romache wrote:


    I've had the same issue and tried all of the described methods to no avail. Then I've found mentions of firewall blocking airport from obtaining ip address from dhcp server here and here and it was it. Basically what I did was:

    1. turn firewall off (allow all connections);
    2. turn airport off;
    3. turn airport on - see how ip address is properly get;
    4. turn firewall on.

    Hope it helps.

    Thank you very much !



  • dman083 Level 1 Level 1

    I have the same problem as well.  I have tried everything as you have to no avail.  I interested to see if you have made progress at all.

  • dman083 Level 1 Level 1

    Sorry, meant to clarify that my post was directed towards mrninja

  • MrNinja Level 1 Level 1

    Hi dman083.


    I have progress in that it randomly started working.


    Unfortunately it started working before I could trace the source of the problem. Except that I'd narrowed it down to my user account.


    Try rebooting to your 'guest' / Safari account and see if you can attach to the wifi and get on the Internet. At least that proves that the Mac OS install is functional.


    If that works I have seen some people advocate creating a new user account and migrating your data across. I wouldn't do that though I'd rather track down the problem.


    Also try a hard wire network cable and see if you can get an IP via ethernet. I'd be interested to know if this does or doesn't work, while the problem is manifesting itself, as this would help track down where the issue is.



  • Fiskepinner Level 1 Level 1

    I tried everything. Deleting files, resetting all kinds of stuff, making new locations in airport, etc.


    If none of that worked for you either, the real problem is a combination of your router and your OS (I'm on 10.6.8)


    So the problem is that your router has a WEP password to connect to it and it doesn't work well with your OS. I found this post that explained it well:


    "What happened is that my Imac 27 (10.6.8) wasn't recognising the modem

    security setting and therefore the DHCP could not properly assign a

    valid IP (..a friend actually explained me that..). To know if that is

    really your case, click in the airport icon on the top right of your

    screen (the radar like icon) with the "Option" button pressed. Right

    bellow the network you are trying to connect it will appear some further

    settings like "PHY Mode", "BSSID", "Channel" and finally "Security".

    In my case, even though there was a required password to log in the

    network, "security" was being shown as "none". So I got in the modem

    through a flatmate computer and changed the password system from WEP to

    WPA2. As simple as that."

    (source: -in-mac-os-x-video-how-to/p3


    So the solution is that you connect to your router and change the password to a WPA type password, but it is really enough just to remove the password protection, and then it works right away.


    I hope this helps!

  • jkaps90 Level 1 Level 1

    Here is what worked for me.  I tried all the complex things people on this forum have suggested to no avail.  It turns out it was a very simple fix. I simply unplugged the router from the back and left it unplugged for about 60 seconds. Then, I plugged it back it. Problem solved. It seems almost too simple but try it out. For an explanation of why, check out Tatiana's post here ( -in-mac-os-x-video-how-to/p3)

  • Jim_ Crawford Level 2 Level 2

    Ok, so I had the same problem, tried all of these things to no avail.  Then i went to the airport utility, network.  Found that the router was "Off - in Bridge Mode".  I switched it back to "DHCP and Nat" and boom!  Problem was instantly gone.  Hope this works for you guys. . . . JC

  • handren Level 1 Level 1

    Hi, all! I had the same problem too, and I had tried all the things, but it does't work. It is so unbelievable. I set up my phone as a Wi-Fi hotspot, my mac connect it successfully, but try to connect my router, it get self-assigned IP problem~ what is the matter with my mac?

  • Louisenyc Level 1 Level 1

    Hi, so I wanted to share because I had the same problem over the past coule of days wiht "the airport having a self-assigned IP address and cannot connect to the internet". I tried everything on this blog and nothing worked. Frustrated out of my mind, I did a factory reset on my router and set it up from scratch and Voila', the airport/wireless started working again with a correct IP address!!

  • CammoP Level 1 Level 1

    I've tried all the above with no luck.  Went into the apple store today and spoke to a 'genius'....he had no idea what i was talking about or how to fix it - after getting on google he suggested i call apple support!  Just glad im not the only one out there with this problem but it is driving me insaaaaane!

  • mathetes- Level 1 Level 1

    So, I had this problem yesterday.  I have other machines on this network, my partner's PC and my ipad and iphone, so I knew the problem was with my mac.Tried almost all the solutions here and still got "self assigned ip." I did have dropbox running, and since dropbox tries to connect to the internet to sync, I thought I'll see what happens if I quit it. Once I shut down dropbox, I followed the password oriented suggestions here: turned airport off, deleted the network (don't forget to "apply"; I forgot the first time), deleted key chain password, and after turning airport back on – voila! This solution did *not* work for me when dropbox was running. So if you have the same problem and none of the solutions work, check if you have this kind of silent, internet-dependent app running in the back – it might combine with whatever's wrong with the password settings (still don't understand how that went wrong) to make things worse.

  • CammoP Level 1 Level 1

    Ive tried many solutions over the last couple of days with no luck.  Tonight i seemed to have solved my problem just trying different things.  The one that finally worked was:


    1. Turn Wifi off

    2. Go to Internet sharing

    3. Turn sharing off

    4. Turn sharing back on creating a new network

    5. Turn wifi back on.

    6. Reboot

    7. Fixed!!


    Not sure if the reboot was necessary.  Fingers crossed this now solves the problem for good.


    By the way... the WIFI settings on my mac still say "Wifi has the self-assinged IP address and will not be able to connect ot the internet' but all devices are connecting fast and without problems.  I dont plan on touching any other settings until i have to!

Previous 1 2 3 4 5 Next